[RISOLTO] Problema Mount File System NTFS read-write

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Unicondor
Linux 1.x
Linux 1.x
Messaggi: 147
Iscritto il: mar 30 nov 2004, 0:00
Slackware: 13.1
Kernel: 2.6.37.6
Località: Potenza
Contatta:

[RISOLTO] Problema Mount File System NTFS read-write

Messaggio da Unicondor »

Salve ragazzi,

Ho uno strano problema quando vado a montare la partizione NTFS del mio disco IDE per effettuare il backup dei dati. Avvio l'installazione di Slackware 13.1 e da shell digito

Codice: Seleziona tutto

mount -t ntfs /dev/sda1 /win

Dove /dev/sda1 e' il mio vecchio disco con NTFS

Se provo a creare una directory sopra, anche se il filesystem e' montato in lettura-scrittura (rw)

Codice: Seleziona tutto

#mount

/dev/sda1 on /root/win type ntfs (rw)
ho sempre un problema che mi dice che il filesystem e' in sola lettura..

Codice: Seleziona tutto

#mkdir pp
mkdir: cannot create directory 'pp' : Read-only File system
Da cosa puo' dipendere questo strano problema?

vi ringrazio in anticipo

P.s. ho provato anche con il flag

Codice: Seleziona tutto

 mount -o rw


ma nulla

Flavio
Ultima modifica di Unicondor il ven 11 feb 2011, 18:48, modificato 1 volta in totale.

Avatar utente
krisis
Linux 4.x
Linux 4.x
Messaggi: 1120
Iscritto il: mar 25 gen 2005, 0:00
Distribuzione: debian
Località: Roma

Re: Problema Mount File System NTFS read-write

Messaggio da krisis »

Forse il modulo ntfs nel kernel huge non è compilato con l'opzione di scrittura.
Quindi mount riesce a passargli l'opzione ma poi il kernel si rifiuta di scrivere.
Le poche volte che ho dovuto usare una partizione ntfs da linux ho usato il modulo fuse che non credo sia presente in fase di installazione di slackware.
Oppure il filsystem si trova in uno stato inconsistente e devi eseguire uno scandisk da windows.
Ti conviene fare il backup prima di installare.

Avatar utente
matzu
Linux 2.x
Linux 2.x
Messaggi: 217
Iscritto il: dom 20 set 2009, 2:26
Nome Cognome: Franco
Slackware: 64-13.37 13.1
Kernel: generic
Desktop: kde

Re: Problema Mount File System NTFS read-write

Messaggio da matzu »

Usa

Codice: Seleziona tutto

-t ntfs-3g
ntfs è il driver del kernel e non consente mount in scrittura, mentre ntfs-3g è user space e consente rw anche da utenti diversi da root (vedi 'man ntfs-3g')

Avatar utente
waka_jawaka
Linux 3.x
Linux 3.x
Messaggi: 781
Iscritto il: mer 10 ago 2005, 0:00
Nome Cognome: Alberto Palillo
Kernel: 2.6.35
Desktop: KDE 4.5
Distribuzione: Archlinux

Re: Problema Mount File System NTFS read-write

Messaggio da waka_jawaka »

il modulo r/w per il filesystem ntfs è ntfs-3g. È presente nel dvd di installazione di slackware e richiede fuse.
http://www.tuxera.com/community/ntfs-3g-manual/ (sito un po' traballante)
Ciao

Post superfluo, bruciato da quello di matzu

Unicondor
Linux 1.x
Linux 1.x
Messaggi: 147
Iscritto il: mar 30 nov 2004, 0:00
Slackware: 13.1
Kernel: 2.6.37.6
Località: Potenza
Contatta:

Re: Problema Mount File System NTFS read-write

Messaggio da Unicondor »

Grazie alla mia adsl 640Kb, ho scaricato solo la ISO install-d1.. che ovviamente non ha il FUSE come pacchetto :(

infatti provai ad usare il comando

Codice: Seleziona tutto

 -t ntfs-3g 


ma non mi riconosceva il tipo di file system...

Grazie per le risposte... mi tocca aspettare 16 ore di download per poter sistemare la cosa.

Come sempre siete velocissimi a trovare le risposte alle mie sempre maggiori difficolta' :P

Flavio

Rispondi