Pagina 1 di 1

Slackware su vecchio server Olivetti Netstrada 460RS

Inviato: mar feb 28, 2012 19:15
da pippo
Salve a tutti, ho conosciuto slackware alcuni anni fa ma la uso quotidianamente solo da un paio per cui scusatemi se non ho ancora molta dimestichezza con il mondo Linux.
Mi è stato chiesto di installare Linux su un vecchio server Olivetti Netstrada 460RS basato su 4 cpu Pentium PRO, 512 MB di ram e chipset Intel Orion 450.
Semplificando al massimo la macchina ha solo controller e periferiche di tipo scsi (no ide no USB) + una VGA, seriali e lpt.
Il nastro, il cd, il masterizzatore sono pilotati dal controller scsi onboard (un Adaptec AIC 7870).
Per gestire i 6 hd SCSI (Raid 5) posso scegliere se usare un controller DTP 4333UW o un IBM Serveraid II.
Vista la limitatezza dell'hw sarei orientato ad installare una vecchia release (10.1, 10.2 al max 12.0), non importa la sicurezza in quanto verrà usato come postazione di scansione (3-4 scanner scsi).
L'hw è ok in quanto testato pezzo a pezzo singolarmente ( e poi prima funzionava... forse con NT o con qualche versione Unix di Olivetti)

I problemi nascono durante l'installazione: con qualunque kernel della serie .i non vengono riconosciute le periferiche scsi = sono fermo
Se scelgo adaptec.s riesco a vedere le periferiche su scsi onboard ma non i dischi su ctrl raid (sia che scelga IBM sia DTP) = Idem come sopra (sono fermo)
Se scelgo il kernel raid.s riesco a partizionare i dischi (se uso il ctrl IBM) ma nella fase di copia da cd a hd non viene più visto il cd sorgente = uffa, sono fermo al quadrato
Se scelgo raid1.s insieme al ctrl DTP ed uso il protocollo EATA-DMA riesco ad installare (almeno credo) il sistema e mi fa tutte le domande su come configurare rete ecc. ecc. ma, dopo il riavvio non fa boot neppure da floppy... = arifermo

Se ho capito bene il mio problema sta nel fatto che dovendo scegliere un kernel all'inizio dell'installazione, se quest'ultimo non supporta TUTTE le periferiche con cui devo interagire durante l'installazione... sono fregato.

Qualcuno (mi rivolgo a quelli che hanno qualche anno in più) ha mai affrontato una situazione simile?
Anche se qualcuno può obiettare che la macchina non vale la fatica la sto prendendo come sfida personale nei confronti di colleghi "mswindows" e ci terrei a almeno a completare l'installazione.
Un sincero grazie a tutti quelli che mi vorranno dare informazioni su come procedere.

Re: Slackware su vecchio server Olivetti Netstrada 460RS

Inviato: mar feb 28, 2012 23:44
da murdock
Così a spanne mi sembra che usare il kernel raid1.s sia la cosa da fare.
Probabilmente però poi subentra qualche problema in fase di boot.
Una volta installato il sistema farei una configurazione manuale di lilo.conf controllando che i parametri siano corretti.
Oppure avvierei da cdrom e farei lo stesso via chroot.
Ottenuto il sistema bootabile e funzionante, ricompilerei il kernel con quanto serve per la macchina in questione.

Saluti,
MuRdOcK

Re: Slackware su vecchio server Olivetti Netstrada 460RS

Inviato: mer feb 29, 2012 11:53
da pippo
Grazie Murdock del consiglio, un dubbio: nella fase di scelta del kernel (la fase iniziale cui chiede di inserire parametri aggiuntivi sulla riga) dovrei inserire qualche parametro particolare? (non ho la più pallida idea di quali possano essere...)
Per la configurazione manuale di lilo proverò a controllare ciascun passo della configurazione
Per chroot credo di non avere le conoscenze... se necessario studierò

Grazie di nuovo
Pippo

Re: Slackware su vecchio server Olivetti Netstrada 460RS

Inviato: mer feb 29, 2012 14:51
da murdock
Non penso siano necessari parametri aggiuntivi, allo stato delle cose. ;)

Saluti,
MuRdOcK