Pagina 1 di 1

G+ e Problemi con pulseaudio

Inviato: mer ago 28, 2013 16:43
da RedSkull92
Dato che per fare un hangout e far funzionare il microfono ho bisogno di pulseaudio ho deciso di installarlo ma con poco successo.

In rete si trova tutto e nulla, non so dove sbattere la testa.
Ho installato la versione 2.0

Quando provo ad avviare pulseaudio via
sudo sh /etc/rc.d/rc.pulseaudio start


Mi viene restituito
Starting pulseaudio...
No protocol specified
E: [pulseaudio] client-conf-x11.c: xcb_connection_has_error() returned true

Ovviamente l'audio non si sente.
Questo è il mio asound.conf
pcm.pulse {
type pulse
}

ctl.pulse {
type pulse
}

pcm.!default {
type pulse
}
ctl.!default {
type pulse
}

e queste è la mia scheda audio
card 0: Intel [HDA Intel], device 0: ALC269VB Analog [ALC269VB Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0


Grazie per l'aiuto.

Re: G+ e Problemi con pulseaudio

Inviato: mer ago 28, 2013 17:21
da miklos
RedSkull92 ha scritto:Dato che per fare un hangout e far funzionare il microfono ho bisogno di pulseaudio ho deciso di installarlo ma con poco successo.
a me sta cosa nn risulta, o magari è cambiata da poco perchè io lo utilizzato fino a poco tempo fa senza alcun bisogno di pulseaudio. pero' ripeto potrebbe essere una cosa di recente introduzione.. oppure una tua esigenza specifica

comunque stando a questo post su linuxquestions, che mi sembra simile al tuo problema, potrebbe essere un problema di permessi ( a meno che non abbia usato lo slackbuild preso da slackbuilds.org)

Re: G+ e Problemi con pulseaudio

Inviato: mer ago 28, 2013 17:52
da RedSkull92
Io lessi in giro che per usare hangout avevo bisogno di pulseaudio (confermatomi da un altro utente).
Infatti la webcam si vedeva tranquillamente ma il microfono non dava segni di vita (quando invece con arecord o skype va tutto bene).
ho anche il plugin di gtalk installato quindi ho voluto provare a vedere se con pulseaudio la cosa si sistemava.

Ho usato sbopk per compilare ed installare pulseaudio, ho tutte le dipendenze ma quell'errore rimane.

(inoltre ora l'audio di skype non funge più)

Consigli ?

Re: G+ e Problemi con pulseaudio

Inviato: mer ago 28, 2013 18:03
da miklos
faro' una prova appena torno a casa e ti faccio sapere (relativamente alla necessità o meno di pulseaudio)
per il resto nn lo uso :( quindi ti sono di scarso aiuto

Re: G+ e Problemi con pulseaudio

Inviato: mer ago 28, 2013 21:04
da boh
L'ho usato l'ultima volta intorno al 25 luglio e oltre ad installare il plugin di google non ho dovuto fare altro.
Come hai installato il plugin?

Re: G+ e Problemi con pulseaudio

Inviato: mer ago 28, 2013 23:23
da hashbang
La directory /var/lib/pulse ha come owner pulse:pulse?

Per quanto riguarda l'audio, al posto di usare asound.conf, installa "alsa-plugins" e lascia ALSA come output di uscita nei software come MPlayer.

Anche io uso PulseAudio su Slackware (io comunque ho installato la 4.0) ed entrambi i problemi segnalati mi sono capitati, ma sono stati risolti immediatamente settando i permessi alla directory ed installando le alsa-plugins.

Re: G+ e Problemi con pulseaudio

Inviato: gio ago 29, 2013 2:15
da RedSkull92
boh ha scritto:L'ho usato l'ultima volta intorno al 25 luglio e oltre ad installare il plugin di google non ho dovuto fare altro.
Come hai installato il plugin?

Sempre da sbopkg, la webcam va, il microfono no.
Ho una -current. (ergo firefox è aggiornato)
hashbang ha scritto:La directory /var/lib/pulse ha come owner pulse:pulse?

Per quanto riguarda l'audio, al posto di usare asound.conf, installa "alsa-plugins" e lascia ALSA come output di uscita nei software come MPlayer.

Anche io uso PulseAudio su Slackware (io comunque ho installato la 4.0) ed entrambi i problemi segnalati mi sono capitati, ma sono stati risolti immediatamente settando i permessi alla directory ed installando le alsa-plugins.


Ho appena installato via Slackbuild la 4.0 ed ho provato ad avviarlo e:
┌─root@smagen:/home/dlion#
└─>sh /etc/rc.d/rc.pulseaudio start
Starting pulseaudio...
W: [pulseaudio] authkey.c: Failed to open cookie file '/var/lib/pulse/.config/pulse/cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to load authorization key '/var/lib/pulse/.config/pulse/cookie': No such file or directory
No protocol specified
E: [pulseaudio] client-conf-x11.c: xcb_connection_has_error() returned true

Mentre per i permessi il risultato è questo:
┌─root@smagen:/home/dlion#
└─>ls -al /var/lib/pulse/
total 40
drwx------ 3 pulse pulse 4096 Aug 28 15:33 .
drwxr-xr-x 35 root root 4096 Aug 20 23:11 ..
-rw-r--r-- 1 pulse pulse 10 Aug 28 16:12 25478ea561ef2434bb19fa3b00000034-default-sink
-rw-r--r-- 1 pulse pulse 18 Aug 28 16:12 25478ea561ef2434bb19fa3b00000034-default-source
-rw-r--r-- 1 pulse pulse 3198 Aug 28 15:33 25478ea561ef2434bb19fa3b00000034-device-volumes.x86_64-slackware-linux-gnu.gdbm
-rw-r--r-- 1 pulse pulse 3072 Aug 28 15:33 25478ea561ef2434bb19fa3b00000034-stream-volumes.x86_64-slackware-linux-gnu.gdbm
-rw------- 1 pulse pulse 16 May 1 02:55 .esd_auth
drwx------ 2 pulse pulse 4096 Aug 28 16:05 .pulse
-rw------- 1 pulse pulse 256 May 1 02:55 .pulse-cookie
-rw-r--r-- 1 pulse pulse 3729 Jul 18 2011 .screenrc


Alsa-plugins è già installato
alsa-plugins-1.0.26-x86_64-1_SBo


Che può essere ?

Re: G+ e Problemi con pulseaudio

Inviato: gio ago 29, 2013 2:28
da RedSkull92
Ho creato la directory .config/pulse/ ed ho copiato .pulse-cookie all'interno con il nome di cookie.
Ora mi restituisce questo:
Starting pulseaudio...
No protocol specified
E: [pulseaudio] client-conf-x11.c: xcb_connection_has_error() returned true

Ovviamente a cookie ho dato un bel
chown pulse:pulse cookie

Edit:
Quello slackbuild doveva avere dei problemi enormi.
ora mi dà:
┌─dlion@smagen:~%
└─> pulseaudio --start
W: [pulseaudio] core-util.c: Failed to open configuration file '/home/dlion/.config/pulse//daemon.conf': Permission denied
W: [pulseaudio] daemon-conf.c: Failed to open configuration file: Permission denied

Me lo passeresti lo slackbuild ?
Quello di slackbuild.org non funge :|

Re: G+ e Problemi con pulseaudio

Inviato: gio ago 29, 2013 9:14
da hashbang
RedSkull92 ha scritto:Quello slackbuild doveva avere dei problemi enormi.
ora mi dà:
┌─dlion@smagen:~%
└─> pulseaudio --start
W: [pulseaudio] core-util.c: Failed to open configuration file '/home/dlion/.config/pulse//daemon.conf': Permission denied
W: [pulseaudio] daemon-conf.c: Failed to open configuration file: Permission denied

Me lo passeresti lo slackbuild ?
Quello di slackbuild.org non funge :|
Lo farei se ce l'avessi.
Quando compilo per fatti miei non uso SlackBuild.
PulseAudio l'ho compilato a mano prendendo la configurazione dal PKGBUILD di Arch.
E non ho nemmeno il pacchetto da darti, dato che l'ho eliminato dopo l'installazione. #-o
Però c'è un pacchetto nel repository di Dropline GNOME (anche se è per la 14.0 e non per -current).

Comunque quelli sono dei Warning. Non dovrebbero inficiare il funzionamento dell'applicazione.
Dai un

Codice: Seleziona tutto

$ pgrep pulseaudio

Se dopo aver dato pulseaudio --start, trovi il PID allora vuol dire che il demone è partito.

Re: G+ e Problemi con pulseaudio

Inviato: gio ago 29, 2013 14:19
da RedSkull92
Installando il pacchetto da te segnalato ed avviandolo mi dà questo errore:
pulseaudio: error while loading shared libraries: libjson-c.so.2: cannot open shared object file: No such file or directory


Pur avendo installato json-c
json-c-0.10-x86_64-2gv
json-c-compat32-0.9-x86_64-1_SBocompat32


:|

Mentre per quanto riguarda il plugin di gtalk ? Voi da dove l'avete preso ?
Che versione avete ?

Re: G+ e Problemi con pulseaudio

Inviato: gio ago 29, 2013 14:42
da hashbang
RedSkull92 ha scritto:Installando il pacchetto da te segnalato ed avviandolo mi dà questo errore:
pulseaudio: error while loading shared libraries: libjson-c.so.2: cannot open shared object file: No such file or directory


Pur avendo installato json-c
json-c-0.10-x86_64-2gv
json-c-compat32-0.9-x86_64-1_SBocompat32

:|
Direi che è normale, visto che sono versioni diverse.
la json-c richiesta dal pacchetto segnalato è la 0.11, mentre quella installata è la 0.10.

Mentre per quanto riguarda il plugin di gtalk ? Voi da dove l'avete preso ?
Che versione avete ?
Non uso quel plugin.

Re: G+ e Problemi con pulseaudio

Inviato: gio ago 29, 2013 16:54
da RedSkull92
Perfetto, ho installato entrambi i pacchetti e mi dà
┌─dlion@smagen:~%
└─> pulseaudio --start
W: [pulseaudio] authkey.c: Failed to open cookie file '/home/dlion/.config/pulse/cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to load authorization key '/home/dlion/.config/pulse/cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to open cookie file '/home/dlion/.pulse-cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to load authorization key '/home/dlion/.pulse-cookie': No such file or directory
┌─dlion@smagen:~%
└─> pgrep pulseaudio
5001


Ora, come faccio a capire se funge ?

Quindi mi stai dicendo che fai hangout senza gtalk-plugin ?

Re: G+ e Problemi con pulseaudio

Inviato: gio ago 29, 2013 16:58
da hashbang
Adesso direi di dare un pulseaudio --kill e di avviare il demone tramite servizio di INIT.

Una volta fatto, avvia MPlayer e, dopo aver controllato se l'uscita è ALSA, fai partire un file audio.

Nel mio caso, quando PulseAudio è presente, l'audio si sente diversamente rispetto all'uso di ALSA puro.

Re: G+ e Problemi con pulseaudio

Inviato: gio ago 29, 2013 17:44
da boh
RedSkull92 ha scritto:Mentre per quanto riguarda il plugin di gtalk ? Voi da dove l'avete preso ?
Che versione avete ?


Io ho scaricato il pacchetto RPM, l'ho convertito con rpm2tgz (mi sembra ci sia anche rpm2txz, ma cambia solo la compressione ovviamente) e l'ho installato. Ha funzionato tutto e subito.