Pagina 1 di 1

[Risolto]Problema dual boot Slackware-Salix: no init found

Inviato: sab feb 22, 2014 13:54
da Twenty-Seven
Ciao,
Su un portatile avevo installato Slackware come unco OS. Ho voluto provare ad installare anche Salix in dual boot. Durante l' installazione ho fatto sovrascrivere il LILO di Slackware con quello di Salix, con intenzione di entrare nel lilo.conf di Salix successivamente ed aggiungere la voce per far partire anche Slackware.

Il LILO di Salix era così configurato:

Codice: Seleziona tutto

image = /boot/vmlinuz   
  label = linux
  root = /dev/sda3
   read-only


Io ho sostanzialmete replicato i parametri, modificando la label e naturalmente mettendo la partizione di root /dev/sda1 di Slackware al posto di /dev/sda3.

Però Salix parte correttamente, ma Slackware, subito dopo aver iniziato il caricamento mi resttuisce il seguente errore:

Kernel Panic -not syncing: No init found. Try to passing init= option to kernel. Pid: 1, comm: ...

Qualcuno ha idea di come risolvere?

Grazie mille

Re: Problema con dual boot Slackware-Salix: no init found

Inviato: sab feb 22, 2014 14:42
da zoros
Da Salix vai in chroot su Slackware,
modifica lilo.conf per installare lilo (di Slackware) sul boot-record, piuttosto che sull'MBR

Codice: Seleziona tutto

boot = /dev/sda1

torna a Salix e aggiungi il lilo.conf

Codice: Seleziona tutto

other = /dev/sda1
  label = Slackware
  table = /dev/sda

e reinstalla lilo, ovviamente

Re: Problema con dual boot Slackware-Salix: no init found

Inviato: sab feb 22, 2014 16:41
da Twenty-Seven
Grazie mille zoros per la risposta. Però dopo che monto /dev/sda1 non mi fa fare il chroot, mi dice:

Codice: Seleziona tutto

impossibile eseguire il comando "/bin/bash" : Formato eseguibile non valido

Re: Problema con dual boot Slackware-Salix: no init found

Inviato: sab feb 22, 2014 17:02
da zoros
mah, avrai due sistemi, 32 e 64 bit
altre strade sono:

eseguire il lilo di Salix sulla partizione di Slackware, cioè da Salix:

Codice: Seleziona tutto

mount /dev/sda1 /mnt/dovevuoi
lilo  -r /mnt/dovevuoi
(ma non credo possa funzionare se hai 64 vs 32)
oppure:
avviare da DVD di installazione Slackware ed eseguire il chroot da lì.

Re: Problema con dual boot Slackware-Salix: no init found

Inviato: dom feb 23, 2014 10:28
da Twenty-Seven
Esatto, su quel pc ho Slackware a 64 bit, mentre Salix è a 32. Allora proverò a riscaricarmi il dvd di slackware e farò quell' operazione e vediamo come va. Per intanto grazie mille

Re: Problema con dual boot Slackware-Salix: no init found

Inviato: dom mar 02, 2014 19:10
da Twenty-Seven
Ho riscaricato la slackware 14.0_64 e l' ho fatta partire da usb. Ho fatto il chroot e scritto il lilo di slackware su sda1. Ha funzionato perfettamente!

Grazie mille