[NON RISOLTO]Problema connessione wireless Slackware 13.0

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Twenty-Seven
Linux 0.x
Linux 0.x
Messaggi: 99
Iscritto il: dom 27 gen 2013, 14:59
Slackware: 14.2
Kernel: 4.14.29
Desktop: Xfce

Re: Problema connessione wireless Slackware 13.0

Messaggio da Twenty-Seven »

Ho letto un po' sulla rete, a quanto pare il problema col wpa è dovuto al driver per le schede ralink 2x00 che non funziona benissimo

rik70
Iper Master
Iper Master
Messaggi: 2173
Iscritto il: gio 10 mar 2011, 9:21
Slackware: 64-current
Kernel: 5.6.x-ck1
Desktop: Xfce 4.14
Distribuzione: Arch Linux

Re: Problema connessione wireless Slackware 13.0

Messaggio da rik70 »

Twenty-Seven ha scritto:Ho letto un po' sulla rete, a quanto pare il problema col wpa è dovuto al driver per le schede ralink 2x00 che non funziona benissimo
Quale modulo del kernel sta utilizzando la scheda wifi?

Twenty-Seven
Linux 0.x
Linux 0.x
Messaggi: 99
Iscritto il: dom 27 gen 2013, 14:59
Slackware: 14.2
Kernel: 4.14.29
Desktop: Xfce

Re: Problema connessione wireless Slackware 13.0

Messaggio da Twenty-Seven »

Il modulo dovrebbe essere rt73usb

rik70
Iper Master
Iper Master
Messaggi: 2173
Iscritto il: gio 10 mar 2011, 9:21
Slackware: 64-current
Kernel: 5.6.x-ck1
Desktop: Xfce 4.14
Distribuzione: Arch Linux

Re: Problema connessione wireless Slackware 13.0

Messaggio da rik70 »

Twenty-Seven ha scritto:Il modulo dovrebbe essere rt73usb
Prova ad aggiungere l'opzione 'nohwcrypt=1'

Twenty-Seven
Linux 0.x
Linux 0.x
Messaggi: 99
Iscritto il: dom 27 gen 2013, 14:59
Slackware: 14.2
Kernel: 4.14.29
Desktop: Xfce

Re: Problema connessione wireless Slackware 13.0

Messaggio da Twenty-Seven »

Devo creare un file in /e tv con quella stringa?

rik70
Iper Master
Iper Master
Messaggi: 2173
Iscritto il: gio 10 mar 2011, 9:21
Slackware: 64-current
Kernel: 5.6.x-ck1
Desktop: Xfce 4.14
Distribuzione: Arch Linux

Re: Problema connessione wireless Slackware 13.0

Messaggio da rik70 »

Puoi provare prima di tutto al volo, senza dover riavviare.

Termina tutti i programmi che utilizzano la scheda wireless - network manager, wpa_supplicant, vari ed eventuali.

Poi fai:

Codice: Seleziona tutto

modprobe -vr rt73usb
Se non da errori:

Codice: Seleziona tutto

modprobe -v rt73usb nohwcrypt=1
e provi a connetterti con la chiave wpa.

Se funziona, rendi il tutto permanente creando un file '/etc/modprobe.d/rt73usb.conf' con dentro:

Codice: Seleziona tutto

options rt73usb nohwcrypt=1

Twenty-Seven
Linux 0.x
Linux 0.x
Messaggi: 99
Iscritto il: dom 27 gen 2013, 14:59
Slackware: 14.2
Kernel: 4.14.29
Desktop: Xfce

Re: Problema connessione wireless Slackware 13.0

Messaggio da Twenty-Seven »

purtroppo non funziona... comunque il problema di questo driver parrebbe essere che è sì inserito di default dal kernel 2.26, però per far funzionare correttamente la scheda ha bisogno di un firmware proprietario che non è incluso nel driver. Ho letto questa cosa su un tutorial per debian, infatti ho provato a scaricare una live di debian coi repository non-free già inclusi e la scheda funziona correttamente. Ho messo "non risolto" nel topic.

Rispondi