Pagina 1 di 1

14.2 su HD USB, problema al caricamento

Inviato: sab nov 18, 2017 18:03
da tigerwalk
Ciao a tutti,
Sono riuscito dopo molta fatica ad installare la 14.2 su un hd usb. Ho dovuto utilizzare la guida e lo script perché con l'una o con l'altro da soli non si riusciva. Comunque il problema è che all'avvio, si blocca in un certo punto con il messaggio
random: nonblocking pool is initialized
sta fermo li e non procede. Ho visto che avviene, subito dopo il riconoscimento dell' hd usb. Non c'è nessun messaggio di errore, resta solo immobile ed il caricamento non procede.

Re: 14.2 su HD USB, problema al caricamento

Inviato: dom nov 19, 2017 7:56
da tigerwalk
Di seguito il tree dell' /initrd che ho costruito, nel caso qualcuno notasse qualche errore/incongruenza o assenza di qualche modulo o file.

tigerwalk@darkstar~ $ tree /tmp/initrd/
/tmp/initrd/
├── bin
│ ├── ash -> busybox
│ ├── busybox
│ ├── echo -> busybox
│ ├── mount
│ ├── sleep -> busybox
│ ├── switch_root -> busybox
│ └── umount -> busybox
├── dev
│ ├── null
│ ├── sda1
│ ├── sdb1
│ ├── sdc1
│ ├── sdd1
│ ├── sde1
│ ├── sdf1
│ └── sdg1
├── etc
│ └── mtab
├── init
├── lib
│ ├── ld-linux.so.2
│ ├── libblkid.so.1
│ ├── libc.so.6
│ ├── libm.so.6
│ ├── libmount.so.1
│ ├── libpthread.so.0
│ ├── librt.so.1
│ ├── libuuid.so.1
│ └── modules
│ └── 4.4.88-smp
│ ├── kernel
│ │ └── drivers
│ │ └── usb
│ │ ├── host
│ │ │ ├── ehci-hcd.ko
│ │ │ ├── ehci-pci.ko
│ │ │ ├── ohci-hcd.ko
│ │ │ ├── uhci-hcd.ko
│ │ │ ├── xhci-hcd.ko
│ │ │ └── xhci-pci.ko
│ │ └── storage
│ │ └── usb-storage.ko
│ ├── modules.alias
│ ├── modules.alias.bin
│ ├── modules.builtin
│ ├── modules.builtin.bin
│ ├── modules.dep
│ ├── modules.dep.bin
│ ├── modules.devname
│ ├── modules.order
│ ├── modules.softdep
│ ├── modules.symbols
│ └── modules.symbols.bin
├── mnt
├── proc
└── sbin
└── modprobe -> ../bin/busybox

14 directories, 44 files

Re: 14.2 su HD USB, problema al caricamento

Inviato: lun nov 20, 2017 11:44
da tigerwalk
Aggiornamento:
Stesso procedimento di installazione, su una pennetta usb da 15 Gb parte senza problemi. Sull' hd usb da 120 Gb non ne vuol sapere e resta inchiodato su
random: nonblocking pool is initialized
Nessuna idea?

Re: 14.2 su HD USB, problema al caricamento

Inviato: mer nov 22, 2017 15:56
da rik70
Ciao,
se è un modulo mancante necessario al disco usb, prova a individuarlo in questo modo:

- avvia la slack 14.2 da chiavetta usb. Una volta caricato il sistema dai:

Codice: Seleziona tutto

lsmod > /tmp/lsmod

- ora collega il disco usb e dopo che viene riconosciuto ridai il comando lsmod, ma "salva" l'output su un altro file. Esempio:

Codice: Seleziona tutto

lsmod > /tmp/lsmod2

A questo punto con un "diff" dovresti vedere se son stati caricati altri moduli e quali:

Codice: Seleziona tutto

diff -Naur /tmp/lsmod /tmp/lsmod2

Metodo forse un po rozzo ma dovrebbe funzionare.

Ad esempio nel mio caso, oltre a 'usb_storage', viene inserito anche il modulo 'uas':

Codice: Seleziona tutto

@@ -1,4 +1,6 @@
 Module                  Size  Used by
+uas                    24576  0
+usb_storage            65536  1 uas
[...]
-usbcore               217088  3 usbhid,xhci_pci,xhci_hcd
-scsi_mod              163840  3 sd_mod,libata,sg
+usbcore               217088  5 usbhid,usb_storage,xhci_pci,uas,xhci_hcd
+scsi_mod              163840  5 sd_mod,usb_storage,libata,uas,sg
 [...]


Prova a buttarci un occhio.

Re: 14.2 su HD USB, problema al caricamento

Inviato: gio nov 23, 2017 14:36
da tigerwalk
Grazie per la tua risposta. In effetti, facendo come dici tu, ho rilevato che tre moduli sono stati caricati dal kernel-huge-smp dopo l'inserimento del disco usb. Di questi l'usb-storage è già presente nell'initrd mentre invece ums-cypress e uas no ed ho provveduto ad inserirli nell'initrd. Al momento ho installato la 13,37 sull'hd esterno ma conto di riprovare con la 14.2 con l'aggiunta dei moduli al più presto.

Re: 14.2 su HD USB, problema al caricamento

Inviato: sab dic 02, 2017 10:41
da tigerwalk
Ho installato la 14.1 su hd usb sperando di avere meno problemi ma è lo stesso. Ho ricompilato il kernel della 14.1 usando il config della 13.37 che parte senza problemi e mettendo statici tutti i driver per i dischi usb. Al caricamento del kernel ricevo il seguente avviso con conseguente interruzione del caricamento:

Codice: Seleziona tutto

Freeing unused kernel memory: 604k freed
Write protecteing the kernel text: 5168k
Write protecting the kernel read-only data: 1580k
NX-protecting the kernel data 3024k

devo rivedere/modificare qualcosa nei parametri di configurazione del kernel?

Re: 14.2 su HD USB, problema al caricamento

Inviato: dom dic 03, 2017 9:35
da tigerwalk
Partendo da disco fisso, ho visto che quel messaggio compare appena prima di

init ver. 2.etc.etc