widescreen e risoluzione 1280x800

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
BAKY
Linux 0.x
Linux 0.x
Messaggi: 30
Iscritto il: dom ott 17, 2004 0:00

widescreen e risoluzione 1280x800

Messaggioda BAKY » gio giu 09, 2005 13:08

Ciao a tutti!

ho preso da poco il notebook e vorrei usare la risoluzione 1024x800 essendo lo scermo 16:10.

la mia scheda video è una ati redeon mobility x300 (non ho ancora installato i driver, sono un po' incasinato e non ho moltissimo tempo, se devo farlo obbligatoriamente lo faccio).
Ho dato uno sguardo sul forum ed ho trovato qualcosa, a quanto ho capito si deve modificare xorg.conf aggiunegndo la modline. Ho provato a farlo inserendo la modeline postata da un altro utente ma poi X non è più partito.

Qualcuno che è riuscito afarlo funzionaremiposterebbe il suo xorg.conf o anche solo la sezione che devo modificare?

grazie mille!!
Ultima modifica di BAKY il gio giu 09, 2005 21:17, modificato 1 volta in totale.

newroz
Linux 1.x
Linux 1.x
Messaggi: 109
Iscritto il: dom mar 13, 2005 0:00
Località: Caserta
Contatta:

Messaggioda newroz » gio giu 09, 2005 15:09

Io ho una widescreen 1280x768, ti posto le modifiche apportate all'xorg.conf da parte mia:

Nella sezione "Device" aggiungere:
Option "XaaNoOffscreenPixmaps"

Nella sezione "Monitor" aggiungere:
Modeline "1280x768" 80.14 1280 1344 1480 1680 768 769 772 795

Nella sezione "Screen", aggiungere, per ogni sottosezione "Display", "1280x768"
Per le frequenze:
Orizzontale (HorizSync): 30 - 90
Verticale (VertRefresh): 50 - 75.0
Non ti posso assicurare che funzionano anche con il tuo monitor, comunque magari prova! :)

newroz
Linux 1.x
Linux 1.x
Messaggi: 109
Iscritto il: dom mar 13, 2005 0:00
Località: Caserta
Contatta:

Messaggioda newroz » gio giu 09, 2005 15:11

Magari nella sezione Monitor, prova a sostituire quello che ho messo io con
Modeline "1024x800" 80 1024 1024 1256 1344 800 800 803 825

BAKY
Linux 0.x
Linux 0.x
Messaggi: 30
Iscritto il: dom ott 17, 2004 0:00

Messaggioda BAKY » gio giu 09, 2005 18:06

perfetto funziona!

adesso però l'immagine è più grande dello schermo. Ho provato a fare di nuovo xorgconfig ma anche se aggiunta la risoluzione 1024x800 in xorg.conf non me la fa scegliere...

Avatar utente
elettronicha
Master
Master
Messaggi: 1712
Iscritto il: mer apr 13, 2005 0:00
Località: Torino
Contatta:

Messaggioda elettronicha » gio giu 09, 2005 20:32

1024/800=1.28, 16/10=1.6 ...... 1.28 diverso da 1.6. Molto prabilmente la risoluzione del tuo video è 1280x800 (rapporto 1.6) :wink: correggi e ti va bene tutto. ciao.

BAKY
Linux 0.x
Linux 0.x
Messaggi: 30
Iscritto il: dom ott 17, 2004 0:00

Messaggioda BAKY » gio giu 09, 2005 21:14

si, hai ragione, è 1280x800.

ho cambiato i valori da 1024 a 1280 ma adesso lo schermo è ancora + grande!!! help meeeeeee!!!

Vlk
Linux 3.x
Linux 3.x
Messaggi: 671
Iscritto il: mer feb 09, 2005 0:00

Messaggioda Vlk » gio giu 09, 2005 21:29

Succede anche a me quando cerco di passare a 1024x768 a 800x600. Anche se dico, durante xorgconfig, di non volere uno schermo virtuale più grande del reale etc etc. Adesso comunque ho smesso di afrmi problemi perchè mi sono abituato a questa risoluzione, ma sarebbe utile sapere da cosa dipende sto problema.

Avatar utente
elettronicha
Master
Master
Messaggi: 1712
Iscritto il: mer apr 13, 2005 0:00
Località: Torino
Contatta:

Messaggioda elettronicha » gio giu 09, 2005 22:22

Subsection "Display"
Depth 24
Modes "1280x800" "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection

Questo è parte del mio xorg.conf. Ho una ATI. Secondo me dove andare di xorgconfig con molta attenzione.

BAKY
Linux 0.x
Linux 0.x
Messaggi: 30
Iscritto il: dom ott 17, 2004 0:00

Messaggioda BAKY » gio giu 09, 2005 23:44

ho risolto così:

inserendo la stringa

Modeline "1024x800" 80 1024 1024 1256 1344 800 800 803 825

ho settato il tutto come ha detto newroz, ho dato xorgconfig settando 1024x768 che non mi da il problema dello schermo più grande (nel tuo caso scegli 800x600 se è quella che non ti da problemi), poi ho modificato xorg.conf sostituendo a 1024x768 1280x800 ed ha funzionato tutto. Non mi pare vero!!!

fammi sapere ;-)

Margherita
Linux 0.x
Linux 0.x
Messaggi: 63
Iscritto il: mar apr 15, 2003 0:00
Contatta:

Messaggioda Margherita » ven giu 17, 2005 7:25

Salve
pure io ho lo stesso poblema di Baky con una ati redeon mobility x600 a 1280x800, ma apportando le modifiche d voi suggerite non mi è cambiato nulla. Vi riassumo i settagggi:

Section Monitor
Identifier "My Monitor"
HorizSync 30 -90
VertRefresh 50 - 75
Modeline "1280x800" 80 1024 1024 1256 1344 800 800 803 825
EndSection

Section "Device"
Identifier "VESA Framebuffer"
Driver "vesa"
Option "XaaNoOffscreenPixmaps"
EndSection

Section "Screen"
Identifier "Screen 1"
Device "VESA Framebuffer"
Monitor "My Monitor"
DefaultDepth 24
Subsection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480" "1280x800"
EndSubsection
Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480" "1280x800"
EndSubsection
Subsection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480" "1280x800"
EndSubsection
Subsection "Display"
Depth 32
Modes "1024x768" "800x600" "640x480" "1280x800"
EndSubsection
EndSection

Ho quindi aggiunto sia il modeline, sia il XaaNoOffscreenPixmaps sia i modi 1280x800, ma continuo a non avere la risoluzione 1280x800.
Tenete presente che se uso xorgconfig c'è qualcosa che sbaglio e lanciando startx mi da uno screen not found.

Spero che qualcuno, dopo aver avuto la pazienza di leggermi, possa capire dove sbaglio e suggerirmi come correggere.
Grazie ciao
Mar

Avatar utente
useless
Staff
Staff
Messaggi: 3896
Iscritto il: dom ott 12, 2003 0:00
Località: A place where the streets have no name
Contatta:

Messaggioda useless » ven giu 17, 2005 8:32

le righe tipo:

Codice: Seleziona tutto

Subsection "Display"
 Depth 8
 Modes "1024x768" "800x600" "640x480" "1280x800"
 EndSubsection
 Subsection "Display"


indicano nell'ordine le risoluzioni da provare ad utilizzare. quindi sposta 1280x800 all'inizio, in tutte le sottosezioni in cui compare.

vi lascio anche questo link che vi aiuterà a risolvere tutti i problemi di risoluzione.

tommyblue
Linux 1.x
Linux 1.x
Messaggi: 112
Iscritto il: gio mar 10, 2005 0:00
Contatta:

Messaggioda tommyblue » ven giu 17, 2005 9:34

ma siete sicuri che servano tutte queste modifiche??
io ho impostato la risoluzione e tutto funziona perfettamente..

Avatar utente
elettronicha
Master
Master
Messaggi: 1712
Iscritto il: mer apr 13, 2005 0:00
Località: Torino
Contatta:

Messaggioda elettronicha » ven giu 17, 2005 10:17

Non sono tante le modifiche da fare, si aggiunge solo "1280x800" in una sola riga, quella relativa a 24 0 32 bit di risoluzione di colore. Tu non hai dovuto fare queste modifiche forse perché il tuo xorg.conf era già a posto, che risoluzione hai?

tommyblue
Linux 1.x
Linux 1.x
Messaggi: 112
Iscritto il: gio mar 10, 2005 0:00
Contatta:

Messaggioda tommyblue » ven giu 17, 2005 10:25

infatti è ciò che mi è bastato fare, senza modeline o viewport o simili

Margherita
Linux 0.x
Linux 0.x
Messaggi: 63
Iscritto il: mar apr 15, 2003 0:00
Contatta:

Messaggioda Margherita » ven giu 17, 2005 12:31

A me spostando all'inizio 1280x800 proprio nn parte
Se qualcuno facesse un riassunto dell'essenziale

Grazie ciao
mar