Slackware 12.0 supportata dal nuovo Gnome 2.20.0

Questo forum raccoglie tutte le discussioni sul progetto Gnome Slacky (Gnome per Slackware).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Gslacky usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda gohanz » lun set 24, 2007 18:27

A dire la verità già ero a buon punto. Le librerie base di Gnome 2.20.0 sono già pronte ed uppate sul server. Mi sono fermato perchè ho deciso di effettuare l'upgrade di dbus alla 1.1.2, mentre lascio Hal alla versione della 12.0.
Insomma mi tocca ricompilare un bel po di librerie sul nuovo dbus. :roll:
Submax poi mi dovresti adattare alcune patch per syste-tools-backend! ;)

Avatar utente
submax82
Staff
Staff
Messaggi: 3202
Iscritto il: mer ago 31, 2005 0:00
Desktop: xfce
Distribuzione: SalixOS
Contatta:

Messaggioda submax82 » mar set 25, 2007 1:30

Submax poi mi dovresti adattare alcune patch per syste-tools-backend!
ok ;)

ho controllato ... non c'è più bisogno della patch è già stata integrata ... mi avevi avvisato anche ... non ti ricordi ?! :shock:

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda gohanz » mar set 25, 2007 8:11

submax82 ha scritto:
Submax poi mi dovresti adattare alcune patch per syste-tools-backend!
ok ;)

ho controllato ... non c'è più bisogno della patch è già stata integrata ... mi avevi avvisato anche ... non ti ricordi ?! :shock:


La patch che hanno inserito funzionano male, sono in contatto con l'autore delle stesse. Mi ha inviato tutto il materiale! Se non aggiornano system-tools-backends, mi dovresti adattare le stesse per l'ultima versione! ;)

Avatar utente
submax82
Staff
Staff
Messaggi: 3202
Iscritto il: mer ago 31, 2005 0:00
Desktop: xfce
Distribuzione: SalixOS
Contatta:

Messaggioda submax82 » mar set 25, 2007 9:06

mi sembrano uguali... booo ... spiega meglio e se puoi inviami il materiale...

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda gohanz » mar set 25, 2007 11:05

Si ti mando tutto via posta! ;) Con system-tools-backends senza patch non funzionano bene il gestore dei servizi e il gestore degli utenti!

GSlacky 2.20.0 icomincia a girare sulla Slackware 12.0! :p
Immagine

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda gohanz » ven set 28, 2007 11:15

GSlacky-2.20.0 completo al 90%! :p Ecco una schermata con Beagle e NetWorkmanger in azione!

Immagine

Avatar utente
Loris
Admin
Admin
Messaggi: 7664
Iscritto il: lun mar 31, 2003 0:00
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5
Località: Gradisca D'Isonzo
Contatta:

Messaggioda Loris » ven set 28, 2007 21:54

:fuori: già al 90% ?
Ragazzi Andrea è un grande :shock:
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda gohanz » ven set 28, 2007 21:56

C'è Submax che mi da un gran supporto! Comunque è vero sto fuori! :D

Avatar utente
submax82
Staff
Staff
Messaggi: 3202
Iscritto il: mer ago 31, 2005 0:00
Desktop: xfce
Distribuzione: SalixOS
Contatta:

Messaggioda submax82 » ven set 28, 2007 21:57

definirlo "grande" è riduttivo ... "incredibile" è meglio :notworthy:

Bart
Staff
Staff
Messaggi: 4249
Iscritto il: lun ago 09, 2004 0:00
Località: Rimini

Messaggioda Bart » ven set 28, 2007 22:10

Boh, io vedendo i risultati di gohanz non capisco più perché Pat abbia abbandonato Gnome. :roll:

Avatar utente
Loris
Admin
Admin
Messaggi: 7664
Iscritto il: lun mar 31, 2003 0:00
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5
Località: Gradisca D'Isonzo
Contatta:

Messaggioda Loris » ven set 28, 2007 22:19

Magari Pat contatta Andrea e gli dice di collaborare... tutto è possibile :p
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett

Bart
Staff
Staff
Messaggi: 4249
Iscritto il: lun ago 09, 2004 0:00
Località: Rimini

Messaggioda Bart » ven set 28, 2007 22:23

Ah davvero, sarebbe spettacolare ;)

Avatar utente
simplex
Linux 2.4
Linux 2.4
Messaggi: 327
Iscritto il: mer lug 27, 2005 0:00
Slackware: current
Desktop: xfce
Contatta:

Messaggioda simplex » sab set 29, 2007 8:18

Bart ha scritto:Boh, io vedendo i risultati di gohanz non capisco più perché Pat abbia abbandonato Gnome. :roll:


Dal ChangeLog di Slackware 10.2:

gnome/*: Removed from -current, and turned over to community support and
distribution. I'm not going to rehash all the reasons behind this, but it's
been under consideration for more than four years. There are already good
projects in place to provide Slackware GNOME for those who want it, and
these are more complete than what Slackware has shipped in the past. So, if
you're looking for GNOME for Slackware -current, I would recommend looking at
these two projects for well-built packages that follow a policy of minimal
interference with the base Slackware system:

http://gsb.sf.net
http://gware.sf.net

There is also Dropline, of course, which is quite popular. However, due to
their policy of adding PAM and replacing large system packages (like the
entire X11 system) with their own versions, I can't give quite the same sort
of nod to Dropline. Nevertheless, it remains another choice, and it's _your_
system, so I will also mention their project:

http://www.dropline.net/gnome/

Please do not incorrectly interpret any of this as a slight against GNOME
itself, which (although it does usually need to be fixed and polished beyond
the way it ships from upstream more so than, say, KDE or XFce) is a decent
desktop choice. So are a lot of others, but Slackware does not need to ship
every choice. GNOME is and always has been a moving target (even the
"stable" releases usually aren't quite ready yet) that really does demand a
team to keep up on all the changes (many of which are not always well
documented). I fully expect that this move will improve the quality of both
Slackware itself, and the quality (and quantity) of the GNOME options
available for it.

Folks, this is how open source is supposed to work. Enjoy. :-)

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda gohanz » sab set 29, 2007 8:18

Ho pensato di inserire Slapt-get e Gslapt preconfigurati con i repository di Slacky e GSlacky. Voi che ne dite? :?:

Avatar utente
submax82
Staff
Staff
Messaggi: 3202
Iscritto il: mer ago 31, 2005 0:00
Desktop: xfce
Distribuzione: SalixOS
Contatta:

Messaggioda submax82 » sab set 29, 2007 10:24

gohanz ha scritto:Ho pensato di inserire Slapt-get e Gslapt preconfigurati con i repository di Slacky e GSlacky. Voi che ne dite? :?:


l'idea non era male ma non mi piace ... scusami ... ma poi si torna mano a mano alla vecchia situazione con 2000 extra... io al massimo metterei solo i file di configurazione nel cd, in modo che uno se li può copiare o un readme oppure uno script per aggiungerli... ma non i pacchetti ;)

inoltre slapt-get non è uno strumento "ufficiale" di installazione per slackware.com

questa è SOLO la mia opinione, il progetto è tuo :)

IDEA: potrei aggiungere all'installer una sezione che se trova slapt-get o swaret installati ( e quindi significa che l'utente gli usa) allora aggiunge ai repository già presenti nel sistema quelli di gslacky.


Torna a “Gnome Slacky”

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite