Pagina 1 di 2

2.18 vs 2.20.1

Inviato: gio nov 15, 2007 18:00
da nico giraldi
Salve,

sul pc al lavoro (un P4 con 758 MB di RAM) ho una slack 12 (kernel 2.6.21.5 customizzato); fino ad oggi avevo gslacky 2.18.3 che usavo con profonda soddisfazione ( a proposito siete veramente in gamba); pre provare la 2.20.1 ho usato prima rimosso la 2.18 usando l'installer epoi ho provato a mettere la 2.20
però quando faccio install.sh nelle voci relative ai vari install non mi compare il numero di pacchetti o la size totale, es e provo ad installare fa solo il post install;
al contrario, pare che rimettere la 2.18 vada bene (lo sto facendo ora). Che ne dite?

ola!

Inviato: gio nov 15, 2007 18:52
da submax82
hai controllato l'md5sum del cd?

questo perchè nè gohanz, nè nessuno ha segnalato un bug simile nell'installer... :?

Inviato: gio nov 15, 2007 20:00
da gohanz
Confermo che l'installer della 2.20.1 funziona bene! ;)

Inviato: gio nov 15, 2007 23:16
da nico giraldi
My fault: avevo scordato di fare il checksum md5; ora sono a casa ma domani mattina riproverò.

In ogni caso immagino dipenda dal mio sistema anche se tutti i pacchetti sono stati scaricati bene.

scusate il fumble

Inviato: ven nov 16, 2007 10:47
da nico giraldi
Per una volta il mio rincoglionimento è indifferente: ho fatto il checksum md5 ed il risultato è:

Codice: Seleziona tutto

awk '$2!~/OK/' md5log  | wc -l
0


guardando l'output di install.sh s'ottiene:

Codice: Seleziona tutto

cat: /opt/bdata/Azureus: No such file or directory
cat: Downloads/tmp1/install-settings/revision: No such file or directory
./install.sh: line 247: [: /home/gmancini/bdata/Azureus: binary operator expected


il nome della dir Azureus Downloads fa casino... (mah con la 2.18 va tranquillo invece)
difatti ora va bene; certo che or a che ho reinstallato la 2.18 mi rode un po' in ogni caso ho avuto fretta di postare.
Già che ci sono volevo sottoporvi le seguenti questione: a casa ho un pc su cui ho messo current (è molto nuovo e anche il cd della 12 si inchioda in fase di boot).

Ora io uso varie app + o - gnome based (tipo le gnome chemistry utils) e avrei piacere di avere gnome anche sulla current. Del resto ho visto che la 2.20.1 rimpiazza molti pacchetti e dubito che l'installazione sia semplice.
Pensate che la 2.18 essendo meno invasiva possa funzionare (quasi) out of the box?
Oppure ricorro al buon garnome?

ola!

Inviato: ven nov 16, 2007 11:23
da gohanz
Secondo me non funziona, comunque l'unica è provare! Forse puoi fare girare le applicazioni Gnome sotto un'altro DE.

Inviato: ven nov 16, 2007 11:30
da nico giraldi
Se lo dici te che sei il mantainer posso fidarmi. A sto punto proverò garnome...
solo una domanda:

una volta messo garnome sotto (ad esempio) /opt/gnome e fatto partire gnome, come faccio ad integrare i menù ed ad evitare "doppie applicazioni". Presumo che garnome reinstalli un botto di roba (tipo mozilla) ed io glielo faccio fare (tanto sta sotto /opt) poi però vorrei poter scegliere quale usare

e per le librerie?

ola!

Inviato: ven nov 16, 2007 11:52
da gohanz
Ti rimando ad una discussione con un mio amico Tedesco, che mi ha aiutato nello sviluppo di GSlacky. Per le librerie prova ad usare quelle per la 12.0. Non conosco Garnome, comunque ricompilare tutte quelle libreie per la current diventa un'impresa proibitiva.

http://www.linuxpackages.net/forum/view ... hp?t=17801

Inviato: ven nov 16, 2007 11:57
da nico giraldi
Ok grazie. Staserà metto le mani in pasta. Magari ne esce qualcosa utile a chi vuole provare gslacky su current...

grazie

Inviato: ven nov 16, 2007 14:12
da submax82
nico giraldi ha scritto:Per una volta il mio rincoglionimento è indifferente: ho fatto il checksum md5 ed il risultato è:

Codice: Seleziona tutto

awk '$2!~/OK/' md5log  | wc -l
0


guardando l'output di install.sh s'ottiene:

Codice: Seleziona tutto

cat: /opt/bdata/Azureus: No such file or directory
cat: Downloads/tmp1/install-settings/revision: No such file or directory
./install.sh: line 247: [: /home/gmancini/bdata/Azureus: binary operator expected


il nome della dir Azureus Downloads fa casino... (mah con la 2.18 va tranquillo invece)
difatti ora va bene; certo che or a che ho reinstallato la 2.18 mi rode un po' in ogni caso ho avuto fretta di postare.


ho capito ... c'è un piccolo BUG nell'installer .... e ho capito perchè con la 2.18 non c'era.... metti tutto in un percorso che non ha spazi nel nome delle directory e tornerà a funzionare...

appena posso correggo il bug e spedisco il nuovo installer ha gohanz

c'è anche un'altro GRAVE errore! se si installa gnome 2.20.1 in modalità full vengono installati anche gli extra tra cui "pkgtools-12.1.0-noarch-1.tgz" che risolvono diversi problemi e fin qui tutto ok... ma se poi rimuovo gnome .... l'installer rimuove anche pkgtools e non ripristina quello vecchio ... questo perchè non c'è sotto packages/Slackware_12.0.0 !!!! quindi il mio suggerimento per gohanz è di inserire anche sotto Slackware_12.0.0 quel pacchetto oppure faccio una piccola aggiunta all'installer per non rimuovere nessun pacchetto pkgtools...

GOHANZ fammi sapere ... io correggerei e ripubblicherei come GSlacky-2.20.1-r2-i686.iso questo perchè i bug sono gravi ma sopratutto l'ultimo dei pkgtools!

Inviato: ven nov 16, 2007 14:37
da gohanz
Si hai ragione questa sera provvedo! :roll:

Inviato: ven nov 16, 2007 14:39
da submax82
gohanz ha scritto:Si hai ragione questa sera provvedo! :roll:


aspetta che ti mando l'installer fixato

Inviato: ven nov 16, 2007 14:50
da gohanz
Si va bene! Ho provato ed infatti pkgtools non andava più. L'unica maniera è stato reinstallare il pacchetto con il classico tar xvzf dato dalla directory root.

Inviato: ven nov 16, 2007 16:00
da nico giraldi
Io questo non lo avevo notato visto che sono rimbalzato da una gnome all'altra...
Comunque ora vi scrivo dalla 2.20!

ola!

Inviato: ven nov 16, 2007 16:02
da submax82
nico giraldi ha scritto:Io questo non lo avevo notato visto che sono rimbalzato da una gnome all'altra...
Comunque ora vi scrivo dalla 2.20!

ola!


quindi è bastato
metti tutto in un percorso che non ha spazi nel nome delle directory e tornerà a funzionare...
? :?: