Pagina 1 di 1

GSlacky Immediate Failure

Inviato: mar gen 22, 2008 3:11
da crasslogic
Greetings all.
Gohanz, thank you for your work here :) All is greatly valued.

Onward, I've burnt the .iso for GSlacky 2.20.3 and when I attempt to run the install.sh,
I get this:
bash-3.1$ ./install.sh
bash: ./install.sh: /bin/bash: bad interpreter: Permission denied


This came up logged in as either root or su. Any ideas? I am running a fresh install of Slackware 12.0, and i've not even re-built my kernel yet. Thanks for your assistance.
--Q

Re: GSlacky Immediate Failure

Inviato: mar gen 22, 2008 7:37
da nuitari
it seems u don't have /bin/bash or u don't have rights to access it...
try those commands:

Codice: Seleziona tutto

find /bin -iname "bash" | xargs ls -la
find /usr -iname "bash" | xargs ls -la


and paste here the result.

Re: GSlacky Immediate Failure

Inviato: mar gen 22, 2008 7:58
da gohanz
Do you have added "root" and your user to plugdev group? It's seem that you are trying to run a shell file without exec rights.

Re: GSlacky Immediate Failure

Inviato: mar gen 22, 2008 15:34
da crasslogic
Well, I used Kuser (the easiest way I know) to make sure both root and user were in group "plugdev", which they are.

The results of the command strings:
bash-3.1# find /bin -iname "bash" | xargs ls -la
-rwxr-xr-x 1 root root 678832 2007-05-10 18:19 /bin/bash
bash-3.1# find /usr -iname "bash" | xargs ls -la
lrwxrwxrwx 1 root root 9 2008-01-19 08:05 /usr/bin/bash -> /bin/bash
bash-3.1#


Any idea?? :-k
--Q

Re: GSlacky Immediate Failure

Inviato: mar gen 22, 2008 15:43
da JohnnyMnemonic
Have you tried to mount the ISO (and not the Cd itself) with

Codice: Seleziona tutto

mount -o loop /where/is/gslacky.iso /mnt/cdrom


and then execute install.sh ?

Only a try.

Re: GSlacky Immediate Failure

Inviato: mar gen 22, 2008 20:51
da crasslogic
Well, my friend, you've done it! :D
Somehow, mounting the .iso as opposed to burning it onto a CD worked just fine. I had reburned just to make sure but that still didn't work. Somehow, mounting it instead of burning got me up and running. Excellent.

Slightly off subject, but quick question, was the Slacky.eu Banshee package compiled to support the iPod? I'll use the Banshee site to figure out how to make that work, but I was wondering if I'll have to build from source or not. Thanks for your all help guys!
--Q

Re: GSlacky Immediate Failure

Inviato: mar gen 22, 2008 21:06
da JohnnyMnemonic
In the description of Banshee it says about the possibilty to play and sync the iPod, and in its dependencies we have other iPod related packages

Import, organize, play, and share your music using Banshee's simple, powerful interface. Rip CDs, play and sync your iPod, create playlists, and burn audio and MP3 CDs. Most portable music devices are supported. Banshee also has support for podcasting, smart playlists, music recommendations, and much more.

Dependencies: libipoddevice, ibburn, libisofs, sg3_utils, ndesk-dbus, ndesk-dbus-glib, podsleuth, libgphoto2-sharp, njb-sharp, ipod-sharp-0.6.3, gslacky

Re: GSlacky Immediate Failure

Inviato: mer gen 23, 2008 1:33
da algol
Hi
I solve the "bad interpreter" problem just typing sh ./install.sh .... :|