installazione mplayer

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
twister
Staff
Staff
Messaggi: 1598
Iscritto il: mar 11 nov 2003, 0:00
Slackware: current
Località: Roma
Contatta:

installazione mplayer

Messaggio da twister »

ciao a tutti
<BR>ho provato ad installare mplayer sulla mia slack 9.1
<BR>ho seguito tutto alla lettera, codecs nella giusta directory, infatti il ./configure li trova
<BR>finisco l´installazione, do il comando gmplayer e mi da questi errori
<BR>
<BR>
<BR>
<BR>MPlayer 1.0pre2-3.2.3 (C) 2000-2003 MPlayer Team
<BR>
<BR>CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred 2005 MHz (Family: 6, Stepping: 1)
<BR>Detected cache-line size is 64 bytes
<BR>CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
<BR>Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE
<BR>
<BR>Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
<BR>Reading config file /home/twister/.mplayer/config
<BR>[cfg] read config file: /home/twister/.mplayer/gui.conf
<BR>Reading config file /home/twister/.mplayer/gui.conf: No such file or directory
<BR>vo: X11 running at 1152x864 with depth 24 and 32 bpp (":0.0" => local display)
<BR>Reading /home/twister/.mplayer/codecs.conf: Can´t open ´/home/twister/.mplayer/codecs.conf´: No such file or directory
<BR>Reading /usr/local/etc/mplayer/codecs.conf: Can´t open ´/usr/local/etc/mplayer/codecs.conf´: No such file or directory
<BR>Using built-in default codecs.conf
<BR>font: can´t open file: /home/twister/.mplayer/font/font.desc
<BR>font: can´t open file: /usr/local/share/mplayer/font/font.desc
<BR>Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
<BR>Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
<BR>Using usleep() timing
<BR>Can´t open input config file /home/twister/.mplayer/input.conf: No such file or directory
<BR>Can´t open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
<BR>Falling back on default (hardcoded) input config
<BR>SKIN dir 1: ´/home/twister/.mplayer/Skin´
<BR>SKIN dir 2: ´/usr/local/share/mplayer/Skin
<BR>
<BR>
<BR>tutte le cartele e i file delle skin e dei font sono messe come da documentation
<BR>che problema puo essere???
<BR>Grazie in anticipo<br>

cRoW2k
Linux 2.x
Linux 2.x
Messaggi: 261
Iscritto il: gio 20 nov 2003, 0:00
Slackware: -current
Contatta:

installazione mplayer

Messaggio da cRoW2k »

Allora, prima di tutto sarebbe opportuno passare il prefix=/usr ogni volta che si compila manualmente. Questo per rispettare lo standard di Slackware.
<BR>
<BR>L´errore è ovvio, mancano i file di conf (No such file or directory ).
<BR>Molto probabilmente non ti ha creato le directory (tipo .mplayer sotto la home).
<BR>Pulisci e riesegui il configure come da manuale (Leggeti i file INSTALL e README dentro le directory dei sorgenti).
<BR>Ciao<br>

Avatar utente
twister
Staff
Staff
Messaggi: 1598
Iscritto il: mar 11 nov 2003, 0:00
Slackware: current
Località: Roma
Contatta:

installazione mplayer

Messaggio da twister »

non mi sarei rivolto al forum se prima non avessi controolato e riprovato il tutto almeno 2/3 volte
<BR>il fatto è che tutte le directory sono state create
<BR>e i file al loro posto.....
<BR><br>

Avatar utente
Loris
Admin
Admin
Messaggi: 7714
Iscritto il: lun 31 mar 2003, 0:00
Nome Cognome: Loris Vincenzi
Località: Gradisca D'Isonzo
Contatta:

installazione mplayer

Messaggio da Loris »

Come hai lanciato il configure ?
<BR>Se vuoi ti passo il mio SlackBuild che compila e crea il .tgz della versione MPlayer-1.0pre2<br>
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett

Avatar utente
twister
Staff
Staff
Messaggi: 1598
Iscritto il: mar 11 nov 2003, 0:00
Slackware: current
Località: Roma
Contatta:

installazione mplayer

Messaggio da twister »

ho lanciato prima tutti i moduli poi ho lanciato con
<BR>./confugre --enable-gui
<BR>
<BR>magari avere il pacchetto :-)
<BR><br>

Avatar utente
Loris
Admin
Admin
Messaggi: 7714
Iscritto il: lun 31 mar 2003, 0:00
Nome Cognome: Loris Vincenzi
Località: Gradisca D'Isonzo
Contatta:

installazione mplayer

Messaggio da Loris »

OK mi organizzo e rendo disponibile il tutto.
<BR>
<BR>Solo una cosa io non uso MPlayer uso Xine quindi chi testa il pacchetto mi avvisi in caso di problemi strani.<br>
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett

Avatar utente
twister
Staff
Staff
Messaggi: 1598
Iscritto il: mar 11 nov 2003, 0:00
Slackware: current
Località: Roma
Contatta:

installazione mplayer

Messaggio da twister »

grazie sei gentilissimo,
<BR>ti faccio volentieri io da beta tester :-)
<BR><br>

francofait
Linux 0.x
Linux 0.x
Messaggi: 2
Iscritto il: ven 21 nov 2003, 0:00

installazione mplayer

Messaggio da francofait »

Scaricato ed installato , funziona alla grande - senza problemi.
<BR><br>

Avatar utente
Loris
Admin
Admin
Messaggi: 7714
Iscritto il: lun 31 mar 2003, 0:00
Nome Cognome: Loris Vincenzi
Località: Gradisca D'Isonzo
Contatta:

installazione mplayer

Messaggio da Loris »

C´è solo il problema dei font ma basta fare un link, eventualmente mi studio un sistema da inserire nel dointst.sh <br>
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett

Avatar utente
twister
Staff
Staff
Messaggi: 1598
Iscritto il: mar 11 nov 2003, 0:00
Slackware: current
Località: Roma
Contatta:

installazione mplayer

Messaggio da twister »

perdona allora la mia ignoranza
<BR>io ho scaricato il tuo pacchetto
<BR>lo ho messo in root
<BR>ho dato explodepkg....
<BR>poi installpkg...
<BR>ma mi si blocca cosi
<BR>
<BR>bash-2.05b# installpkg MPlayer-1.0pre2-i486-1.tgz
<BR>Installing package MPlayer-1.0pre2-i486-1...
<BR>PACKAGE DESCRIPTION:
<BR>MPlayer: mplayer
<BR>MPlayer:
<BR>MPlayer: Movie player for linux (runs on many other Unices, and non-x86
<BR>MPlayer: CPUs, see the documentation) It plays most MPEG, VOB, AVI,
<BR>MPlayer: OGG/OGM, VIVO, ASF/WMA/WMV, QT/MOV/MP4, FLI, RM, NuppelVideo,
<BR>MPlayer: YUV4MPEG, FILM, RoQ, PVA files, supported by many native, XAnim,
<BR>MPlayer: and Win32 DLL codecs. You can watch VideoCD, SVCD, DVD, 3ivx,
<BR>MPlayer: DivX 3/4/5 and even WMV movies, too (without the avifile library).
<BR>MPlayer:
<BR>Executing install script for MPlayer-1.0pre2-i486-1...
<BR>
<BR>bash-2.05b#
<BR><br>

Avatar utente
useless
Staff
Staff
Messaggi: 3896
Iscritto il: dom 12 ott 2003, 0:00
Località: A place where the streets have no name
Contatta:

installazione mplayer

Messaggio da useless »

explodepkd non è necessario, basta installpkg. quando al "blocco"... vuol semplicemente dire che è andato tutto bene ed ora il pacchetto è installato. lancia l´eseguibile ora! (mplayer, o gmplayer se c´era anche la gui).<br>

Avatar utente
twister
Staff
Staff
Messaggi: 1598
Iscritto il: mar 11 nov 2003, 0:00
Slackware: current
Località: Roma
Contatta:

installazione mplayer

Messaggio da twister »

infatti sono un cretino io :-)
<BR>il problema però è che continua a darmi l´errore decritto all´inizio del thread :-(
<BR>Uffa..<br>

Avatar utente
Loris
Admin
Admin
Messaggi: 7714
Iscritto il: lun 31 mar 2003, 0:00
Nome Cognome: Loris Vincenzi
Località: Gradisca D'Isonzo
Contatta:

installazione mplayer

Messaggio da Loris »

Prova a cancellare la directory .mplayer della tua home e riesegui gmplayer
<BR>Il vecchi mplayer è stato rimosso ?<br>
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett

Avatar utente
twister
Staff
Staff
Messaggi: 1598
Iscritto il: mar 11 nov 2003, 0:00
Slackware: current
Località: Roma
Contatta:

installazione mplayer

Messaggio da twister »

alla grande, ora va
<BR>mi era rimasto un file in /usr/local/bin che mi ra scappato....
<BR>Grazie e scusa
<BR>:-)<br>

Avatar utente
Loris
Admin
Admin
Messaggi: 7714
Iscritto il: lun 31 mar 2003, 0:00
Nome Cognome: Loris Vincenzi
Località: Gradisca D'Isonzo
Contatta:

installazione mplayer

Messaggio da Loris »

Di nulla, felice che ora ti funziona :-) <br>
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett

Rispondi