Samba: l'eterno ritorno

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
kens
Linux 2.x
Linux 2.x
Messaggi: 208
Iscritto il: dom giu 06, 2004 0:00
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: KDE

Samba: l'eterno ritorno

Messaggioda kens » lun gen 11, 2010 17:43

Dopo aver per lungo tempo rinunciato all'idea di avere una LAN casalinga decente, causa le "formattazioni" selvagge che i miei due pargoli organizzavano con frenetica frequenza sui rispettivi p.c. [-( [-( sono stato recentemente colto da un attacco di buonismo ;) e mi sono rimesso all'opera con Samba.
I tre p.c. (una Slack 12.2 + due Win XP) si "vedono"e condividono pure la stampante, disciplinati dal seguente smb.conf:

Codice: Seleziona tutto

[global]
   unix charset = ISO-8859-15
   display charset = ISO-8859-15
   workgroup = NIKHOME
   server string = K6_400
   update encrypted = Yes
   log file = /var/log/samba/log.%m
   max log size = 50
   socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
   printcap name = cups
   wins support = Yes
   ldap ssl = no
   hosts allow = 10.0.0., 127.

[public]
   comment = Area Pubblica
   path = /mnt/win_d/SambaShare
   read only = No
   create mask = 0664
   directory mask = 0775
   guest ok = Yes

[BROTHERDCP-165C]
   comment = BROTHER DCP-165C
   path = /var/spool/samba
   read only = No
   create mask = 0770
   guest ok = Yes
   printable = Yes
   print command = lpr-cups -P %p -o raw %s
   use client driver = Yes
   oplocks = No

Ho deliberatamente scelto di lasciare in default (user) l'opzione "SECURITY" della sezione [GLOBAL], per dare un taglio un po' più rigoroso alla faccenda e poter magari utilizzare l'esperienza maturata anche in ambito non casalingo; debbo dire che funziona praticamente tutto :thumbright:
L'unico aspetto che mi "perplime" ;) è il seguente:

mi pareva di aver letto che facendo coincidere le coppie username/password di tutti gli utenti Windows sia con quelle degli account Samba sia con quelle degli utenti Linux corrispondenti, sarebbe stato sufficiente effettuare il login sui client per essere automaticamente accreditati da Samba (anche con SECURITY=USER, sì); una volta richiesta una risorsa condivisa in modo "non guest" la trasmissione dei relativi dati, da quel che sapevo, sarebbe stata automatica.
Ebbene non è così. Quando da un client XP tento di accedere per la prima volta alla directory "SambaShare" mi viene comunque e sempre chiesto di autenticarmi; ripetuto il login (usando la stessa coppia username/password indicata all'avvio di XP) si svolge tutto regolarmente e senza incertezze.
Non è certo gravissimo, non per me almeno ;) ma mi piacerebbe capire il perché.

Ho toppato il "samba.conf" o cos'altro? :-k

Grazie sin d'ora per la pazienza.

--

Avatar utente
andy-x
Linux 1.x
Linux 1.x
Messaggi: 139
Iscritto il: lun lug 13, 2009 11:19
Slackware: 12.2
Kernel: 2.6.27.7
Desktop: kde

Re: Samba: l'eterno ritorno

Messaggioda andy-x » lun gen 11, 2010 19:02

Allora.....
Sul server del lavoro piu' o meno funziona come hai detto tu. Infatti e' bastato far accedere solo la prima volta alle risorse e dare user e password per avere tutto
disponibile senza piu' dare niente.
Ovviamente la prima volta ho detto ai client di memorizzare la password.
Ora sono a casa ma domani mattina ti do' un occhio alla mia configurazione... :-k

Comunque se dai accesso ai guest non dovresti vedere le risorse condivise a prescindere?

Avatar utente
kens
Linux 2.x
Linux 2.x
Messaggi: 208
Iscritto il: dom giu 06, 2004 0:00
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: KDE

Re: Samba: l'eterno ritorno

Messaggioda kens » lun gen 11, 2010 19:30

Non ho dato l'accesso ai guest deliberatamente, riservandolo al solo utilizzo della stampante (ho deciso di complicarmi la vita, sì ;) ).
Per quanto riguarda la condivisione "SambaShare" anche da me, una volta dati user e password, ogni successivo accesso alla risorsa avviene senza che venga più chiesto nulla (ci mancherebbe, sai che zebedei! :D ...)
Ma mi pareva di aver letto che una volta effettuato il login sui client digitando user e password di XP la trasmissione di tali dati dovrebbe essere automatica anche accedendo alla condivisione Samba per la prima volta (ovviamente se c'è perfetta identità tra le coppie username/password sia in XP sia in Linux sia in Samba).

Avatar utente
kens
Linux 2.x
Linux 2.x
Messaggi: 208
Iscritto il: dom giu 06, 2004 0:00
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: KDE

Re: Samba: l'eterno ritorno

Messaggioda kens » lun gen 11, 2010 19:55

Credo di aver risolto.

Non avevo spuntato il flag "memorizza la password" nella finestra di dialogo che si presenta al primo accesso da parte di un client Xp alla risorsa condivisa. Facendolo tutto si "normalizza" e non viene più chiesto nulla, nemmeno spegnendo e riaccendendo la macchina.
Non l'avevo dimenticato; solo pensavo che essendo la password di accesso alle risorse Samba identica a quella di XP bastasse fornire le "credenziali" in sede di login in windows. Evidentemente non è così. In effetti, pensandoci bene, nulla vieterebbe di differenziare le password tra Samba ed XP; probabilmente è per questo che, almeno una prima volta, è necessario comunque digitare la password per esteso e memorizzarla.

--

Avatar utente
andy-x
Linux 1.x
Linux 1.x
Messaggi: 139
Iscritto il: lun lug 13, 2009 11:19
Slackware: 12.2
Kernel: 2.6.27.7
Desktop: kde

Re: Samba: l'eterno ritorno

Messaggioda andy-x » lun gen 11, 2010 20:11

=D> :wav: =D>
Bene sono contento che tu abbia risolto. Samba e' stupendo ma a volte fa' anche un po' arrabbiare.... :-X
Comunque si trova sempre la soluzione giusta.. 8-)

Avatar utente
kens
Linux 2.x
Linux 2.x
Messaggi: 208
Iscritto il: dom giu 06, 2004 0:00
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: KDE

Re: Samba: l'eterno ritorno

Messaggioda kens » lun gen 11, 2010 20:15

Samba è di una tale vastità (eccessiva, oserei dire) che spesso si perdono anche gli "specialisti", figuriamoci un modesto autodidatta come me ;)
Grazie, Andy, per la gentilezza e la pazienza comunque dimostrate.
Alle prossime :thumbright:

--

Avatar utente
Naitso
Linux 2.x
Linux 2.x
Messaggi: 208
Iscritto il: lun nov 10, 2008 15:09

Re: Samba: l'eterno ritorno

Messaggioda Naitso » mar gen 12, 2010 11:40

Per vedere gli utenti di samba

Codice: Seleziona tutto

# pdbedit -L

se il comando non da nessun output, aggiungi gli utenti "Windows" con smbpasswd (devi mantenere lo stesso user e stessa password di xp)
Gli utenti di samba non sono gli utenti in /etc/passwd
Ciao ;)

Avatar utente
NetNightmare
Linux 1.x
Linux 1.x
Messaggi: 175
Iscritto il: lun ago 18, 2008 11:00
Nome Cognome: Giuseppe De Nicolo'
Slackware: 13.37 x86_64
Kernel: 2.6.37.6-smp
Desktop: Fluxbox
Località: Rome

Re: Samba: l'eterno ritorno

Messaggioda NetNightmare » mar gen 12, 2010 11:56

Ciao ;-)

Mi intrometto un secondo nella discussione giusto per dare un punto di vista alternativo, sebbene il tuo problema sia risolto, vorrei farti notare che in realta' cio' che hai fatto e' semplicemente salvare le credenziali di accesso alla share nel computer locale ..... e non abilitare il SSO ( Single Sign On ) tra il computer che fa da server samba e i client XP. per carita' funziona ma non mi sembra sia quello che avevi chiesto nel post precendente ....

Quello che mi sembrava chiedessi nel post principale penso fosse esattamente come far funzionare SSO nella tua situazione, che in pratica e' quella di replicare cosa succede in un Gruppo di Lavoro Microsoft ... ovvero inserire user e pass coincidenti sui pc e utilizzare quindi le credenziali di accesso per le share tra i PC.

Avatar utente
kens
Linux 2.x
Linux 2.x
Messaggi: 208
Iscritto il: dom giu 06, 2004 0:00
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: KDE

Re: Samba: l'eterno ritorno

Messaggioda kens » mar gen 12, 2010 12:41

NetNightmare ha scritto:...Quello che mi sembrava chiedessi nel post principale penso fosse esattamente come far funzionare SSO nella tua situazione, che in pratica e' quella di replicare cosa succede in un Gruppo di Lavoro Microsoft ... ovvero inserire user e pass coincidenti sui pc e utilizzare quindi le credenziali di accesso per le share tra i PC.


qualche "sospetto" era venuto pure a me, sai NetNight? :D la tua "intromissione" è dunque graditissima! :thumbright:
Questa meravigliosa condizione, della quale prima della tua comparsa ignoravo nome ed esitenza ;) questo benedetto "SSO" insomma, come funziona e come può ottenersi tramite Samba?
Non dirmi che debbo impelagarmi tra gestione e controllori di domini, "elezioni" varie di master browser e roba simile; vabbè la didattica ma credo che nel mio caso sarebbe come sparare col cannone al proverbiale moscerino, o no? ;)

Grazie anche a te, ovviamente, della pazienza :thumbright:

Avatar utente
twister
Staff
Staff
Messaggi: 1598
Iscritto il: mar nov 11, 2003 0:00
Slackware: current
Località: Roma
Contatta:

Re: Samba: l'eterno ritorno

Messaggioda twister » mar gen 12, 2010 18:42

Beh credo che la via più semplice per farlo sia usare Samba come PDC, ma se sei su slackware e non vuoi ricompilarti pam è un po una rottura

Avatar utente
NetNightmare
Linux 1.x
Linux 1.x
Messaggi: 175
Iscritto il: lun ago 18, 2008 11:00
Nome Cognome: Giuseppe De Nicolo'
Slackware: 13.37 x86_64
Kernel: 2.6.37.6-smp
Desktop: Fluxbox
Località: Rome

Re: Samba: l'eterno ritorno

Messaggioda NetNightmare » mer gen 13, 2010 9:30

Effettivamente slackware non e' proprio la distro ottimale per lavorare con samba ... data la mancanza di pam , ad ogni modo dato che tu vuoi utilizzare la modalita' stand-alone potresti innanzi tutto verificare l'output del comando suggerito da Naitso ( e quindi vedere se hai creato gli utenti in samba ). Dopodiche dovresti provare ad inserire nella sezione global :

Codice: Seleziona tutto

encrypt passwords = yes


Ciao

EDIT : inoltre , non e' dasottovalutare che il problema potrebbe ( nota il condizionale) anche dipendere da Windows ..... se stai lavorando in Workgroup verifica che le informazioni di user e workgroup che visualizzi sulla mascherina di logon ( ctrl+alt+canc ) o sulla fastlogin page coincida con quello scritto in questa chiave di registro e sopratutto con quelle inserite in samba

Codice: Seleziona tutto

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon


Spesso infatti succede che l'utente sia creato in fase di installazione , e successivamente venga rinominato o cambiato il nome del workgroup , ma esso cambia solo in visualizzazione ( potete anche non crederci ma e' cosi ) .... se cosi fosse devi ricreare l'utente con il nome di workgroup attuale o crearne uno nuovo

Avatar utente
kens
Linux 2.x
Linux 2.x
Messaggi: 208
Iscritto il: dom giu 06, 2004 0:00
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: KDE

Re: Samba: l'eterno ritorno

Messaggioda kens » mer gen 13, 2010 15:49

NetNightmare ha scritto: ...potresti innanzi tutto verificare l'output del comando suggerito da Naitso ( e quindi vedere se hai creato gli utenti in samba ). Dopodiche dovresti provare ad inserire nella sezione global :

Codice: Seleziona tutto

encrypt passwords = yes




allora... ;)

- Gli utenti Samba sono correttamente mostrati dal comando suggerito da Naitso.
- la modalità "encrypt password", anche se non compare in smb.conf, è attiva (lo è di default, SWAT la omette per questo).
- Per quanto riguarda la chiave di registro di XP controllerò appena possibile.

Di nuovo grazie ! :thumbright:

--