Ubuntu 10.4_x64 e Slackware13.1_64: qualche domanda

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
SIV
Linux 2.6
Linux 2.6
Messaggi: 921
Iscritto il: mer apr 25, 2007 14:07

Ubuntu 10.4_x64 e Slackware13.1_64: qualche domanda

Messaggioda SIV » mar giu 08, 2010 16:54

Ragazzi qualche giorno fa ho deciso su una partizione inutilizzata di piazzare ubuntu 10.4_x64
Solo che ho avuto qualche problemino iniziale:

-Pur avendo scaricato l'apposito flashplayer10 per 64 bit ed avendolo piazzato in .mozilla/plugins/, non funziona a dovere, nel senso che o posso ascoltare l'audio di un video flashplayer o l'audio per esempio di un riproduttore musicale: non contemporaneamente!

-La questione ventole mi è sembrata un po' strana. Sarà il caldo di questi giorni, sarà che è la prima volta che provo qualcosa a 64bit (e quindi forse è normale) sarà la stessa ubuntu ma la ventola di raffreddamento del laptop parte spesso e volentieri.
Con lm-sensors vedo che si aggira sempre sui 47°- 49° ma soprattutto la temperatura della scheda nvidia sui 60°!!
Sono temperature normali secondo voi? Non ricordo dove leggevo che forse per la questione ventola della scheda video possono ifluire i drivers.
In effetti non gli ho installati come normalmente faccio su slack (scarico ed avvio il binario) ma dall'apposita voce "Drivers Hardware" mi pare. Devo provare ad installarli normalmente, mi sa che devo blacklistare qualche modulo.

Altra questione:
-Chi ha slackware 13.1_x64 come si trova?
Ha di questi problemi descritti sopra? E per la questione pacchetti,?

Da questa breve avventura (che comunque sono disposto a continuare sempre risolvendo queste piccole cose) devo dire che ho rivalutato un po' la distro by canonical.
In particolare ho apprezzato:
-L'enorme quantità di software a 64bit che ha nei suoi repository
-Nei giorni in cui non avevo il tempo per smanettare, ho rivalutato apt-get
-Gnome!! Non so perchè ma me lo vedo più solido e carino di Kde. Però devo dire che non ho ancora visto Kde che c'è in slack 13.1 (che sto tra l'altro scaricando per provare).

:-k :-k :thumbright: :thumbright:

Avatar utente
gigiobagiano
Linux 2.6
Linux 2.6
Messaggi: 524
Iscritto il: dom mar 11, 2007 12:58
Nome Cognome: Filippo
Slackware: 14.2
Kernel: vanilla-4.4.38
Desktop: xfce
Distribuzione: SalixOS
Contatta:

Re: Ubuntu 10.4_x64 e Slackware13.1_64: qualche domanda

Messaggioda gigiobagiano » mar giu 08, 2010 17:36

Io ho slackware64-13.1 ( ho utilizzato anche la 13 ), il mio laptop ha due anni e mezzo, ho dovuto ripulire la ventola, non tanto tempo fa, perchè non riusciva più a raffreddarlo (tutti i fori di uscita erano praticamente intasati ), inoltre sempre in questa fase critica, ho effettuato molte ricerche riguardo il controllo delle ventole sotto linux, e ho pure provato con slackware 32 bit, e una mandriva, il risultato non è cambiato, quindi ho concluso che, almeno per quanto mi riguarda, il più o meno carico della ventola è piuttosto indipendente dalla distribuzione ( ovviamente con windows Xp la ventola è praticamente sempre accesa ).
Le mie temperature vanno dai 40-54° gradi per la cpu ( ai 54° ho notato che entra in funzione la ventola), mentre la gpu nvidia nvs 140M punta più in alto, e in genere rimane sempre qualche grado in più della cpu. Insomma per me i 60° che rilevi non sono nulla di preoccupante, ma ogni tanto, dai un'occhiata alle temperature per valutare la bontà della ventola (cioè se riesce effettivamente ad abbassarle), potrebbe essere necessario, come lo è stato per me, dare una buona pulizia al laptop. ;)

Avatar utente
Bakkio2
Linux 2.4
Linux 2.4
Messaggi: 286
Iscritto il: gio mar 24, 2005 0:00
Nome Cognome: Carlo B.
Slackware: 13.37 64
Kernel: 2.6.33.4-smp
Desktop: kde-4.4.3
Località: Villesse (GO)
Contatta:

Re: Ubuntu 10.4_x64 e Slackware13.1_64: qualche domanda

Messaggioda Bakkio2 » mar giu 08, 2010 21:39

gigiobagiano ha scritto:-Pur avendo scaricato l'apposito flashplayer10 per 64 bit ed avendolo piazzato in .mozilla/plugins/, non funziona a dovere, nel senso che o posso ascoltare l'audio di un video flashplayer o l'audio per esempio di un riproduttore musicale: non contemporaneamente!

forse per via di asound?

Avatar utente
SIV
Linux 2.6
Linux 2.6
Messaggi: 921
Iscritto il: mer apr 25, 2007 14:07

Re: Ubuntu 10.4_x64 e Slackware13.1_64: qualche domanda

Messaggioda SIV » mar giu 08, 2010 23:44

Cosa sarebbe? E come si può risolvere?? Thanks

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6463
Iscritto il: gio nov 03, 2005 14:05
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Re: Ubuntu 10.4_x64 e Slackware13.1_64: qualche domanda

Messaggioda targzeta » mer giu 09, 2010 0:03

Anche secondo me le temperature sono ok. Anche io come gigiobagiano ho ripulito la ventola (ma il mio PC ha quasi 4 anni) perchè ormai si accendeva spesso sulle temperature di 74-75° e quasi sempre con una piccola compilazione partiva la seconda velocità. Ora invece parte sempre su 54-55° e porta il PC sui 41-42°, la seconda velocità poi non si attiva quasi mai.

Per il flash player anche io ho lo stesso problema, però penso sia dovuto a firefox o al player più che al resto. Infatti se vedo un video in flash e poi lo metto in pausa posso tranquillamente ascoltare mplayer, se però ascolto mplayer il suono del video flash non lo sento neanche dopo che esco da mplayer.

Se si risolve il problema è tanto di guadagnato :),
Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà 

Avatar utente
Blallo
Packager
Packager
Messaggi: 3292
Iscritto il: ven ott 12, 2007 11:37
Nome Cognome: Savino Liguori
Slackware: 14.2 / 12.2
Kernel: 4.4.14-smp
Desktop: DWM
Località: Torino / Torremaggiore (FG)
Contatta:

Re: Ubuntu 10.4_x64 e Slackware13.1_64: qualche domanda

Messaggioda Blallo » mer giu 09, 2010 0:06

credo sia per firefox
perchè io con chromium non ho problemi del genere
My DWM configuration: https://github.com/8lall0/dwm

Feel free to use.

Avatar utente
SIV
Linux 2.6
Linux 2.6
Messaggi: 921
Iscritto il: mer apr 25, 2007 14:07

Re: Ubuntu 10.4_x64 e Slackware13.1_64: qualche domanda

Messaggioda SIV » mer giu 09, 2010 11:23

spina ha scritto:Anche secondo me le temperature sono ok. Anche io come gigiobagiano ho ripulito la ventola (ma il mio PC ha quasi 4 anni) perchè ormai si accendeva spesso sulle temperature di 74-75° e quasi sempre con una piccola compilazione partiva la seconda velocità. Ora invece parte sempre su 54-55° e porta il PC sui 41-42°, la seconda velocità poi non si attiva quasi mai.

Per il flash player anche io ho lo stesso problema, però penso sia dovuto a firefox o al player più che al resto. Infatti se vedo un video in flash e poi lo metto in pausa posso tranquillamente ascoltare mplayer, se però ascolto mplayer il suono del video flash non lo sento neanche dopo che esco da mplayer.

Se si risolve il problema è tanto di guadagnato :),
Emanuele


Sì anche a me se metto in play o uno o l'altro posso ascoltare l'audio. Solo contemporaneamente non posso ascoltare.

Avatar utente
Bakkio2
Linux 2.4
Linux 2.4
Messaggi: 286
Iscritto il: gio mar 24, 2005 0:00
Nome Cognome: Carlo B.
Slackware: 13.37 64
Kernel: 2.6.33.4-smp
Desktop: kde-4.4.3
Località: Villesse (GO)
Contatta:

Re: Ubuntu 10.4_x64 e Slackware13.1_64: qualche domanda

Messaggioda Bakkio2 » mer giu 09, 2010 23:04

SIV ha scritto:Cosa sarebbe? E come si può risolvere?? Thanks

spero che meska non si incazzi,visto che questa è una sua guida, ma prova a leggere qui e vedere se risol...vi-vete
http://digilander.libero.it/linux352/dmix.html

Avatar utente
absinthe
Iper Master
Iper Master
Messaggi: 2354
Iscritto il: dom mag 15, 2005 0:00
Nome Cognome: Matteo Nunziati
Slackware: 12.1 - defunct
Kernel: 2.6.32-5-amd64
Desktop: gnome
Distribuzione: debian squeeze
Località: Prato
Contatta:

Re: Ubuntu 10.4_x64 e Slackware13.1_64: qualche domanda

Messaggioda absinthe » gio giu 10, 2010 8:19

io utilizzo ubuntu 8.04 64bit - la nuova lts in realtà sotto debina è ancora in testing e infatti piovono aggiornamenti continui (ho la 10.4 su 2 pc che uso per dei calcoli). per flashplayer facevo così:

Codice: Seleziona tutto

aptitude search flash #<- mi trova il player perchè non ricordo mai il nome del pacchetto
aptitude install flashplugin-nonfree #<-installa il plugin di adobe

il pacchetto se ricordo bene scarica dalla rete il plugin. di recente però ho trovato un ppa in cui viene pacchettizzato l'installer per la 10 beta e quindi utilizzo quello per usare flash 10.x.

ho problemi vari anche io e non so quanto sia firefox e quanto il plugin in se. ma direi che sono noie minime in realtà.

per le ventole...girano parecchio anche le mie. puoi vedere cosa fa il kernel buttanto un occhio in /sys per vedere che governor viene utilizzato.

M

Avatar utente
SIV
Linux 2.6
Linux 2.6
Messaggi: 921
Iscritto il: mer apr 25, 2007 14:07

Re: Ubuntu 10.4_x64 e Slackware13.1_64: qualche domanda

Messaggioda SIV » gio giu 10, 2010 12:16

@bakkio2
Ho letto la guida però prima di provarla ho riflettuto che la mia scheda comunque supporta due streams in contemporanea! Del resto su slack 32 bit ha sempre funzionato.
Non è che è il plugin per x86_64 a dare questo problema?

@absinthe
Il plugin flashplugin-nonfree lo avevo installato ma mi aveva crerato dei problemi (l'audio neanche si sentiva più). Ho preferito procedere a mano scaricando l'archivio dal sito adobe.
Per il resto, la seconda parte del tuo messaggio per me è arabo :D

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6463
Iscritto il: gio nov 03, 2005 14:05
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Re: Ubuntu 10.4_x64 e Slackware13.1_64: qualche domanda

Messaggioda targzeta » gio giu 10, 2010 12:36

SIV ha scritto:@bakkio2
Ho letto la guida però prima di provarla ho riflettuto che la mia scheda comunque supporta due streams in contemporanea! Del resto su slack 32 bit ha sempre funzionato.
Non è che è il plugin per x86_64 a dare questo problema?
Io ho letto solo l'introduzione e poi mi sono fermato per lo stesso motivo.[/quote]

SIV ha scritto:@absinthe
Il plugin flashplugin-nonfree lo avevo installato ma mi aveva crerato dei problemi (l'audio neanche si sentiva più). Ho preferito procedere a mano scaricando l'archivio dal sito adobe.
Per il resto, la seconda parte del tuo messaggio per me è arabo :D

Il gevernor è un pezzo del kernel incaricato nella gestione del cpu frequency scaling (l'alternarsi delle frequenze a cui va la CPU). Tutti questi dati li trovi sotto '/sys/devices/system/cpu/cpuNUM/cpufreq' c'è una directory per ogni CPU (io ne ho due, cpu0 e cpu1) che però hanno gli stessi valori. Ad esempio

Codice: Seleziona tutto

$> ls /sys/devices/system/cpu/cpu0/cpufreq/
affected_cpus
bios_limit
conservative
cpuinfo_cur_freq
cpuinfo_max_freq
cpuinfo_min_freq
cpuinfo_transition_latency
related_cpus
scaling_available_frequencies
scaling_available_governors
scaling_cur_freq
scaling_driver
scaling_governor
scaling_max_freq
scaling_min_freq
scaling_setspeed
stats
Ognugo di questi file contiene delle informazioni sul gevernor che usi e sulla frequenza attuale della CPU. Il mio processore attualmente ha una frequenza a 1GHz (la più bassa per questo prodotto):

Codice: Seleziona tutto

$> cat scaling_cur_freq
1000000
Il mio governor attuale è:

Codice: Seleziona tutto

$> cat scaling_governor
conservative
Mentre il driver che uso è:

Codice: Seleziona tutto

$> cat scaling_driver
acpi-cpufreq


Tutte queste e altre informazioni le puoi trovare quando compili il kernel:

Codice: Seleziona tutto

Power management and ACPI options  --->
CPU Frequency scaling  --->


Se il tuo processore supporta il frequency scaling è cosa buona e giusta usarlo, altrimenti il processore va sempre alla massima frequenza scaldandosi di prima.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà 

Avatar utente
gigiobagiano
Linux 2.6
Linux 2.6
Messaggi: 524
Iscritto il: dom mar 11, 2007 12:58
Nome Cognome: Filippo
Slackware: 14.2
Kernel: vanilla-4.4.38
Desktop: xfce
Distribuzione: SalixOS
Contatta:

Re: Ubuntu 10.4_x64 e Slackware13.1_64: qualche domanda

Messaggioda gigiobagiano » gio giu 10, 2010 15:48

Perdonatemi, ma si fa molto prima con:

Codice: Seleziona tutto

cpufreq-info

visto che il pacchetto cpufrequtils è stato inserito da un paio di release di slackware... ;)

Avatar utente
SIV
Linux 2.6
Linux 2.6
Messaggi: 921
Iscritto il: mer apr 25, 2007 14:07

Re: Ubuntu 10.4_x64 e Slackware13.1_64: qualche domanda

Messaggioda SIV » gio giu 10, 2010 16:09

Da me non c'è O_o

Comunque cattando i file che ha elencato spina:

Codice: Seleziona tutto

root@darkstar:/sys/devices/system/cpu/cpu0/cpufreq# cat scaling_cur_freq
800000

Codice: Seleziona tutto

root@darkstar:/sys/devices/system/cpu/cpu0/cpufreq# cat scaling_governor
ondemand


Codice: Seleziona tutto

root@darkstar:/sys/devices/system/cpu/cpu0/cpufreq# cat scaling_driver
acpi-cpufreq

Avatar utente
absinthe
Iper Master
Iper Master
Messaggi: 2354
Iscritto il: dom mag 15, 2005 0:00
Nome Cognome: Matteo Nunziati
Slackware: 12.1 - defunct
Kernel: 2.6.32-5-amd64
Desktop: gnome
Distribuzione: debian squeeze
Località: Prato
Contatta:

Re: Ubuntu 10.4_x64 e Slackware13.1_64: qualche domanda

Messaggioda absinthe » ven giu 11, 2010 11:46

gigiobagiano ha scritto:Perdonatemi, ma si fa molto prima con:

Codice: Seleziona tutto

cpufreq-info

visto che il pacchetto cpufrequtils è stato inserito da un paio di release di slackware... ;)

non sapevo neanche che esistessero!!!
le mie sono abitudini da quando usavo la slack a kernel 2.4 e mi ricompilavo il 2.6 a mano...
ci do un occhio appena ho tempo, grazie!

M

Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3464
Iscritto il: sab giu 26, 2004 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

Re: Ubuntu 10.4_x64 e Slackware13.1_64: qualche domanda

Messaggioda Trotto@81 » ven giu 11, 2010 12:56

Il governor per la cpu lo potete impostare in rc.modules, troverete la sezione dedicata verso la fine dello script.
Di default è impostato su battery per i portatili.
Per il plugin di flash uso lo slackbuild di alien e non ho mai avuto problemi di audio.
Sono molto soddistatto della slack64, valorizza di più l'hardware se utilizzato per calcoli intensivi.


Torna a “Gnu/Linux in genere”

Chi c’è in linea

Visitano il forum: Nessuno e 10 ospiti