Installazione PHP con supporto mysql

Area di discussione libera.

Moderatore: Staff

Regole del forum
1) Rispettare le idee altrui.
2) Evitare le offese dirette.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
scartozzo
Packager
Packager
Messaggi: 253
Iscritto il: mar feb 08, 2005 0:00
Nome Cognome: Flavio Gallucci
Kernel: 3.19
Desktop: fluxbox
Distribuzione: ScarTOzzoLinux
Località: Torino

Installazione PHP con supporto mysql

Messaggioda scartozzo » dom mag 24, 2015 10:55

Buongiorno,
ho installato un server LAMP sul mio SO.
Sembra funzionare tutto al meglio.
Il file php.ini, per quanto concerne il supporto mysql dice

Codice: Seleziona tutto

mysqlnd
mysqlnd   enabled
Version    mysqlnd 5.0.11-dev - 20120503 - $Id: 3c688b6bbc30d36af3ac34fdd4b7b5b787fe5555 $
Compression    supported
core SSL    supported
extended SSL    supported
Command buffer size    4096
Read buffer size    32768
Read timeout    31536000
Collecting statistics    Yes
Collecting memory statistics    No
Tracing    n/a
Loaded plugins    mysqlnd,debug_trace,auth_plugin_mysql_native_password,auth_plugin_mysql_clear_password,auth_plugin_sha256_password
API Extensions    no value


Al momento di installare PHPBB o anche phpfilenavigator2 i messaggi dicono che il supporto a mysql non è abilitato ... e sarebbe necessario ricompilare il php.

Questo è lo script per l'installazione da sorgenti del PHP:

Codice: Seleziona tutto

./configure --prefix=/usr                   \
            --sysconfdir=/etc               \
            --localstatedir=/var            \
            --datadir=/usr/share/php        \
            --mandir=/usr/share/man         \
            --with-apxs2                    \
            --with-config-file-path=/etc    \
            --with-pcre-regex=/usr          \
            --with-zlib                     \
            --with-openssl=shared           \
            --with-pcre-regex=/usr          \
            --enable-bcmath                 \
            --with-bz2                      \
            --enable-calendar               \
            --with-curl                     \
            --enable-dba=shared             \
            --with-gdbm                     \
            --with-gmp                      \
            --enable-ftp                    \
            --with-gettext                  \
            --with-gd=/usr                  \
            --with-jpeg-dir=/usr            \
            --with-png-dir=/usr             \
            --with-zlib-dir=/usr            \
            --with-xpm-dir=/usr             \
            --with-freetype-dir=/usr        \
            --enable-mbstring               \
            --with-readline                 \
            --with-mysql=shared,mysqlnd     \
            --with-mysqli=shared,mysqlnd    \
            --with-mysql-sock=/run/mysqld/mysqld.sock \
            --enable-pdo=shared             \
            --with-pdo-mysql=shared,mysqlnd \
            --with-pdo-sqlite=shared,/usr   \
            --with-sqlite3=shared           \
            --enable-zip=shared             \
            --enable-shared=yes             \
            --enable-static=no              &&
make
#            --enable-fpm                 \
#            --with-fpm-user=apache       \
#            --with-fpm-group=apache      \

make install                                         &&
install -v -m644 php.ini-production /etc/php.ini     &&
# mv -v /etc/php-fpm.conf{.default,}                   &&

install -v -m755 -d /usr/share/doc/php-5.6.6 &&
install -v -m644    CODING_STANDARDS EXTENSIONS INSTALL NEWS README* UPGRADING* php.gif \
                    /usr/share/doc/php-5.6.6 &&
ln -v -sfn          /usr/lib/php/doc/Archive_Tar/docs/Archive_Tar.txt \
                    /usr/share/doc/php-5.6.6 &&
ln -v -sfn          /usr/lib/php/doc/Structures_Graph/docs \
                    /usr/share/doc/php-5.6.6

install -v -m644 ../php_manual_en.html.gz \
    /usr/share/doc/php-5.6.6 &&
gunzip -v /usr/share/doc/php-5.6.6/php_manual_en.html.gz

tar -xvf ../php_manual_en.tar.gz \
    -C /usr/share/doc/php-5.6.6 --no-same-owner


Qualche idea?

Grazie

Avatar utente
scartozzo
Packager
Packager
Messaggi: 253
Iscritto il: mar feb 08, 2005 0:00
Nome Cognome: Flavio Gallucci
Kernel: 3.19
Desktop: fluxbox
Distribuzione: ScarTOzzoLinux
Località: Torino

Re: Installazione PHP con supporto mysql

Messaggioda scartozzo » dom mag 24, 2015 16:57

Omettendo l'opzione shared (--with-mysql=shared,mysqlnd --with-mysqli=shared,mysqlnd --with-pdo-mysql=shared,mysqlnd) scompare il problema.
Mah!

Avatar utente
conraid
Staff
Staff
Messaggi: 13205
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Installazione PHP con supporto mysql

Messaggioda conraid » lun mag 25, 2015 8:25

Ma su che sistema è il tutto, non hai specificato poi la cosa più importante.
Sembra infatti, ed il fatto che compilando staticamente funzioni, tu non abbia caricato la libreria mysql nel file di configurazione.
qualcosa come questo

Codice: Seleziona tutto

extension=mysql.so
extension=mysqli.so
extension=pdo_mysql.so

nel file php.ini