Pagina 2 di 3

Re: Pacchetti per Arduino

Inviato: mer gen 04, 2012 13:57
da Vito
ho aggiornato il pacchetto alla versione 1.0.Come tu dicevi la libreria "ArduinoTestSuite" non è presente.
In ogni caso segnalo sul loro forum questa anomalia,e vediamo cosa mi rispondono.

ecco il thread : http://arduino.cc/forum/index.php/topic,85739.msg642108.html#msg642108

Re: Pacchetti per Arduino

Inviato: mer gen 04, 2012 17:55
da Vito
Probabilmente è la versione di (avr-)gcc.
Appena ho un po' di tempo ricompilo il tutto con una versione precedente a quella attuale e vediamo se funziona definitivamente.

Re: Pacchetti per Arduino

Inviato: mer gen 04, 2012 19:11
da leocata
Io ho ricompilato anche quello con gli slackbuilds ed attualmente ho istallato questo:
bash-4.1$ ls /var/log/packages/avr*
/var/log/packages/avr-binutils-2.21.1-i486-1_SBo
/var/log/packages/avr-gcc-4.5.3-i486-1_SBo
/var/log/packages/avr-libc-1.7.1-i486-1_SBo
/var/log/packages/avrdude-5.11.1-i486-1_SBo
credo che sia un bug connesso con di arduino...

Re: Pacchetti per Arduino

Inviato: mer gen 04, 2012 20:00
da Vito

Codice: Seleziona tutto

/var/log/packages/avr-gcc-4.5.3-i486-1_SBo

è la stessa versione dei miei pacchetti.
Ora faccio un downgrade e ti faccio sapere.

Re: Pacchetti per Arduino

Inviato: mer gen 04, 2012 21:58
da Vito
Con la versione 4.4.3 di gcc il problema permane.

Re: Pacchetti per Arduino

Inviato: mer gen 04, 2012 23:19
da leocata
io credo che qualche file che il linker usa sia baggato.... mentre nell'uso con la famosa libreria linka qualche file ok. Puo' essere?

Re: Pacchetti per Arduino

Inviato: mer gen 04, 2012 23:22
da Vito
Infatti ora provo a fare il downgrade anche di binutils alla 2.20.1 .
Questa è l'ultima prova che faccio per adesso (anche perchè sto ricompilando di tutto da quando ho smesso di studiare e sono abbastanza stanco).
Mi hanno consigliato di inlcudere anche la libreria "serial".

Re: Pacchetti per Arduino

Inviato: gio gen 05, 2012 0:20
da Vito
Funziona!!!Faccio l'upload dei pacchetti e degli slackbuild domani ad ora di pranzo.(Ora sono troppo assonnato :sleepy2: )
Se vuoi posso farti avere i pacchetti anche a 32bit.Magari chiedo a qualche packager per x86 di compilarli.
La "suite" completa adesso è formata da:

  • avr-binutils-2.20.1-x86_64-1sl
  • avr-gcc-4.3.3-x86_64-2sl
  • avr-libc-1.7.1-x86_64-5sl
  • avrdude-5.10-x86_64-1sl
  • arduino-1.0-x86_64-4sl

Re: Pacchetti per Arduino

Inviato: gio gen 05, 2012 10:01
da leocata
Ok grazie ho risolto.... ho ricompilato anch'io avr-binutils attraverso lo slackbuilds alla versione avr-binutils-2.20.1-i486-1_SBo.tgz. Comunque il package su slacky mi sa che sono da aggiornare :-k .
Offtopic: In bocca al lupo con gli esami :thumbright:

Re: Pacchetti per Arduino

Inviato: gio gen 05, 2012 12:34
da Vito
quelli per per x86_64 li carico dopo pranzo.

Offtopic: Crepi il lupo (o Grazie a seconda di come si intenda il detto)

Re: Pacchetti per Arduino

Inviato: gio gen 05, 2012 14:59
da Vito
Caricati.

Re: Pacchetti per Arduino

Inviato: ven gen 06, 2012 19:30
da Vito
a breve saranno disponibili anche i pacchetti per x86.

Re: Pacchetti per Arduino

Inviato: dom ott 07, 2012 0:57
da Vito
il prima possibile preparo i pacchetti per la 14.0

Re: Arduino on Slackware

Inviato: ven gen 11, 2013 12:24
da gda
Ho provato ad installare i pacchetti su slackware 13.37 32bit.
Tuttavia quando dalla suite Java arduino cerco di compilare ottengo il seguente messaggio di errore:

Codice: Seleziona tutto

/usr/libexec/gcc/avr/4.3.3/cc1plus: error while loading shared libraries: libmpfr.so.4: cannot open shared object file: No such file or directory


Che indica una incompatibilita' con la versione delle librerie mpfr installate sul mio pc. Visto che tali librerie sono librerie di base utilizzate anche dal compilatore gcc preferirei non aggiornarle per evitare poi di dover poi aggiornare anche gcc...

Come posso risolvere?

Grazie
Ciao!

Re: Arduino on Slackware

Inviato: ven gen 11, 2013 12:39
da Vito
Se mi dai un po' di tempo simulo questa cosa su una Slackware 13.37 e ti faccio sapere.
Puoi cominciare col dirmi quali pacchetti (della suite di Arduino) hai installato?