[RISOLTO] flash in blu (driver nvidia proprietari)

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
boh
Linux 4.x
Linux 4.x
Messaggi: 1027
Iscritto il: ven 16 set 2005, 0:00
Slackware: 14.2 (x64)
Kernel: 4.4.111
Desktop: KDE 4.14.32
Località: Milano
Contatta:

Re: flash in blu

Messaggio da boh »

Riesumo il topic per un dubbio.
Con il rilascio della versione 14, il vecchio plugin (versione 11.1) che avevo installato non funziona più. Ho controllato su sBo per uno slackbuild della stessa versione, ma nulla da fare. Così ho installato il pacchetto di alienBob (versione 11.2.202.243) e ovviamente l'effetto puffo è apparso puntualmente.

Seguendo i consigli di questo topic ho provato a disabilitare l'accelerazione hardware dalle impostazioni di flash player (tasto destro sul video --> settings) ed effettivamente funziona.
Ora le mie domande sono principalmente due:
  • lasciando la voce disabilitata, l'unica parte in cui non viene usata l'accelerazione hardware è lo streaming video? Ovvero, effetti grafici desktop e altro continuano eventualmente ad usufruire di questa feature?
  • disabilitando tale opzione, la visione di video in alta definizione risulterà quindi più lenta?
Oltre a queste, ho la domanda da un milione di dollari: non è che per caso è stata trovata qualche soluzione a questo problema? :-k
"Be yourself. Everyone else is already taken." ~ Oscar Wilde

Avatar utente
tornadomig
Linux 3.x
Linux 3.x
Messaggi: 579
Iscritto il: gio 30 set 2010, 15:17
Nome Cognome: Giorgio
Slackware: Current64 multilib
Kernel: -current
Desktop: Xfce

Re: flash in blu

Messaggio da tornadomig »

http://www.z01.eu/repo-slack/slackware6 ... er-plugin/

i puffi son cosi' tralala' e via cosi'...scherzi a parte, metti il primo che e' quello che mantiene l'accelerazione senza "bluare" tutto...almeno, io uso quello oppure ti installi google-chrome o chromium che ce l' hanno ficcato dentro chissa' perche' quelli di adobe ed e' un po' piu' aggiornato

e cosi' mi permetti di ringraziare ancora una volta il buon ZeroUno ;)
rm -rf / && rm -rf . && rm -rf *

Avatar utente
ZeroUno
Staff
Staff
Messaggi: 5300
Iscritto il: ven 2 giu 2006, 14:52
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current
Località: Roma / Castelli
Contatta:

Re: flash in blu

Messaggio da ZeroUno »

non mi risulta che chromium abbia flash incorporato, ma si appoggia a quello di sistema come firefox.
Google chrome ce l'ha non perché ce l'ha messo adobe. Adobe ha dichiarato morto flash per linux e google ha chiesto il permesso di continuare a manutenerlo lui ma chiaramente solo per il suo browser. Esiste un workaround per estrarlo da chrome ed inserirlo in chromium ma non in firefox.

Io comunque tengo il 10.2 e disattivo l'accelerazione quando vedo youtube e la riattivo quando ho finito. Il problema é che l'accelerazione della 11.1 non mi funge bene su alcune applicazioni.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg

Codice: Seleziona tutto

1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111

Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3557
Iscritto il: sab 26 giu 2004, 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

Re: flash in blu

Messaggio da Trotto@81 »

Con libvdpau 0.5 non ho più quelle effetto.

Avatar utente
ZeroUno
Staff
Staff
Messaggi: 5300
Iscritto il: ven 2 giu 2006, 14:52
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current
Località: Roma / Castelli
Contatta:

Re: flash in blu

Messaggio da ZeroUno »

Io uso i driver proprietari.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg

Codice: Seleziona tutto

1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111

Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3557
Iscritto il: sab 26 giu 2004, 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

Re: flash in blu

Messaggio da Trotto@81 »

Anche io, il tuo pacchetto per essere precisi. :)

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2738
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.5.3-ck1
Desktop: lxde
Località: Pisa
Contatta:

Re: flash in blu

Messaggio da ponce »

Trotto@81 ha scritto:Con libvdpau 0.5 non ho più quelle effetto.
si, dovrebbe essere questo aggiornamento quello che risolve il problema (ce l'avevo anch'io).

Avatar utente
tornadomig
Linux 3.x
Linux 3.x
Messaggi: 579
Iscritto il: gio 30 set 2010, 15:17
Nome Cognome: Giorgio
Slackware: Current64 multilib
Kernel: -current
Desktop: Xfce

Re: flash in blu

Messaggio da tornadomig »

@ZeroUno

grazie per la correzione! :thumbright:
rm -rf / && rm -rf . && rm -rf *

Avatar utente
boh
Linux 4.x
Linux 4.x
Messaggi: 1027
Iscritto il: ven 16 set 2005, 0:00
Slackware: 14.2 (x64)
Kernel: 4.4.111
Desktop: KDE 4.14.32
Località: Milano
Contatta:

Re: flash in blu

Messaggio da boh »

Ragazzi scusate, mi avete un attimo confuso.
Allora:
- chromium, come già detto, si appoggia sul plugin del sistema;
- la versione 11.1 presente nel repo di ZeroUno è quella senza effetto puffo, ma è compilata su una current di giugno; andrebbe bene ugualmente o me lo ricompilo con lo slackbuild per la 14?
- libvdpau che librerie sono? E in che modo risolvono il problema? Potrebbe essere una soluzione migliore al downgrade, visto che in teoria una versione più aggiornata di flash è anche più sicura :-k
"Be yourself. Everyone else is already taken." ~ Oscar Wilde

Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3557
Iscritto il: sab 26 giu 2004, 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

Re: flash in blu

Messaggio da Trotto@81 »

Flash non si compila, puoi installare tranquillamente una versione precedente.
Il pacchetto libvdpau contiene gli header per la compilazione di programmi che usano le GPU Nvidia per l'accelerazione hardware dei video; la versione 0.5 contiene il fix che dava l'effetto puffo sull'ultima versione con driver Nvidia ufficiali.

Avatar utente
boh
Linux 4.x
Linux 4.x
Messaggi: 1027
Iscritto il: ven 16 set 2005, 0:00
Slackware: 14.2 (x64)
Kernel: 4.4.111
Desktop: KDE 4.14.32
Località: Milano
Contatta:

Re: flash in blu

Messaggio da boh »

Sì, lo sapevo, ho sbagliato a scrivere :D (E in effetti non avrei neanche dovuto scriverlo :badgrin: )
Ma quindi il problema è dei driver nVidia, del plugin o dell'usare questi due elementi insieme?
Comunque a questo punto credo valga la pena installare le librerie vdpau...
"Be yourself. Everyone else is already taken." ~ Oscar Wilde

Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3557
Iscritto il: sab 26 giu 2004, 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

Re: flash in blu

Messaggio da Trotto@81 »

Io l'ho installata e con l'ultimissima versione di flash per linux e dei driver nvidia niente effetto puffo con accelerazione hw attiva.

Avatar utente
ZeroUno
Staff
Staff
Messaggi: 5300
Iscritto il: ven 2 giu 2006, 14:52
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current
Località: Roma / Castelli
Contatta:

Re: flash in blu

Messaggio da ZeroUno »

vediamo quello che riesco a fare quando ho tempo.

Si accettano consigli:
1) metto nel pacchetto i driver nvidia E il nuovo libvdpao
2) tolgo del tutto vdpau dal pacchetto, faccio un nuovo pacchetto per solo vdpau e ci metto un legame di dipendenz
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg

Codice: Seleziona tutto

1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111

Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3557
Iscritto il: sab 26 giu 2004, 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

Re: flash in blu

Messaggio da Trotto@81 »

Gli header sono a parte, puoi reinglobarli come un tempo, ma non capisco cosa dici togliere vdpau dal pacchetto e farlo separatamente.

Avatar utente
tornadomig
Linux 3.x
Linux 3.x
Messaggi: 579
Iscritto il: gio 30 set 2010, 15:17
Nome Cognome: Giorgio
Slackware: Current64 multilib
Kernel: -current
Desktop: Xfce

Re: flash in blu

Messaggio da tornadomig »

@Trotto

ricordo sfilare tra i vari log di compilazione del pacchetto nvidia anche quelli di vdpau, se non erro.

e' giusto, ZeroUno?
rm -rf / && rm -rf . && rm -rf *

Rispondi