Pagina 1 di 1

[RISOLTO] Libreoffice su Slack14

Inviato: gio ott 11, 2012 16:43
da amevolley
Ciao a tutti,
qual e' il metodo consigliato per installare Libreoffice su slackware 14?
Il txz del 13.37 non funziona.

Re: Libreoffice su Slack14

Inviato: gio ott 11, 2012 17:34
da goodlife
In attesa di Slacky.eu ho scaricato i txz dal repo di Salix. La versione è la 3.6.1. Per il momento tutto funziona e non ho problemi.
Omar

Re: Libreoffice su Slack14

Inviato: gio ott 11, 2012 19:07
da joseph
Stessa cosa ho fatto io su una macchina virtuale, sembra funzionare tutto alla perfezione 8)

Re: Libreoffice su Slack14

Inviato: gio ott 11, 2012 20:00
da tornadomig
ciao! nel frattempo puoi guardare intanto qui, leggi e segui la guida, e' ottima!

http://submax.altervista.org/index.php?link=slackware/libreoffice-autobuilder-multilang.php

e se non ti basta, puoi anche andare a trovare il buon alienbob

http://www.slackware.com/~alien/slackbuilds/libreoffice/build/

e se non vuoi compilare, installa direttamente i pacchetti per la tua architettura

http://www.slackware.com/~alien/slackbuilds/libreoffice/pkg/13.37/

l' esempio sopra riportato vale anche per la slackware 14 x86.

spero di averti aiutato :)

Re: Libreoffice su Slack14

Inviato: gio ott 18, 2012 14:09
da amevolley
Tutto OK con l'autobuilder... Per gli altri programmi non compresi nella distribuzione, invece, ho ancora ben capito se gli "slackbuilds" possono veramente risolvere le incompatibilita' che si riscontrano cambiando la versione di Slackware. Di fatto sono da settimane ancora al lavoro sulla Slack12, mentre proseguo l'infinito lavoro di personalizzazione della 14 nel poco tempo libero...questo scenario non e' molto invitante per il cambio versione...

Re: [RISOLTO] Libreoffice su Slack14

Inviato: gio ott 18, 2012 15:57
da Loris
Provate questo http://www.slacky.eu/asche/pkgs/index.p ... 6&pkg=1367 è quello di Submax... anzi ditemi se ci sono problemi.
Ciao.
Loris

Re: [RISOLTO] Libreoffice su Slack14

Inviato: gio ott 18, 2012 18:11
da Xunyl
Loris ha scritto:Provate questo http://www.slacky.eu/asche/pkgs/index.p ... 6&pkg=1367 è quello di Submax... anzi ditemi se ci sono problemi.
Ciao.
Loris

Provato, nessun problema :thumbright:

Re: [RISOLTO] Libreoffice su Slack14

Inviato: ven ott 19, 2012 20:17
da ZeroUno
Loris ha scritto:Provate questo

ma lo slackbuild non è un (bel) po' "anomalo" per i canoni slacky?

Re: [RISOLTO] Libreoffice su Slack14

Inviato: ven ott 19, 2012 20:21
da gohanz
Perchè non aggiorniamo lo SlackBuild di Libreoffice della 13.37, parlo della versione compilata.

Re: [RISOLTO] Libreoffice su Slack14

Inviato: ven ott 19, 2012 20:28
da Loris
Andrea io ho tentato ma non sono riuscito :(

Re: [RISOLTO] Libreoffice su Slack14

Inviato: ven ott 19, 2012 20:30
da gohanz
Loris ha scritto:Andrea io ho tentato ma non sono riuscito :(


Anche io non ci sono riuscito! #-o

Re: [RISOLTO] Libreoffice su Slack14

Inviato: sab ott 20, 2012 16:04
da ZeroUno
gohanz ha scritto:Anche io non ci sono riuscito! #-o

Quali sono i problemi che si incontrano?

Re: [RISOLTO] Libreoffice su Slack14

Inviato: sab ott 20, 2012 22:30
da ZeroUno
Chi ha provato il pacchetto di submax (l'autobuilder), quello di alien e quello di salix (e quello di qualcun altro), che differenze trova?

Re: [RISOLTO] Libreoffice su Slack14

Inviato: sab ott 20, 2012 22:38
da gohanz
ZeroUno ha scritto:
gohanz ha scritto:Anche io non ci sono riuscito! #-o

Quali sono i problemi che si incontrano?


Uno dei tanti è scaricare la miriade di pacchetti dei sorgenti. Prima c'era uno script lanciato dallo SlackBuild che si occupava di scaricare tutto l'occorrernte per la compilazione. Ha funzionato fino alla versione presente sul repository 13.37.

Re: [RISOLTO] Libreoffice su Slack14

Inviato: dom ott 21, 2012 1:37
da ZeroUno
A me il download ha funzionato
v. http://dev-www.libreoffice.org/bundles/ ... rom_tar.sh
per il download dei primi pacchetti (la wget $SOURCE è obsoletata)

ora lo sto compilando al volo, giusto come dry (so che fallirà).
Per ora ho dovuto commentare tutte le patch e aggiungere al configure
--without-krb5 \
--without-gssapi \
--disable-gnome-vfs \
--without-junit \

domani continuo (spero)


piuttosto noto, senza approfondire, che alienbob ha usato un bel po' di patch