Aggiornare MPlayer di Pat a H.265

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Meskalamdug
Iper Master
Iper Master
Messaggi: 3806
Iscritto il: ven mag 14, 2004 0:00

Re: Aggiornare MPlayer di Pat a H.265

Messaggioda Meskalamdug » mer nov 11, 2015 22:04

hashbang ha scritto:
Trotto@81 ha scritto:Sarà la mia GeForce 8600GT un po' vetusta?
La 8600GT ha supporto alla decodifica hw per H.264 (<= High Profile) e VC-1.
Se non ricordo male il supporto ad HEVC parte dalle GPU Maxwell 2nd gen.
Nelle Maxwell 1st gen si usava un decoding misto in quanto non c'era il pieno supporto, quindi era metà hw e metà sw.

Quindi sebbene libvdpau abbia il supporto ad HEVC non riuscirai comunque ad avere decodifica hw, perché ti manca il supporto a livello di periferica.

Meskalamdug ha scritto:Sto provando ora un video h265,la qualità è ottima ma consuma il 100% della cpu.
È la mia scheda troppo vecchia?
No, penso sia più un problema di CPU e uscita video.

Di CPU in quanto un video HEVC richiede molta più potenza di calcolo di un video AVC (H.264) e di certo quella risoluzione video non ti aiuta, specie con CPU poco prestanti, e di uscita video in quanto potresti stare forzando la CPU ad usare uscite accelerate come quelle basate su OpenGL.

Prova ad usare uscite basate su X11 che richiedono poca potenza di calcolo a scapito della qualità. Su MPlayer se non ricordo male dovrebbe essere -vo=xv.

Nel mio caso, per esempio, che ho un Celeron B830 Sandy Bridge, il video "ducks-take-off" ha necessitato della rimozione dello smooth motion sull'uscita video opengl-hq di mpv, altrimenti laggava di brutto nel momento in cui le anatre spiccavano il volo.
Però senza smooth motion l'ho riprodotto senza problemi.

Ah, un consiglio: cerca di prendere video che non siano più grandi della tua risoluzione perché altrimenti metti in gioco algoritmi di downscaling che essendo usati in playback consumano un bel po', oltre ad introdurre artefatti.

Perfetto grazie