Pagina 3 di 3

Re: Aggiornare MPlayer di Pat a H.265

Inviato: sab nov 07, 2015 22:11
da Meskalamdug
ponce ha scritto:mi sembra che l'errore sia relativo al fatto che non trova un header specifico del raspberrypi, bcm_host.h: non e' che lo stai compilando per quella piattaforma? puo' darsi anche che gli script di build di MPlayer lo facciano in automatico se hai installato mmal (ipotizzo)...

Meskalamdug ha scritto:Io ho una scheda abbastanza vecchia,possibile sia per quello che non ritorna h265?

non credo, il comando per testare l'ho dato su una macchina virtuale dove sicuramente fa la decodifica via software.

Vero infatti anche su freebsd mi da 265 abilitato(macchina virtuale)

Re: Aggiornare MPlayer di Pat a H.265

Inviato: sab nov 07, 2015 22:12
da Trotto@81
Allora, ho compilato con il file del tuo archivio e non ricevo errore, ho tra i decoder vdpau disponibili quello per HEVC, ma non lo usa. Sarà la mia GeForce 8600GT un po' vetusta?

EDIT: Ho notato che i driver non mi danno HEVC tra i codec supportati da VDPAU, devo provare ad aggiornare anche loro.

Re: Aggiornare MPlayer di Pat a H.265

Inviato: sab nov 07, 2015 22:16
da ponce
Trotto@81 ha scritto:Allora, ho compilato con il file del tuo archivio e non ricevo errore, ho tra i decoder vdpau disponibili quello per HEVC, ma non lo usa. Sarà la mia GeForce 8600GT un po' vetusta?

devi usare vdpau come video output: o gli passi da linea di comando l'opzione "-vo vdpau" o aggiungi al file ~/.mplayer/config la linea

Codice: Seleziona tutto

vo = vdpau

a quello che leggo su wikipedia sono veramente poche le schede che supportano il decoding di hevc in hardware
https://en.wikipedia.org/wiki/Nvidia_Pu ... reVideo_HD

Re: Aggiornare MPlayer di Pat a H.265

Inviato: sab nov 07, 2015 22:22
da Trotto@81
Il parametro lo passa SMPlayer in automatico, però noto dal tuo link che la mia VGA è di classe A, ovvero non supporta il decoding hardware di HEVC.

Re: Aggiornare MPlayer di Pat a H.265

Inviato: dom nov 08, 2015 16:26
da Trotto@81
Appena scende sotto le 100€ una bella GTX 950 per sostituire la mia vetusta 8600 GT è la benvenuta. :D

Re: Aggiornare MPlayer di Pat a H.265

Inviato: mar nov 10, 2015 9:19
da Meskalamdug
Pazzesco!
Sarà il driver nvidia o che?
Macchina virtuale,slack64 pulita

Codice: Seleziona tutto

mplayer -vc help | grep -i h.265
ffhevc      ffmpeg    working   FFmpeg HEVC / H.265  [hevc]
ffhevcvdpau ffmpeg    working   FFmpeg HEVC / H.265 (VDPAU)  [hevc]


Macchina slack64 host,scheda nvidia

Codice: Seleziona tutto

mplayer -vc help | grep -i h.265



Ovviamente il pacchetto è lo stesso(compilato sulla macchina virtuale,ricompilandolo sull'host stesso risultato)
Che sarà mai?Il driver nvidia?

Re: Aggiornare MPlayer di Pat a H.265

Inviato: mar nov 10, 2015 9:28
da Trotto@81
I pacchetti sono identici anche nella configurazione?

Re: Aggiornare MPlayer di Pat a H.265

Inviato: mar nov 10, 2015 9:48
da Meskalamdug
Ho risolto,era un vetusto(del 2011!) codecs.conf in /etc/mplayer
,eliminato,ora va.

Re: Aggiornare MPlayer di Pat a H.265

Inviato: mar nov 10, 2015 9:50
da Meskalamdug
Sto provando ora un video h265,la qualità è ottima ma consuma il 100% della cpu.
È la mia scheda troppo vecchia?

Codice: Seleziona tutto

01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 210] (rev a2)

Re: Aggiornare MPlayer di Pat a H.265

Inviato: mar nov 10, 2015 9:58
da Trotto@81
Non credo centri la vga visto che la decodifica è eseguita dalla CPU.
Il mio i7 920 non supera mai il 25% di carico durante la visione.

Re: Aggiornare MPlayer di Pat a H.265

Inviato: mer nov 11, 2015 1:23
da Meskalamdug
Sarà perchè era un hd 1920x960?
Qualcuno ha un link con filmati meno corposi?

Re: Aggiornare MPlayer di Pat a H.265

Inviato: mer nov 11, 2015 6:55
da ponce

Re: Aggiornare MPlayer di Pat a H.265

Inviato: mer nov 11, 2015 9:20
da Trotto@81
Meskalamdug ha scritto:Sarà perchè era un hd 1920x960?
Qualcuno ha un link con filmati meno corposi?

Il mio è 1920x1030. :D

Re: Aggiornare MPlayer di Pat a H.265

Inviato: mer nov 11, 2015 10:58
da hashbang
Trotto@81 ha scritto:Sarà la mia GeForce 8600GT un po' vetusta?
La 8600GT ha supporto alla decodifica hw per H.264 (<= High Profile) e VC-1.
Se non ricordo male il supporto ad HEVC parte dalle GPU Maxwell 2nd gen.
Nelle Maxwell 1st gen si usava un decoding misto in quanto non c'era il pieno supporto, quindi era metà hw e metà sw.

Quindi sebbene libvdpau abbia il supporto ad HEVC non riuscirai comunque ad avere decodifica hw, perché ti manca il supporto a livello di periferica.

Meskalamdug ha scritto:Sto provando ora un video h265,la qualità è ottima ma consuma il 100% della cpu.
È la mia scheda troppo vecchia?
No, penso sia più un problema di CPU e uscita video.

Di CPU in quanto un video HEVC richiede molta più potenza di calcolo di un video AVC (H.264) e di certo quella risoluzione video non ti aiuta, specie con CPU poco prestanti, e di uscita video in quanto potresti stare forzando la CPU ad usare uscite accelerate come quelle basate su OpenGL.

Prova ad usare uscite basate su X11 che richiedono poca potenza di calcolo a scapito della qualità. Su MPlayer se non ricordo male dovrebbe essere -vo=xv.

Nel mio caso, per esempio, che ho un Celeron B830 Sandy Bridge, il video "ducks-take-off" ha necessitato della rimozione dello smooth motion sull'uscita video opengl-hq di mpv, altrimenti laggava di brutto nel momento in cui le anatre spiccavano il volo.
Però senza smooth motion l'ho riprodotto senza problemi.

Ah, un consiglio: cerca di prendere video che non siano più grandi della tua risoluzione perché altrimenti metti in gioco algoritmi di downscaling che essendo usati in playback consumano un bel po', oltre ad introdurre artefatti.

Re: Aggiornare MPlayer di Pat a H.265

Inviato: mer nov 11, 2015 22:04
da Meskalamdug
hashbang ha scritto:
Trotto@81 ha scritto:Sarà la mia GeForce 8600GT un po' vetusta?
La 8600GT ha supporto alla decodifica hw per H.264 (<= High Profile) e VC-1.
Se non ricordo male il supporto ad HEVC parte dalle GPU Maxwell 2nd gen.
Nelle Maxwell 1st gen si usava un decoding misto in quanto non c'era il pieno supporto, quindi era metà hw e metà sw.

Quindi sebbene libvdpau abbia il supporto ad HEVC non riuscirai comunque ad avere decodifica hw, perché ti manca il supporto a livello di periferica.

Meskalamdug ha scritto:Sto provando ora un video h265,la qualità è ottima ma consuma il 100% della cpu.
È la mia scheda troppo vecchia?
No, penso sia più un problema di CPU e uscita video.

Di CPU in quanto un video HEVC richiede molta più potenza di calcolo di un video AVC (H.264) e di certo quella risoluzione video non ti aiuta, specie con CPU poco prestanti, e di uscita video in quanto potresti stare forzando la CPU ad usare uscite accelerate come quelle basate su OpenGL.

Prova ad usare uscite basate su X11 che richiedono poca potenza di calcolo a scapito della qualità. Su MPlayer se non ricordo male dovrebbe essere -vo=xv.

Nel mio caso, per esempio, che ho un Celeron B830 Sandy Bridge, il video "ducks-take-off" ha necessitato della rimozione dello smooth motion sull'uscita video opengl-hq di mpv, altrimenti laggava di brutto nel momento in cui le anatre spiccavano il volo.
Però senza smooth motion l'ho riprodotto senza problemi.

Ah, un consiglio: cerca di prendere video che non siano più grandi della tua risoluzione perché altrimenti metti in gioco algoritmi di downscaling che essendo usati in playback consumano un bel po', oltre ad introdurre artefatti.

Perfetto grazie