[SOLVED] problema aMule 2.3.1 64bit e libbfd

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
F4B1CK
Linux 2.4
Linux 2.4
Messaggi: 248
Iscritto il: dom gen 11, 2004 0:00
Slackware: current 64 bit
Kernel: 4.4.x
Desktop: KDE 5
Località: Cosenza
Contatta:

[SOLVED] problema aMule 2.3.1 64bit e libbfd

Messaggioda F4B1CK » mer dic 09, 2015 16:16

Ciao,
sono in current a 64 bit e da quando ho aggiornato il pacchetto : aMule-2.3.1_r10834-x86_64-1sl
non riconosce più la libreria libbfd che attualmente è la : binutils-2.25.1-x86_64-1

mi da questo errore :

amule: error while loading shared libraries: libbfd-2.23.52.0.1.20130226.so: cannot open shared object file: No such file or directory

l'unica soluzione è creare un symlink alla libreria oppure c'è un aggiornamento?

Grazie
Ultima modifica di F4B1CK il gio dic 10, 2015 13:02, modificato 1 volta in totale.

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2713
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: problema aMule 2.3.1 64bit e libbfd

Messaggioda joe » mer dic 09, 2015 17:07

Potresti provare a ricompilare amule costruendo il pacchetto in locale, in modo che sia dipendente dalla libreria che hai effettivamente installata sul sistema..
Quel pacchetto sembrerebbe aspettarsi la libbfd-2.23.x, mentre sul tuo sistema hai la più recente 2.25.x.

Avatar utente
Rama
Linux 2.4
Linux 2.4
Messaggi: 301
Iscritto il: sab mar 29, 2008 12:18
Slackware: 14.2 64bit
Kernel: 4.8.2 preemptive
Desktop: KDE 4.14.21
Distribuzione: Debian
Località: Novara, provincia
Contatta:

Re: problema aMule 2.3.1 64bit e libbfd

Messaggioda Rama » mer dic 09, 2015 18:29

io faccio i link simbolici -al plurale perché mi sa che dovrai farne mezza dozzina;
sulla tosticità della Slackware, ovvero distro sedicenti facili e realmente tali:
http://www.umpf.net/ramapage/sulla.htm

F4B1CK
Linux 2.4
Linux 2.4
Messaggi: 248
Iscritto il: dom gen 11, 2004 0:00
Slackware: current 64 bit
Kernel: 4.4.x
Desktop: KDE 5
Località: Cosenza
Contatta:

Re: problema aMule 2.3.1 64bit e libbfd

Messaggioda F4B1CK » mer dic 09, 2015 22:00

Grazie mille per le risposte.
Volevo evitare i link selvaggi sperando in un aggiornamento del pacchetto, ma mi sa che dovrò adottare questa soluzione.
Ho provato a vedere in giro se ci sono software più aggiornati per la gestione delle reti che gestisce emule ma non ho trovato granché.

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2713
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: problema aMule 2.3.1 64bit e libbfd

Messaggioda joe » gio dic 10, 2015 0:08

Ma hai provato a crearti il pacchetto a partire da questo slackbuild?

http://repository.slacky.eu/slackware64 ... SlackBuild

Personalmente proverei a scaricarmi tutto il contenuto della directory sorgente:

Codice: Seleziona tutto

lftp -c "http://repository.slacky.eu/slackware64-14.1/network/aMule/2.3.1_r10834/; mirror src"
cd src
chmod +x *.Slackbuild
./aMule.SlackBuild

E ti dovrebbe creare un .txz nella dir corrente, che poi andrai ad installare con installpkg...
L'eseguibile "amule" (o quel che è) contenuto in quel pacchetto non dovrebbe avere problemi di librerie mancanti perchè dovrebbe venire "linkato" precisamente a quelle che hai sul sistema al momento della compilazione del programma..
Insomma, prova...
Ripensando a quello che ho appena scritto e vedendo che usi slack current, probabilmente dovresti già avere confidenza con questa procedura... Perchè per quel che sapevo il parco software precompilato per current è molto più ridotto rispetto a quello per le versioni stabili... e quindi tanta roba di cui non trovi il precompilato te la devi pacchettizzare in locale possibilmente sfruttando, come in questo caso slackbuilds già pronti.
Boo, prova un po'...
Se invece il problema è un altro allora ho interpretato male io la tua situazione... :)

erio
Linux 3.x
Linux 3.x
Messaggi: 1189
Iscritto il: ven ott 09, 2009 19:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: problema aMule 2.3.1 64bit e libbfd

Messaggioda erio » gio dic 10, 2015 9:32

per la current c'e' il repository personale di ponce: http://ponce.cc/slackware/slackware64-current/packages/

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2194
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.14.0
Desktop: lxde
Località: Pisa
Contatta:

Re: problema aMule 2.3.1 64bit e libbfd

Messaggioda ponce » gio dic 10, 2015 9:46

erio ha scritto:per la current c'e' il repository personale di ponce: http://ponce.cc/slackware/slackware64-current/packages/

scusatemi se faccio questa precisazione per l'ennesima volta (meglio una di piu' che una di meno): fa ancora fede quello che e' scritto nel README ;)

poi, da qualche tempo, c'e' anche slackonly che, sebbene usi gli script di SlackBuilds.org, il fork per current di questi che abbiamo fatto con David Spencer e lo slackrepo di quest'ultimo, e' gestito da un utente Slackware, Panagiotis Nikolaou, che lo fa come iniziativa personale (anche se David gli ha dato una grossa mano).

F4B1CK
Linux 2.4
Linux 2.4
Messaggi: 248
Iscritto il: dom gen 11, 2004 0:00
Slackware: current 64 bit
Kernel: 4.4.x
Desktop: KDE 5
Località: Cosenza
Contatta:

Re: problema aMule 2.3.1 64bit e libbfd

Messaggioda F4B1CK » gio dic 10, 2015 13:02

joe ha scritto:Ma hai provato a crearti il pacchetto a partire da questo slackbuild?

http://repository.slacky.eu/slackware64 ... SlackBuild

...



Ciao, abitualmente infatti creo io il pacchetto di aMule dallo Slackbuild e funziona tutto regolarmente.
Dopo l'ultimo aggiornamento però non mi andava e quindi ero passato al precompilato.

Ho risolto creando un solo simlink (è andata bene) ed intallando il pacchetto che fornisce libGeoIP (che è richiesto).

Non avevo mai letto il README.txt di Ponce, ora che l'ho fatto ho aggiunto gli utenti ed i gruppi consigliati :-P ...ma essendo in current sono consapevole di tutti i rischi :-D

Io ho configurato slackpkgplus per usare questo repository : http://ponce.cc/slackers/repository/
contiene le stesse cose di quello suggerito, ovvero : http://ponce.cc/slackware/slackware64-current/packages/

oppure devo inserirli entrambi?

Grazie come sempre a tutti! In ogni caso segno il thread come risolto.

Avatar utente
conraid
Staff
Staff
Messaggi: 12954
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: [SOLVED] problema aMule 2.3.1 64bit e libbfd

Messaggioda conraid » gio dic 10, 2015 13:14

ehm, il primo è il mio, che il buon ponce ospita da quando non ho più slackers.it. Appena finisco un paio di lavori mi metto a fare delle pagine e sistemare un po', che così in effetti si cade in errore.
Io compilo solo su current ed a 64bit, però a differenza di ponce sono leggermente più buono ed utenti e gruppi li faccio creare dal doinst.sh, cosa per cui sarò dannato all'inferno dalla chiesa del subgenio, lo so.
Inoltre spesso uso opzioni o versioni in sviluppo, roba strana che magari serve a me e per le mie particolari esigenze. Per esempio forse fra poco inserisco php7.
Il secondo è quello di ponce, che mi sembra si basi sugli script di slackbuilds.org aggiornati alla current.

Puoi anche usare un po' di qua ed un po' di la eh, io stesso prima non compilavo alcuni pacchetti ed installavo quelli di alien e ponce, poi alcuni gestori dei programmi per installare pacchetti, tipo slpkg, mi hanno cazziato dicendo che deve esserci tutto nel repository, allora compilo tutto, o semplicemente ho tolto alcune cose.

p.s.
comunque il README c'è anche lì, quindi mi sa che non l'hai letto :P

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2194
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.14.0
Desktop: lxde
Località: Pisa
Contatta:

Re: [SOLVED] problema aMule 2.3.1 64bit e libbfd

Messaggioda ponce » gio dic 10, 2015 13:30

Io ho configurato slackpkgplus per usare questo repository : http://ponce.cc/slackers/repository/
contiene le stesse cose di quello suggerito, ovvero : http://ponce.cc/slackware/slackware64-current/packages/

oppure devo inserirli entrambi?

per me puoi fare quello che ti pare, basta che (come suggerito nel README) tu non mi venga a cercare perche' qualcosa non ti funziona ;)