[RISOLTO] Google Earth e Slackware

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
F4B1CK
Linux 2.4
Linux 2.4
Messaggi: 248
Iscritto il: dom gen 11, 2004 0:00
Slackware: current 64 bit
Kernel: 4.4.x
Desktop: KDE 5
Località: Cosenza
Contatta:

[RISOLTO] Google Earth e Slackware

Messaggioda F4B1CK » dom gen 03, 2016 17:47

Dopo tanto tempo, oggi avevo deciso di installare google earth per giocare un pò con dei layer kml. Purtroppo mi sono ricordato che non esiste supporto per la nostra distro preferita.
Ho provato dunque a seguire le indicazioni presenti su SlackBuild, ma il pacchetto generato non ne vuole sapere di partire.
Ho cercato un pò in rete un pacchetto precompilato ma non ho trovato nulla.
Qualcuno ha avuto esperienza sulla compilazione del pacchetto oppure ha sotto mano un repository da cui poterlo scaricare?
Grazie come sempre alla community!!
Ultima modifica di F4B1CK il mar gen 05, 2016 15:56, modificato 1 volta in totale.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2192
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.14.0
Desktop: lxde
Località: Pisa
Contatta:

Re: Google Earth e Slackware

Messaggioda ponce » dom gen 03, 2016 18:00

qui google-earth di SBo fa un pacchetto perfettamente funzionante (slackware64-current).

assicurati di aver seguito tutte le indicazioni nel README, sono 5 punti specifici: commentali qui uno per uno per verificare che tu abbia chiari i prerequisiti.

una volta fatto sopra, prova a lanciarlo da un terminale all'interno della tua sessione X col comando "google-earth" e vedi che errore ti da.

in bocca al lupo.

F4B1CK
Linux 2.4
Linux 2.4
Messaggi: 248
Iscritto il: dom gen 11, 2004 0:00
Slackware: current 64 bit
Kernel: 4.4.x
Desktop: KDE 5
Località: Cosenza
Contatta:

Re: Google Earth e Slackware

Messaggioda F4B1CK » lun gen 04, 2016 14:44

ponce ha scritto:qui google-earth di SBo fa un pacchetto perfettamente funzionante (slackware64-current).

assicurati di aver seguito tutte le indicazioni nel README, sono 5 punti specifici: commentali qui uno per uno per verificare che tu abbia chiari i prerequisiti.

una volta fatto sopra, prova a lanciarlo da un terminale all'interno della tua sessione X col comando "google-earth" e vedi che errore ti da.

in bocca al lupo.


Ok. Ho seguito i vari punti ed avevo scordato il link relativo all'LSB.
La compilazione va a buon fine ma una volta installato e lanciato mi da questo errore :

./googleearth-bin: /lib/libc.so.6: version `GLIBC_2.18' not found (required by /usr/lib/libstdc++.so.6)

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2192
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.14.0
Desktop: lxde
Località: Pisa
Contatta:

Re: Google Earth e Slackware

Messaggioda ponce » lun gen 04, 2016 15:12

aggiorna la tua slackware64-current da un mirror.

poi aggiorna tutti i pacchetti delle multilib alle ultime versioni: intendo quelli che trovi nella directory principale qui sotto

http://taper.alienbase.nl/mirrors/peopl ... b/current/

e anche quelli nelle sottocartelle di

http://taper.alienbase.nl/mirrors/peopl ... -compat32/

per scaricare tutte le directory e pacchetti che ti servono in una directory "current" puoi usare questo comando

Codice: Seleziona tutto

lftp -c mirror http://taper.alienbase.nl/mirrors/people/alien/multilib/current/


comunque non hai commentato i punti uno ad uno come ti avevo chiesto: se ti si presentano altri problemi in seguito all'aggiornamento delle multilib fallo come prima cosa.

F4B1CK
Linux 2.4
Linux 2.4
Messaggi: 248
Iscritto il: dom gen 11, 2004 0:00
Slackware: current 64 bit
Kernel: 4.4.x
Desktop: KDE 5
Località: Cosenza
Contatta:

Re: [RISOLTO] Google Earth e Slackware

Messaggioda F4B1CK » mar gen 05, 2016 15:59

Ponce, grazie mille per il supporto! Sei stato illuminante!

Non avevo commentato i punti però ti assicuro che avevo seguito passo passo le istruzioni riportate.

Ho risolto l'ultimo problema di avvio ricorrendo a questi comandi :

slackpkg update
slackpkg upgrade multilib

(dove multilib è il repository che punta a http://taper.alienbase.nl/mirrors/peopl ... b/current/ )

ed installando i pacchetti proposti.

Se nemmeno questo avesse funzionato avrei provveduto all'installazione manuale dei vari pacchetti di compatibilità.