Pagina 1 di 1

installare grsecurity su slackware 13.37

Inviato: ven giu 24, 2011 21:25
da giovanni-69
ciao a tutti :).
ho deciso di farmi un server,con un vecchio pc, per metterci su il mio blog e volevo sapere come installare grsecurity su slackware 13.37, potreste dirmi quale versione di grsecurity devo installare e come si installa?
vi ringrazio in anticipo :)

Re: installare grsecurity su slackware 13.37

Inviato: ven giu 24, 2011 21:32
da Ansa89
Non lo conosco affatto, però sul loro wiki ci sono i passaggi su come patchare il kernel e quali altri software servono (in pratica grsecurity è una patch per il kernel, in più c'è gradm che è il tool userspace per la configurazione).
Di più non so dirti.

Re: installare grsecurity su slackware 13.37

Inviato: sab giu 25, 2011 10:23
da giovanni-69
grazie :) ho letto tutto solo che resta il problema di compatibilità perche su grsecurity non c'è la patch per il kernel 2.6.37.6, dovrei compilare un kernel più vecchio per mettere la patch secondo voi?

Re: installare grsecurity su slackware 13.37

Inviato: sab giu 25, 2011 10:25
da Ansa89
Se vuoi posso provare a patchare il 2.6.39.2 ed eventualmente tentare di correggere la patch.

Re: installare grsecurity su slackware 13.37

Inviato: sab giu 25, 2011 10:57
da giovanni-69
la patch nella pagina testing c' è per il 2.6.39.1 vuoi dire che dovrei mettere quello?

Re: installare grsecurity su slackware 13.37

Inviato: sab giu 25, 2011 11:05
da Ansa89
Dal mio punto di vista è meglio un kernel più aggiornato, rispetto ad uno più vecchio (ammesso che non si abbiano particolari esigenze).
Secondo me puoi fare una prova con la patch testing su kernel 2.6.39.[1,2] e vedere come va.

Re: installare grsecurity su slackware 13.37

Inviato: sab giu 25, 2011 17:21
da giovanni-69
ok grazie lo farò :)

Re: installare grsecurity su slackware 13.37

Inviato: dom giu 26, 2011 9:09
da hashbang
Io sinceramente ad uso server opterei per un kernel più maturo.
Inoltre, sempre secondo me, non userei la 13.37, ma una versione ben più testata e rock-solid.

Secondo me, Slackware 12.2 + kernel 2.6.32 con patch grsecurity dovrebbe garantirti un serverino stabile e sicuro. :)