[RISOLTO] Problemi con kde 4.4.5

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
ZeD
Linux 1.x
Linux 1.x
Messaggi: 112
Iscritto il: ven 28 ott 2005, 12:30
Slackware: 12.1
Località: Terra

[RISOLTO] Problemi con kde 4.4.5

Messaggio da ZeD »

Ho aggiornato (tramite slackpkg) la mia slackware 13.1 a current, con il nuovo kde 4.4.5

Da quando l'ho fatto, pero', ho una serie di problemi, penso di incompatibilità; plasma non carica neanche un plugin (e quindi ho il monitor perfettamente bianco), krunner non fa partire i thread di ricerca, e, ad esempio, se lancio systemsettings, ottengo:

Codice: Seleziona tutto

$ systemsettings 
systemsettings(16482) SettingsBase::initApplication: "View load error: The plugin 'classic_mode' uses an incompatible KDE library (4.4.5 (KDE 4.4.5))." 
systemsettings(16482) SettingsBase::initApplication: "View load error: The plugin 'icon_mode' uses an incompatible KDE library (4.4.5 (KDE 4.4.5))." 
$
Sapete come posso risolvere il problema?
Ultima modifica di ZeD il sab 31 lug 2010, 11:35, modificato 1 volta in totale.

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom 17 apr 2005, 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Problemi con kde 4.4.5

Messaggio da phobos3576 »

In questi casi, il metodo più sbrigativo consiste nel rinominare la directory $HOME/.kde.

Esegui questa operazione dalla modalità testo, poi avvia KDE e controlla se il problema si risolve.

Il fastidio è che così perdi tutte le vecchie impostazioni; se però riesci ad individuare la causa del problema, puoi anche ripristinare la directory .kde precedentemente rinominata.

Avatar utente
ZeD
Linux 1.x
Linux 1.x
Messaggi: 112
Iscritto il: ven 28 ott 2005, 12:30
Slackware: 12.1
Località: Terra

Re: Problemi con kde 4.4.5

Messaggio da ZeD »

Niente da fare... ho anche tentato creando un nuovo utente ad-hoc, solo per vedere se da zero fungeva
ma niente...

hashbang
Packager
Packager
Messaggi: 1980
Iscritto il: ven 4 giu 2010, 10:27
Nome Cognome: Luca De Pandis
Distribuzione: macOS Catalina
Località: Lecce / Bergamo / Milano
Contatta:

Re: Problemi con kde 4.4.5

Messaggio da hashbang »

ZeD ha scritto:Niente da fare... ho anche tentato creando un nuovo utente ad-hoc, solo per vedere se da zero fungeva
ma niente...
Io sono sempre contrario all'upgrade; preferisco piallare l'hard disk e installare da zero. La mia current è stata installata così (ovviamente in modalità netinst) ;):_

Avatar utente
ZeD
Linux 1.x
Linux 1.x
Messaggi: 112
Iscritto il: ven 28 ott 2005, 12:30
Slackware: 12.1
Località: Terra

Re: Problemi con kde 4.4.5

Messaggio da ZeD »

atomix600 ha scritto:Io sono sempre contrario all'upgrade; preferisco piallare l'hard disk e installare da zero. La mia current è stata installata così (ovviamente in modalità netinst) ;):_
Io son partito da una 13.1 "da zero", e funzionava.
poi ho aggiornato alla current (tramite slackpkg, ma credo sia ininfluente) e da allora è scoppiato kde...

erio
Linux 4.x
Linux 4.x
Messaggi: 1206
Iscritto il: ven 9 ott 2009, 19:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Problemi con kde 4.4.5

Messaggio da erio »

ciao,ma hai installato tutto il pacchetto dei file che servono per kde 4.4.5,quelli accessori,che sono un bel pò.

Avatar utente
ZeD
Linux 1.x
Linux 1.x
Messaggi: 112
Iscritto il: ven 28 ott 2005, 12:30
Slackware: 12.1
Località: Terra

Re: [RISOLTO] Problemi con kde 4.4.5

Messaggio da ZeD »

come ho già detto, ho installato i pacchetti automaticamente, usando slackpkg...
comunque probabilmente c'è stato qualche problema durante l'aggiornamento: ho forzato la reinstallazione di tutti i pacchetti kde* e ora è tornato a funzionare

Rispondi