Pagina 3 di 4

Re: multilib all-in-one

Inviato: sab set 25, 2010 17:57
da ZeroUno
Wine è per 32 bit
anzi, wine è opensource quindi si compila anche a 64 bit, ma in tal caso puoi farci girare solamente programmi windows a 64 bit ;-)
quindi va usata la versione a 32bit

Re: multilib all-in-one

Inviato: sab set 25, 2010 18:04
da robbybby
1. Scaricato Wine 1.3.3 da Slacky. assieme alle sue dipendenze.
2. Installato.
3. Funziona (con le multilib di ZeroUno, of course). Ho lanciato write, skype e winhelp, direttamente dalla partizione di Win7. Firefox, e altri programmi, non funzionano, ma penso sia colpa di wine.
4. Yuppiiiieieieieieie!!! :)

Se ti servono altri dati, o prove, chiedi pure. La partizione di test è lì apposta.

PS: ho scaricato firefox dal sito, l'ho installato in wine, e funziona!
Quindi direi che le multilib di ZeroUno sono promosse a pieni voti.

Non avevo mai usato Wine, e forse si vede :)
Adesso devo vedere se funziona TomTome Home, perché mi servirebbe.

PS: nel pacchetto wine 1.3.3 manca wine_gecko-1.1.0-x86.cab.

Re: multilib all-in-one

Inviato: dom set 26, 2010 17:24
da robbybby
Mi è venuto in mente un altro programma che esiste solo a 32 bit: GoogleEarth.
Ho appena installato la versione a 32 bit, e funziona.
E con questo direi che il test delle multilib di ZeroUno può dirsi concluso, in maniera più che positiva. O no? :)
@ZeroUno: le metti nel repository ufficiale?

Re: multilib all-in-one

Inviato: dom set 26, 2010 23:23
da ZeroUno
L'ho appena caricato... sarà disponibile a breve.

Mentre per current: compat32-libraries-1.0_current-x86_64-1sl

Re: multilib all-in-one

Inviato: gio mag 19, 2011 14:46
da ZeroUno
compat32-libraries-1.1_13.37-x86_64-1sl.txz

Ho fatto la versione per slackware 13.37 ma ho poco modo di testarla.

Qualcuno sa darmi qualche riscontro?

A breve sarà disponibile sul repository.

Re: multilib all-in-one

Inviato: gio mag 19, 2011 22:38
da neongen
adobe reader:

Codice: Seleziona tutto

error while loading shared libraries: libgdk_pixbuf_xlib-2.0.so.0: cannot open shared object file: No such file or directory


google-earth:

Codice: Seleziona tutto

/usr/bin/google-earth: line 43: ./googleearth-bin: File o directory non esistente

Re: multilib all-in-one

Inviato: gio mag 19, 2011 23:16
da ZeroUno
in slackware 13.37 alcune librerie sono state spostate in altri pacchetti rispetto alla 13.1; alcune tolte alcune aggiunte. Per questo non so se l'elenco delle librerie che ho inserito sono sufficienti.

Dammi un ldd di googleearth-bin e del binario di adobe reader che gli do una occhiata domani.
ti funzionava con il pacchetto precedente?

Re: multilib all-in-one

Inviato: ven mag 20, 2011 13:35
da neongen
prima usavo le librerie di bluewhite64, adesso volevo provare il tuo pacchetto... in ogni caso:

acroread:

Codice: Seleziona tutto

ldd acroread | grep not
        libBIB.so => not found
        libBIBUtils.so => not found
        libACE.so => not found
        libAGM.so => not found
        libCoolType.so => not found
        libAXE8SharedExpat.so => not found
        libJP2K.so => not found
        libAdobeXMP.so => not found
        libicuuc.so.36 => not found
        libgdk_pixbuf_xlib-2.0.so.0 => not found
        libgdk_pixbuf-2.0.so.0 => not found
        libResAccess.so => not found
        libgdk_pixbuf-2.0.so.0 => not found
        libgdk_pixbuf-2.0.so.0 => not found

a parte gdk-pixbuf, le altre segnate mancanti sono presenti nell'installazione di acroread

per google-earth: da sempre l'errore file not found, nonostante il link /lib/ld-linux

Codice: Seleziona tutto

ldd googleearth-bin | grep not
        libgoogleearth_free.so => not found

Re: multilib all-in-one

Inviato: ven mag 20, 2011 15:56
da ZeroUno
libgdk_pixbuf è giusto una libreria scorporata e messa in un altro pacchetto.
compat32-libraries-1.1.02_13.37-x86_64-1sl.txz

Ora dovrebbe andare.

per quanto riguarda earth però la libreria che cerca dovrebbe essere nel pacchetto di earth stesso.
Funzionava con la precedente versione di compat32-libraries?

fai una find di quella libreria e vedi in che path si trova.

Re: multilib all-in-one

Inviato: ven mag 20, 2011 16:37
da neongen
si si, google-earth non trova le sue stesse librerie; l'avevo scritto nel post precedente ma si deve essere perso rimaneggiando il testo :lol:
intendevo dire che il problema non è nuovo, ma prima avevo risolto con il symlink /lib/ld-linux.so.2 -> ld-2.13.so mentre adesso non va più.

adobe reader invece funziona, grazie!

Re: multilib all-in-one

Inviato: ven mag 20, 2011 17:01
da ZeroUno
Il pacchetto che ti ho dato lo fa lui il link. Quello precedente (1.0) linkava a ld-2.11.so

Da dove hai scaricato earh? se me lo passi lo installo e provo io.

Re: multilib all-in-one

Inviato: ven mag 20, 2011 17:31
da ZeroUno
Ho provato a scaricare l'ultimo dal repository slacky e mi funziona.

se dai ls -l /lib/ld-lsb.so.3 cosa ti da?

Re: multilib all-in-one

Inviato: ven mag 20, 2011 17:57
da neongen
risolto: ld-lsb.so.3 -> ld-2.13.so era questo il link che mancava

Re: multilib all-in-one

Inviato: ven mag 20, 2011 18:46
da ZeroUno
neongen ha scritto:risolto: ld-lsb.so.3 -> ld-2.13.so era questo il link che mancava

lo crea googleearth in fase di installazione

Re: multilib all-in-one

Inviato: ven mag 20, 2011 20:13
da neongen
#-o creando il pacchetto sulla 64bit non lo mette al posto giusto

Codice: Seleziona tutto

( cd lib64 ; ln -sf /lib64/ld-linux.so.2 ld-lsb.so.3 )