Pagina 1 di 1

[RISOLTO]xpdf e libXm.so.2

Inviato: mar dic 27, 2011 16:57
da N1cuz
Ho un problema con xpdf, non si avvia perchè dice gli manca libXm.so, ho installato da slackbuild openmotif ma continua a darmi lo stesso errore.

Re: xpdf e libXm.so.2

Inviato: mar dic 27, 2011 17:08
da targzeta
Il pacchetto da installare per risolvere quella dipendenza di xpdf è 'lesstif' e si trova sotto il ramo 'l'. Dal tuo profilo tu dovresti avere una Slackware64 13.37, e quindi il pacchetto divrebbe essere questo.

Emanuele

Re: xpdf e libXm.so.2

Inviato: mar dic 27, 2011 17:44
da N1cuz
Si con "lesstif" si risolve, anche se non capisco come mai non vada bene "openmotif", che su slackbuilds.org viene dato come pacchetto alternativo a "lesstif", per le librerie motif (che contiene comunque libXm.so tra l'altro), "lesstif" lo avevo escluso dall'installazione perchè conteneva "mwm" che personalmente non uso e pensavo che bastasse un pacchetto qualunque per le librerie motif, in ogni caso per evitare complicazioni inutili ho reinstallato il pacchetto del ramo "i" ed adesso xpdf funziona, grazie mille Emanuele.

Re: xpdf e libXm.so.2

Inviato: mar dic 27, 2011 18:23
da targzeta
Ho provato a compilare openmotif prendendo tutto da slackbuilds.org però il pacchetto creato non contiene la libreria che cerchi. Stavo anche vedendo se fosse possibile compilare lesstif senza mwm ma sembrerebbe di no...almeno non in maniera "semplice".

Emanuele

Re: xpdf e libXm.so.2

Inviato: mar dic 27, 2011 18:38
da targzeta
Comunque, se quello che ti serve è solo la libreria libXm, puoi sempre prelevarla da lesstif senza installare il pacchetto stesso. Ho fatto una rapida ricerca sulle dipendenze di quest'ultima e sembra che non necessiti di nessun'altra libreria installata da lesstif. Anche xpdf sembra che necessiti della sola libreria libXm e di nessun'altra libreria installata con lesstif.

Per fare questo devi:
  • Estrarre la libreria dal pacchetto lesstif che ti ho linkato, con:

    Codice: Seleziona tutto

    tar -xf lesstif-0.95.2-x86_64-1.txz usr/lib64/libXm.so.2.0.1
    (verrà estratta nella directory 'usr/lib64/' relativa alla directory in cui ti trovi)
  • Copiare la libreria sotto '/usr/lib64/'
  • Creare i link simbolici 'libXm.so' e 'libXm.so.2', sempre in '/usr/lib64/' che puntino a 'libXm.so.2.0.1'
In pratica sembra complicato ma non lo è :).

Emanuele

Re: xpdf e libXm.so.2

Inviato: mar dic 27, 2011 19:35
da hashbang
N1cuz ha scritto:Si con "lesstif" si risolve, anche se non capisco come mai non vada bene "openmotif", che su slackbuilds.org viene dato come pacchetto alternativo a "lesstif", per le librerie motif (che contiene comunque libXm.so tra l'altro)
Se vuoi usare XPDF con OpenMotif devi ricompilarlo. Altrimenti non funziona. Anche io ho avuto quel problema, quando pacchettizzai OpenMotif per OpenCDE.
La libXm di lesstif non è la stessa di OpenMotif. Probabilmente cambia qualche funzione.

"lesstif" lo avevo escluso dall'installazione perchè conteneva "mwm" che personalmente non uso
Anche OpenMotif lo contiente. MWM è il window manager di Motif e pertanto è in tutte e due le implementazioni. È parte integrante del framework.

e pensavo che bastasse un pacchetto qualunque per le librerie motif,
Certo che è così. Puoi usare XPDF con OpenMotif se vuoi (io faccio così). L'importante è che ricompili il software prima di usarlo.

Re: xpdf e libXm.so.2

Inviato: mar dic 27, 2011 19:42
da hashbang
spina ha scritto:Ho provato a compilare openmotif prendendo tutto da slackbuilds.org però il pacchetto creato non contiene la libreria che cerchi.

Guarda, ho controllato il pacchetto di OpenMotif che ho creato io per Slacky (32 bit):
http://pkgs.org/slackware-13.37/slacky- ... l.txz.html

/usr/lib/libXm.la
/usr/lib/libXm.so.4.0.3

e la libreria è presente.

È molto strano che libXm.so non ci sia nel pacchetto di SBo. Nel caso usate il mio SlackBuild, mettendo ARCH=x86_64 se necessario.

Re: xpdf e libXm.so.2

Inviato: mar dic 27, 2011 21:56
da N1cuz
spina ha scritto:Comunque, se quello che ti serve è solo la libreria libXm, puoi sempre prelevarla da lesstif senza installare il pacchetto stesso. Ho fatto una rapida ricerca sulle dipendenze di quest'ultima e sembra che non necessiti di nessun'altra libreria installata da lesstif. Anche xpdf sembra che necessiti della sola libreria libXm e di nessun'altra libreria installata con lesstif.

Per fare questo devi:
  • Estrarre la libreria dal pacchetto lesstif che ti ho linkato, con:

    Codice: Seleziona tutto

    tar -xf lesstif-0.95.2-x86_64-1.txz usr/lib64/libXm.so.2.0.1
    (verrà estratta nella directory 'usr/lib64/' relativa alla directory in cui ti trovi)
  • Copiare la libreria sotto '/usr/lib64/'
  • Creare i link simbolici 'libXm.so' e 'libXm.so.2', sempre in '/usr/lib64/' che puntino a 'libXm.so.2.0.1'
In pratica sembra complicato ma non lo è :).

Emanuele


Per adesso faccio così, appena ho tempo però provo ad utilizzare openmotif (ricompilando xpdf come suggerito da atomix600) , ma solo per pura curiosità.
atomix600 ha scritto:È molto strano che libXm.so non ci sia nel pacchetto di SBo. Nel caso usate il mio SlackBuild, mettendo ARCH=x86_64 se necessario.

In effetti nel pacchetto di SBo libXm.so c'è, è la verisone 4 anzichè 2 ma c'è, infatti xpdf non avvia chiedendo libXm.so.2, di solito i problemi si dovrebbero avere se si utilizzano librerie più vecchie non più nuove.... Comunque grazie mille ragazzi :thumbright:

Re: xpdf e libXm.so.2

Inviato: mar dic 27, 2011 23:24
da targzeta
N1cuz ha scritto:...
atomix600 ha scritto:È molto strano che libXm.so non ci sia nel pacchetto di SBo. Nel caso usate il mio SlackBuild, mettendo ARCH=x86_64 se necessario.

In effetti nel pacchetto di SBo libXm.so c'è, è la verisone 4 anzichè 2 ma c'è, infatti xpdf non avvia chiedendo libXm.so.2, di solito i problemi si dovrebbero avere se si utilizzano librerie più vecchie non più nuove.... Comunque grazie mille ragazzi :thumbright:

Errore mio, la compilazione fallisce (ma non me ne ero accorto) perché mi manca qualcosa a livello di librerie e/o include. Quindi ottengo un pacchetto a metà (ho disabilitato 'set -e') in cui non c'è libXm.

Se la libreria è più nuova, avete provato semplicemente a creare un link simbolico alla 4? Se c'è retrocompatibilità il tutto dovrebbe funzionare. Però ovviamente, se come dice atomix, le due versioni hanno proprio delle API differenti allora è un altro paio di maniche e non c'è verso a meno di compilare xpdf linkandolo con le librerie preferite.

Emanuele

Re: xpdf e libXm.so.2

Inviato: mer dic 28, 2011 11:05
da hashbang
spina ha scritto:Se la libreria è più nuova, avete provato semplicemente a creare un link simbolico alla 4? Se c'è retrocompatibilità il tutto dovrebbe funzionare. Però ovviamente, se come dice atomix, le due versioni hanno proprio delle API differenti allora è un altro paio di maniche e non c'è verso a meno di compilare xpdf linkandolo con le librerie preferite.
Si Emanuele. Provai già allora a fare un symlink ma quando aprì XPDF via console per controllare l'output, quest'ultimo crashava lanciando una sfilza di errori. L'unica soluzione è stata ricompilare XPDF e stare attento a non aggiornarlo con slackpkg.