[RISOLTO] AVI to MP4

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
daniele50
Linux 2.6
Linux 2.6
Messaggi: 964
Iscritto il: mar apr 10, 2007 13:58
Nome Cognome: Daniele Cinquanta
Slackware: Slackware64 14.1
Kernel: 3.10.17
Desktop: Xfce 4.10
Località: San Zenone al Lambro (MI)
Contatta:

[RISOLTO] AVI to MP4

Messaggioda daniele50 » dom mag 11, 2014 13:18

Devo convertire dei video.avi in formato mp4, ho trovato questo esempio:

Codice: Seleziona tutto

ffmpeg -i input.avi -acodec libfaac -b:a 128k -vcodec mpeg4 -b:v 1200k -flags +aic+mv4 output.mp4

ma mi ritorna l'errore:

Codice: Seleziona tutto

Unknown encoder 'faac'

però ho appena installato faac e la dipendenza libmp4v2, entrambi scaricati da slackbuilds.org, cosa non va?
Ultima modifica di daniele50 il dom mag 11, 2014 15:15, modificato 1 volta in totale.

rik70
Master
Master
Messaggi: 1688
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: 4.0.x-smp
Desktop: Xfce 4.12

Re: AVI to MP4

Messaggioda rik70 » dom mag 11, 2014 13:43

Hai impostato FAAC=yes nella riga di comando?
Prova a incollare:

Codice: Seleziona tutto

ffmpeg -version

Avatar utente
daniele50
Linux 2.6
Linux 2.6
Messaggi: 964
Iscritto il: mar apr 10, 2007 13:58
Nome Cognome: Daniele Cinquanta
Slackware: Slackware64 14.1
Kernel: 3.10.17
Desktop: Xfce 4.10
Località: San Zenone al Lambro (MI)
Contatta:

Re: AVI to MP4

Messaggioda daniele50 » dom mag 11, 2014 14:11

$ ffmpeg -version
ffmpeg version 2.1
built on Mar 12 2014 22:31:33 with gcc 4.8.2 (GCC)
configuration: --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/lib64 --docdir=/usr/doc/ffmpeg-2.1/html --mandir=/usr/man --disable-debug --enable-shared --disable-static --enable-pthreads --enable-libtheora --enable-libvorbis --enable-gpl --enable-version3 --enable-postproc --enable-swscale --enable-x11grab --enable-avfilter --enable-gnutls --enable-libcdio --enable-libssh --arch=x86_64 --enable-libmp3lame --enable-libx264
libavutil 52. 48.100 / 52. 48.100
libavcodec 55. 39.100 / 55. 39.100
libavformat 55. 19.104 / 55. 19.104
libavdevice 55. 5.100 / 55. 5.100
libavfilter 3. 90.100 / 3. 90.100
libswscale 2. 5.101 / 2. 5.101
libswresample 0. 17.104 / 0. 17.104
libpostproc 52. 3.100 / 52. 3.100

rik70
Master
Master
Messaggi: 1688
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: 4.0.x-smp
Desktop: Xfce 4.12

Re: AVI to MP4

Messaggioda rik70 » dom mag 11, 2014 14:31

Non ha compilato il supporto a libfaac.

O ricompili con

Codice: Seleziona tutto

FAAC=yes [altre variabili] sh ffmpeg.SlackBuild


Oppure usa questo per la codifica:

Codice: Seleziona tutto

ffmpeg -i input.avi -acodec aac -strict -2 -b:a 128k -vcodec mpeg4 -b:v 1200k -flags +aic+mv4 output.mp4

Avatar utente
daniele50
Linux 2.6
Linux 2.6
Messaggi: 964
Iscritto il: mar apr 10, 2007 13:58
Nome Cognome: Daniele Cinquanta
Slackware: Slackware64 14.1
Kernel: 3.10.17
Desktop: Xfce 4.10
Località: San Zenone al Lambro (MI)
Contatta:

Re: AVI to MP4

Messaggioda daniele50 » dom mag 11, 2014 15:14

rik70 ha scritto:Non ha compilato il supporto a libfaac.

O ricompili con

Codice: Seleziona tutto

FAAC=yes [altre variabili] sh ffmpeg.SlackBuild


Oppure usa questo per la codifica:

Codice: Seleziona tutto

ffmpeg -i input.avi -acodec aac -strict -2 -b:a 128k -vcodec mpeg4 -b:v 1200k -flags +aic+mv4 output.mp4


con il codec aac ho raggiunto il mio scopo, se più avanti avrò necessariamente bisogno di utilizzare faac ricompilerò ffmpeg...

Grazie! :thumbright:


Torna a “Slackware64”

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti