Alzare il livello volume di alsamixer

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Black bart
Linux 2.x
Linux 2.x
Messaggi: 286
Iscritto il: sab 20 apr 2013, 23:10
Nome Cognome: Omar
Slackware: Slackware64-current
Desktop: xfce
Località: Bergamo

Alzare il livello volume di alsamixer

Messaggio da Black bart »

Salve a tutti,sono a chiedervi se esiste la possibilità di alzare il livello del volume di alsamixer,al momento ho trovato da terminale digitando alsamixer,alzo il livello di PCM fino all'81% perchè oltre il suono è disturbato e il master lo controllo con i tasti dedicatidel portatile,esiste qualche altra possibilità per alzare il livello del volume?


Grazie!

sixjan
Linux 2.x
Linux 2.x
Messaggi: 413
Iscritto il: dom 6 gen 2008, 11:46
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: Xfce 4.10

Re: Alzare il livello volume di alsamixer

Messaggio da sixjan »

kmix

Black bart
Linux 2.x
Linux 2.x
Messaggi: 286
Iscritto il: sab 20 apr 2013, 23:10
Nome Cognome: Omar
Slackware: Slackware64-current
Desktop: xfce
Località: Bergamo

Re: Alzare il livello volume di alsamixer

Messaggio da Black bart »

sixjan ha scritto:kmix

Ovvio,usando kde uso kmix...

La mia domanda è se esiste la possibilità di amplificare il volume di alsamixer,ad esempio se avvio la partizione dove tengo debian stabile e uso pulseaudio a ed il volume al 50% lo stesso è palesemente più alto rispetto al volume sempre al 50% con slackware ed il solo alsa,probabilmente mi sono spiegato male...

Grazie

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3261
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Alzare il livello volume di alsamixer

Messaggio da joe »

Se ho capito bene e la memoria non mi inganna alsamixer da solo non controlla completamente il volume dello speaker, potresti provare ad usare il programma "aumix" e controllare a che livello è settato il volume del "mixer".
man aumix per i dettagli.
Per una prova rapida dai lo switch "query" (-q):

Codice: Seleziona tutto

aumix -q
E dovrebbe mostrarti anche il volume attuale.
In alternativa vedi cosa hai in "~/.aumixrc". Se non hai quel file controlla l'equivalente a livello globale /etc/aumixrc:
Ecco cosa leggo io ad esempio:

Codice: Seleziona tutto

joe@darkstar:~$ cat .aumixrc 
vol:100:100:P
pcm:100:100:P
line:100:100:P
pcm2:100:100:P
igain:100:100:P
dig1:100:100:P
joe@darkstar:~$ cat /etc/aumixrc 
vol:86:86:P
pcm:100:100:P
line:100:100:P
pcm2:100:100:P
igain:94:94:P
dig1:100:100:P
Come vedi nel mio caso il volume impostato per il sistema è più basso rispetto a quello che avevo modificato io nelle impostazioni del mio utente (~/.aumixrc).
Fare paragoni con la debian andando a vedere cosa è impostato in files corrispondenti non so se sia possibile perchè in quella hai detto che vi è pulseaudio che gestisce il suono mentre qui su slack no. Per cui devi andare ad orecchio!
Good Luck! :)

PS.
Butto lì una mia esperienza: un'alternativa ad Alsa è OpenSoundSystem, che sto usando da tempo sul mio sistema, nel mio caso controllo il tutto con "ossmix" o meglio nella veste grafica con tanto di pulsante nell'area di notifica: "ossxmix".
Ero approdato a questo sistema perchè la qualità audio nelle chiamate voip era risultata così leggermente superiore.
L'impostazione è piuttosto semplice, eventualmente ci fossero interessati basta cercare tra i miei post in questo forum...
Avevo trovato anche un valido aiuto nella documentazione presente sul wiki di archlinux. Anche per far funzionare l'audio nel browser google chrome o chromium che non supportavano OSS.

Avatar utente
conraid
Staff
Staff
Messaggi: 13488
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: Alzare il livello volume di alsamixer

Messaggio da conraid »

Riguardo il volume io con i nuovi kernel (nonostante abbia segnalato il bug e lo hanno risolto con varie patch) l'ho sempre molto basso rispetto a prima. Purtroppo mi sa che dipende anche dai driver del kernel delle due distribuzioni.
Mi fa lo stesso scherzo, basso e se lo alzo sento molto disturbato.
joe ha scritto:

Codice: Seleziona tutto

aumix -q
aumix è stato tolto dalla 14.1, in quanto va solo con oss e non con alsa.
Tue May 14 06:33:30 UTC 2013
ap/aumix-2.9.1-i486-1.txz: Removed.
This only works with OSS (or the ALSA OSS compatibility modules, which are
now disabled by default). Moving to /pasture.
joe ha scritto:
Butto lì una mia esperienza: un'alternativa ad Alsa è OpenSoundSystem.
OSS è il "vecchio" sistema, quindi più che un'alternativa è un ritorno al passato. Sulla Slackware è stato disabilitato di default, compreso il modulo di compatibilità, come leggi nel pezzo di changelog segnalato sopra.
Nulla vieta che puoi ricompilare varie cose per farle funzionare con oss :-)

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3261
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Alzare il livello volume di alsamixer

Messaggio da joe »

Acc..
Allora sono rimasto indietro!
In effetti io ho ancora slack 14.0...
Su questa come ho detto sono passato a OSS, se non ricordo male il pacchetto era oss-4.2.2008-i486-1_SBo.
A dire la verità nel mio caso al momento se lancio "aumix -q" mi dice:

Codice: Seleziona tutto

joe@darkstar:~$ aumix -q
aumix:  nessun dispositivo trovato: File o directory non esistente
Boo prima invece con Alsa mi funzionava...
Adesso coi nuovi kernel la faccenda allora è cambiata.
Certo che se riscontrate che il volume è più basso di prima non va bene...
Non potrebbe essere un problema magari risaputo nella slack-community e forse risolvibile in qualche modo?
Alcune cose potrebbero trovarsi discusse anche su linuxquestions, magari provate a dare un'occhiata anche lì...

Avatar utente
conraid
Staff
Staff
Messaggi: 13488
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: Alzare il livello volume di alsamixer

Messaggio da conraid »

oss su SBo c'è sempre
http://slackbuilds.org/repository/14.1/audio/oss/
e sembra meno difficile del previsto usare oss
http://slackbuilds.org/slackbuilds/14.1 ... .SLACKWARE

poi immagino il resto dipenda dall'applicazione usata.

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3261
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Alzare il livello volume di alsamixer

Messaggio da joe »

Precisamente, basta fare quelle tre cose spiegate lì... avevo seguito proprio quelle indicazioni.
Come ho detto l'unico problema riscontrato per quello che mi riguarda è stata l'incompatibilità con chrome/chromium.
In pratica i video su youtube o simili erano muti.

Però con le indicazioni del wiki di arch avevo risolto applicando un workaround...
Avevo anche spiegato la faccenda in un topic ad hoc proprio qui sul forum. Almeno così mi sembra di ricordare..
EDIT:
Non trovo nessun post tra i miei in cui spiegavo come ho fatto ad attivare l'audio per chrome/chromium ecc.
Probabilmente ho fatto confusione, ad ogni modo applicando queste modifiche:
https://wiki.archlinux.org/index.php/Op ... zione_ALSA
Si risolvono i problemi di mutismo nei browser chrome/chromium

Se sia una scelta valida o meno non saprei... Anzi se ne sapete di più dite pure :D

Avatar utente
conraid
Staff
Staff
Messaggi: 13488
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: Alzare il livello volume di alsamixer

Messaggio da conraid »

Non sapevo che fosse tornato libero il codice di oss, dovrei provarlo per capire se risolvo qualcosa.
Anche se per ora mi va bene così, tanto lo uso poco l'audio da notebook.

Rispondi