Problema xorg o almeno credo...

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
StormyMonday
Linux 2.x
Linux 2.x
Messaggi: 395
Iscritto il: dom 8 mag 2005, 0:00
Slackware: Current
Kernel: 2.6.27.7
Desktop: xfce

Problema xorg o almeno credo...

Messaggio da StormyMonday »

Eccomi tornato dopo qualche anno, ho un problema dopo l'aggiornamento alla 14.2, e cioè quando faccio partire xfce mi ritrovo senza il mouse funzionante, la tastiera, e nemmeno la conessione.
Avendo l'accesso da root con mc sono riuscito ad accedere e modificare il file xorg.conf (che in realtà non esiste) ma ho xorg.conf-vesa ma senza nessun risultato, ad ogni prova però sono costretto a riavviare, visto che non ho accesso alla console...
Vi chiedo un poco di pazienza, sento che la soluzione è vicina, ma non vorrei formattare se non come ultima spiaggia.
Potete aiutarmi?
Grazie a tutti

Avatar utente
Rama
Linux 2.x
Linux 2.x
Messaggi: 347
Iscritto il: sab 29 mar 2008, 12:18
Slackware: 14.2 64bit
Kernel: 5.4.1 preemptive
Desktop: KDE 4.14.21
Distribuzione: Debian Stretch
Località: Novara, provincia

Re: Problema xorg o almeno credo...

Messaggio da Rama »

anch'io ho xorg.conf-vesa, lo noto ora;
i log che dicono? visto che la tastiera funziona dovrebbe essere un problema da poco;

Avatar utente
StormyMonday
Linux 2.x
Linux 2.x
Messaggi: 395
Iscritto il: dom 8 mag 2005, 0:00
Slackware: Current
Kernel: 2.6.27.7
Desktop: xfce

Re: Problema xorg o almeno credo...

Messaggio da StormyMonday »

Rama ha scritto:anch'io ho xorg.conf-vesa, lo noto ora;
i log che dicono? visto che la tastiera funziona dovrebbe essere un problema da poco;
Intendi Xorg.0.log?
Non riesco a incollare perchè scrivo da un altro pc, ma non mi pare ci siano errori.

L'unica cosa che noto sono tre voci

(==) Automatically adding devices
(==) Automatically enabling devices
(==) Automatically adding GPU devices

e mi sembra di ricordare che vanno disabilitate in xorg.conf...
Provo...

Edit
Non cambia nulla...

Avatar utente
conraid
Staff
Staff
Messaggi: 13454
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: Problema xorg o almeno credo...

Messaggio da conraid »

xorg.conf non importa usarlo, e xorg.conf-vesa è solo un esempio, se vuoi usarlo devo rinominarlo.

La nuova modalità è avere vari file in /etc/X11/xorg.conf.d/
Se hai errori significa che quelli di default non vanno bene, copiali (da /usr/share/X11/xorg.conf.d) in quella directory, con lo stesso nome, e modificali per le tue esigenze

Io per esempio ho questi

Codice: Seleziona tutto

conraid@blankstar:/etc/X11/xorg.conf.d$ cat 50-synaptics.conf 

Section "InputClass"
        Identifier "touchpad"
        Driver "synaptics"
        MatchDevicePath "/dev/input/event*"
        MatchIsTouchpad "on"
        Option "TapButton1" "1"
        Option "TapButton2" "2"
        Option "TapButton3" "3"
    Option "SHMConfig" "true"
    #Option "MaxTapMove" "2000"
    Option "VertEdgeScroll" "true"
    Option "AccelFactor" "0.01"
EndSection

Codice: Seleziona tutto

conraid@blankstar:/etc/X11/xorg.conf.d$ cat 90-keyboard-layout.conf 
Section "InputClass"
        Identifier "keyboard-all"
        MatchIsKeyboard "on"
        Driver "evdev"
        Option "XkbLayout" "it"
        #Option "XkbVariant" ""
        Option "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

Avatar utente
Rama
Linux 2.x
Linux 2.x
Messaggi: 347
Iscritto il: sab 29 mar 2008, 12:18
Slackware: 14.2 64bit
Kernel: 5.4.1 preemptive
Desktop: KDE 4.14.21
Distribuzione: Debian Stretch
Località: Novara, provincia

Re: Problema xorg o almeno credo...

Messaggio da Rama »

da me la dir /etc/X11/xorg.conf.d/ è vuota;
c'entra il fatto che ho installato KDE?

Avatar utente
conraid
Staff
Staff
Messaggi: 13454
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: Problema xorg o almeno credo...

Messaggio da conraid »

Rama ha scritto:da me la dir /etc/X11/xorg.conf.d/ è vuota;
c'entra il fatto che ho installato KDE?
La directory deve essere vuota, sta a te riempirla, se serve.
I file di default li trovi in /usr/share/X11/xorg.conf.d e se ne leggi uno trovi scritto per esempio in quello della tastiera
# READ THIS FOR CUSTOM KEYBOARD INFORMATION
#
# If you want to add a custom model/layout/variant to X, you will need to COPY
# this file to /etc/X11/xorg.conf.d/ and edit that copy. After editing it to
# suit, you will need to restart X.
Oppure crearli ex novo se non è presente un file relativo al tuo problema, per esempio se vuoi aggiungere opzione ai driver video intel, farai un 10-intel.conf e ci metterai la sezione dentro, sezione come avresti fatto in xorg.conf (che in teoria puoi sempre utilizzare)

Rispondi