[RISOLTO] error while loading shared libraries: libsteam_api.so

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
tornadomig
Linux 3.x
Linux 3.x
Messaggi: 567
Iscritto il: gio set 30, 2010 15:17
Nome Cognome: Giorgio
Slackware: Current64 multilib
Kernel: 4.19.5-generic
Desktop: Xfce

[RISOLTO] error while loading shared libraries: libsteam_api.so

Messaggioda tornadomig » ven gen 19, 2018 16:34

Ciao a tutti!

Condivido questa risoluzione a chi ha questo problema.
A me è già successo due volte, sempre su Slackware 64 -current multilib, su pc uefi e anche legacy bios, nell'arco di un paio di mesi.
Dopo vari upgrade di sistema, lancio il mio gioco preferito su Steam, Euro Truck Simulator 2 e a terminale vedo che il gioco non parte. Steam sì, però.
Scaricate a questo indirizzo:

Codice: Seleziona tutto

x86_64 lib : https://github.com/rlabrecque/Steamworks.NET/raw/master/Plugins/x86_64/libsteam_api.so

oppure

Codice: Seleziona tutto

x86 lib : https://github.com/ValveSoftware/source-sdk-2013/raw/master/mp/src/lib/public/linux32/libsteam_api.so

rispettivamente per chi ha architettura 64 o a 32 bit.
Dopo, nella directory dove avete appena scaricato il suddetto file, date:

Codice: Seleziona tutto

# cp libsteam_api.so /usr/lib

Così facendo il gioco riparte normale.

Spero serva a qualcuno, oppure cercate con Google altre risposte.
rm -rf / && rm -rf . && rm -rf *

Avatar utente
tornadomig
Linux 3.x
Linux 3.x
Messaggi: 567
Iscritto il: gio set 30, 2010 15:17
Nome Cognome: Giorgio
Slackware: Current64 multilib
Kernel: 4.19.5-generic
Desktop: Xfce

Re: [RISOLTO] error while loading shared libraries: libsteam_api.so

Messaggioda tornadomig » gio mag 31, 2018 21:49

Ciao a tutti,

ciò capita sempre e soltanto se si installa steamclient di Alienbob. Con slackbuilds.org invece non si presenta la cosa.

Scusate, era solo per precisare.

Buona serata!
rm -rf / && rm -rf . && rm -rf *

Avatar utente
tornadomig
Linux 3.x
Linux 3.x
Messaggi: 567
Iscritto il: gio set 30, 2010 15:17
Nome Cognome: Giorgio
Slackware: Current64 multilib
Kernel: 4.19.5-generic
Desktop: Xfce

Re: [RISOLTO] error while loading shared libraries: libsteam_api.so

Messaggioda tornadomig » sab giu 09, 2018 16:29

tornadomig ha scritto:Ciao a tutti!

Condivido risoluzione a chi ha questo problema.
A me è già successo due volte, sempre su Slackware 64 -current multilib, su pc uefi e anche legacy bios, nell'arco di un paio di mesi.
Dopo vari upgrade di sistema, lancio il mio gioco preferito su Steam, Euro Truck Simulator 2 e a terminale vedo che il gioco non parte. Steam sì, però.
Scaricate a questo indirizzo:

Codice: Seleziona tutto

x86_64 lib : https://github.com/rlabrecque/Steamworks.NET/raw/master/Plugins/x86_64/libsteam_api.so

oppure

Codice: Seleziona tutto

x86 lib : https://github.com/ValveSoftware/source-sdk-2013/raw/master/mp/src/lib/public/linux32/libsteam_api.so

rispettivamente per chi ha architettura 64 o a 32 bit.
Dopo, nella directory dove avete appena scaricato il suddetto file, date:

Codice: Seleziona tutto

# cp libsteam_api.so /usr/lib

Così facendo il gioco riparte normale.

Spero serva a qualcuno, oppure cercate con Google altre risposte.
rm -rf / && rm -rf . && rm -rf *