Problema installazione aMule da Slackbuild

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Pigi
Linux 0.x
Linux 0.x
Messaggi: 2
Iscritto il: gio 26 apr 2018, 10:48

Re: Problema installazione aMule da Slackbuild

Messaggio da Pigi »

Ciao a tutti, e scusate l' intervento " a gamba tesa".
Il problema segnalato nel primo post riguarda un cambio di primitive della crypto++ dalla 6 in poi.

https://github.com/amule-project/amule/issues/119
ed il fix e' riportato qui:
https://github.com/amule-project/amule/ ... e7b6a3a8aa

Io pero, passato questo punto, ho un problema ( identico sia con la crypto++ >6 che con <6 ) in fase di link, ma ci sto ancora combattendo.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2732
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.5.3-ck1
Desktop: lxde
Località: Pisa
Contatta:

Re: Problema installazione aMule da Slackbuild

Messaggio da ponce »

Pigi ha scritto:Ciao a tutti, e scusate l' intervento " a gamba tesa".
Il problema segnalato nel primo post riguarda un cambio di primitive della crypto++ dalla 6 in poi.

https://github.com/amule-project/amule/issues/119
ed il fix e' riportato qui:
https://github.com/amule-project/amule/ ... e7b6a3a8aa
e' molto strano, perche' l'autore del topic diceva di aver installato cryptopp-5.6.x. da SlackBuilds.org (gliel'avevo chiesto espressamente nella prima risposta).

Pigi
Linux 0.x
Linux 0.x
Messaggi: 2
Iscritto il: gio 26 apr 2018, 10:48

Re: Problema installazione aMule da Slackbuild

Messaggio da Pigi »

Hai ragione, Ponce, ma nelle mie innumerevoli prove di compilazione ho avuto quel problema solo con la crypto++ 6.0, mentre con la 5.6.x ho ( avevo ) solo il problema di linking.
Questo problema e' poi scomparso installando la crypto++ 5.6.5 presa dal tuo repository ( a proposito, grazie :) )

Pigi

Meskalamdug
Iper Master
Iper Master
Messaggi: 3919
Iscritto il: ven 14 mag 2004, 0:00

Re: Problema installazione aMule da Slackbuild

Messaggio da Meskalamdug »

È possibile compilare amule 2.3.2 con la nuova crypto++ usando questa patch

https://gitweb.gentoo.org/repo/gentoo.g ... 0ced8f40d4

Rispondi