Alcuni streaming e video su Firefox non si vedono [RISOLTO]

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
conraid
Staff
Staff
Messaggi: 13079
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Alcuni streaming e video su Firefox non si vedono [RISOLTO]

Messaggioda conraid » sab feb 10, 2018 15:10

Su Current 64bit.

Da un po' di tempo non vedo più per esempio i video su Gazzetta e Repubblica.
Sul sito della gazzetta i video rimangono alla prima schermata come se fosse un'immagine. Su Repubblica per esempio adesso c'è scritto "Non è stato trovato alcun formato o MIME type supportati". Pensando a un problema con ffmpeg di alien ho rimesso quello di Pat ma stesso problema.
Con Chromium li vedo tranquillamente, e se ricordo anche su Firefox fino a un po' di tempo fa.
Cosa potrei controllare?

Ho provato con profilo pulito.

UPDATE
youtube va tranquillamente, senza flash (che per essere sicuro ho disinstallato)

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2371
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.16.2
Desktop: lxde
Località: Pisa
Contatta:

Re: Alcuni streaming e video su Firefox non si vedono più

Messaggioda ponce » sab feb 10, 2018 18:05

e' probabile che non ti funzioni flash: quale versione dello stesso stai usando?

Avatar utente
conraid
Staff
Staff
Messaggi: 13079
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Alcuni streaming e video su Firefox non si vedono più

Messaggioda conraid » sab feb 10, 2018 18:36

Flash funziona, quei video son senza flash. Tra l'altro cliccando con "visualizza video" e dico di usare VLC li vedo.

Avviando da terminale noto questi errori

Codice: Seleziona tutto

:~$ firefox
[Child 8997, MediaPlayback #2] WARNING: 7f9500e8a1c0 OpenCubeb() failed to init cubeb: file /tmp/firefox-58.0.2/dom/media/AudioStream.cpp, line 387
[Child 8997, MediaPlayback #2] WARNING: Decoder=7f9501074000 [OnMediaSinkAudioError]: file /tmp/firefox-58.0.2/dom/media/MediaDecoderStateMachine.cpp, line 3642


Firefox-developer me li mostra tranquillamente.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2371
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.16.2
Desktop: lxde
Località: Pisa
Contatta:

Re: Alcuni streaming e video su Firefox non si vedono più

Messaggioda ponce » sab feb 10, 2018 18:45

forse devi ricompilare ffmpeg sull'ultima current col supporto, ad esempio, di x264?

Avatar utente
conraid
Staff
Staff
Messaggi: 13079
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Alcuni streaming e video su Firefox non si vedono

Messaggioda conraid » sab feb 10, 2018 18:50

Comunque ho detto cosa non vera, Firefox-developer mi mostra quelli della gazzetta, ma i live di repubblica dice ugualmente che non c'è mime type
https://video.repubblica.it/edizione/mi ... P1-S1.8-T2

Avatar utente
conraid
Staff
Staff
Messaggi: 13079
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Alcuni streaming e video su Firefox non si vedono

Messaggioda conraid » sab feb 10, 2018 18:51

Ma lo fa sia con quello di Alien sia con quello di Pat, dici che quello di Alien non è aggiornato e quello di Pat manca il supporto?

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2371
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.16.2
Desktop: lxde
Località: Pisa
Contatta:

Re: Alcuni streaming e video su Firefox non si vedono

Messaggioda ponce » sab feb 10, 2018 19:25

si, e' possibile che quello di Alien Bob, che dovrebbe supportare x264, non sia stato ricompilato dopo l'aggiornamento a glibc-2.27.

Avatar utente
conraid
Staff
Staff
Messaggi: 13079
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Alcuni streaming e video su Firefox non si vedono

Messaggioda conraid » sab feb 10, 2018 19:36

Sto provando a ricompilare con il build di Alien. Vediamo quanto ci sta.

Avatar utente
conraid
Staff
Staff
Messaggi: 13079
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Alcuni streaming e video su Firefox non si vedono

Messaggioda conraid » sab feb 10, 2018 20:13

E dalla curva si alza un coro "LODE A TE MATTEO PONCE, LODE A TE MATTEO PONCE" :D

Il live non so, perché non c'è più, ma i video si vedono dopo la ricompilazione :)

idefix
Linux 1.x
Linux 1.x
Messaggi: 178
Iscritto il: gio giu 19, 2008 1:48
Nome Cognome: stefano
Slackware: slack64-14.2
Kernel: 4.4.19
Desktop: tde 14.0.3

Re: Alcuni streaming e video su Firefox non si vedono

Messaggioda idefix » sab feb 10, 2018 22:26

non usate mai i binari gia pronti di firefox ?
ci sono per varie piattaforme e varie lingue.
italiano compreso.

https://ftp.mozilla.org/pub/firefox/releases/58.0.2/

veloce e funzionale.

Avatar utente
conraid
Staff
Staff
Messaggi: 13079
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Alcuni streaming e video su Firefox non si vedono

Messaggioda conraid » dom feb 11, 2018 11:37

idefix ha scritto:non usate mai i binari gia pronti di firefox ?
ci sono per varie piattaforme e varie lingue.
italiano compreso.

https://ftp.mozilla.org/pub/firefox/releases/58.0.2/

veloce e funzionale.


Non sarebbe cambiato niente, infatti il problema era ffmpeg, è quello che ho dovuto ricompilare.

idefix
Linux 1.x
Linux 1.x
Messaggi: 178
Iscritto il: gio giu 19, 2008 1:48
Nome Cognome: stefano
Slackware: slack64-14.2
Kernel: 4.4.19
Desktop: tde 14.0.3

Re: Alcuni streaming e video su Firefox non si vedono

Messaggioda idefix » dom feb 11, 2018 12:10

ok, ora capisco...
io ffmpeg lo avevo gia ricompilato per mie necessita
quindi non avevo notato il problema.

comunque i binari gia fatti sono molto comodi.