Slackware64 Current - Configurazione Slackpkg+

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3205
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Slackware64 Current - Configurazione Slackpkg+

Messaggio da joe »

Come glà discusso nel topic, "Considerazioni su Slackware e Alternative", vorrei un attimo fare il punto sulla configurazione del software in oggetto Slackpkg+ in modo tale da poter mantenere un sistema current.
Nel dettaglio:
- mi serve multilib, ma non ci devo compilare pacchetti 32bit, solo alcuni programmi 32 devo farli girare sul sistema 64, che ricordi al volo sicuramente i driver proprietari della stampante Brother.
- uso degli slackbuilds di SBo, almeno quelli di ponce per la current, ma poi anche gli altri sperando che funzionino per i programmi che mi servono, nonostante siano per la stabile. Il tutto possibilmente con sbopkg. Va be' se mai ne riparleremo.
- aggiungereri anche i repo di Alen (alienbob e restricted)

Allora, leggendo il README di slackpkg+ ho creato la seguente configurazione:

slackpkgplus.conf

Codice: Seleziona tutto

# sed -e '/^#/d' -e '/^$/d' /mnt/ssd/etc/slackpkg/slackpkgplus.conf
SLACKPKGPLUS=on
VERBOSE=1
ALLOW32BIT=off
USEBL=1
WGETOPTS="--timeout=20 --tries=2"
SEARCH_CLOG_INPARENT=on
CACHEUPDATE=off
GREYLIST=on
SENSITIVE_SEARCH=on
WW_FILE_SEARCH=on
SHOWORDER=package
DETAILED_INFO=none
STRICTGPG=on
PKGS_PRIORITY=( patches:gcc slackware64:gcc multilib )
TAG_PRIORITY=off
REPOPLUS=( slackpkgplus restricted alienbob )
MIRRORPLUS['alienbob']=http://bear.alienbase.nl/mirrors/people/alien/sbrepos/current/x86_64/
MIRRORPLUS['restricted']=http://bear.alienbase.nl/mirrors/people/alien/restricted_sbrepos/current/x86_64/
MIRRORPLUS['slackpkgplus']=http://slakfinder.org/slackpkg+/
MIRRORPLUS['multilib']=http://bear.alienbase.nl/mirrors/people/alien/multilib/current/
blacklist

Codice: Seleziona tutto

# sed -e '/^#/d' -e '/^$/d' /mnt/ssd/etc/slackpkg/blacklist
kernel-generic
kernel-generic-smp
kernel-huge
kernel-huge-smp
kernel-modules
kernel-modules-smp
kernel-source
[0-9]+_SBo
kde
kdei
xfce
mirrors

Codice: Seleziona tutto

# sed -e '/^#/d' -e '/^$/d' /mnt/ssd/etc/slackpkg/mirrors
https://slackware.uk/slackware/slackware64-current/
Non nel slackpkgplus.config, non ho aggiunto multilib in REPOPLUS, perché è già in PKGS_PRIORITY.
In questo modo non dovrebbero essere considerati gli aggiornamenti del kernel, nè installata roba inerente kde o xfce, così come pacchetti già installati da SBo.
Poi, se un pacchetto è sia sul repo ufficiale che sul repo "multilib" di alien, allora verrà data la precedentza a quest'ultimo (a parte gcc).
Poi, se un pacchetto non è trovato né in multilib né sul repo ufficiale, ecco che vengono considerati gli altri repo in REPOPLUS, da come ho capito in ordine di priorità in caso di omonimia:
slackpkgplus - poi - restricted - e infine - alienbob

Cosa vi sembra, dovrebbe essere corretto no?
Ripeto, lo scopo è di avere slack current con multilib, pescaggio dai repo di alien e installazione anche di pacchetti creati da SBo.
Correggete se vedete errori!

Rispondi