Quanto è stable la stable - glib-networking

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
ilmich
Master
Master
Messaggi: 1549
Iscritto il: lun 16 lug 2007, 17:39
Slackware: 14.2 64bit
Kernel: 4.19.46
Desktop: dwm
Località: Roma

Quanto è stable la stable - glib-networking

Messaggio da ilmich »

Buongiorno a tutti,

so di essere forse un po' blasfemo ma io continuo imperterrito ad utilizzare la stable perchè appunto mi serve un sistema 'stable'.
Purtroppo pero' oggi ho provato ad utilizzare un browser basato su webkit perchè.... vabbe non è interessante :)
Il purtroppo è legato al fatto che non ne funziona manco mezzo... dà un errore di comunicazione tls.
Dopo aver googlato un po ho visto che il problema 'dovrebbe' risiedere nelle librerie glib-networking che sulla stable sono obsolete e serve la versione >= 2.58

Sto provando a fare questo aggiornamento ma va aggiornata qualche libreria a contorno.Nessun problema.. lo faro.. pero' la mia domanda è...

La 14.2 piaccia o non piaccia è l'attuale stable.. se segnalassi questa cosa (dopo aver risolto chiaramente).. Pat secondo voi puo' valutarne l'aggiornamento o mi manda a stendere!??! (stiamo parlando del parco software legato alle gtk)

Un saluto
ho visto cose che voi astemi non potete immaginare
https://github.com/ilmich

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2759
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.7.10
Desktop: lxde
Località: Pisa
Contatta:

Re: Quanto è stable la stable - glib-networking

Messaggio da ponce »

credo, ma ovviamente non ne posso essere sicuro al 100%, che ti possa rispondere picche dicendo che webkit non fa parte di Slackware e che l'aggiornamento di glib2 & C. porterebbe incompatibilita' col resto del software in Slackware.

ilmich
Master
Master
Messaggi: 1549
Iscritto il: lun 16 lug 2007, 17:39
Slackware: 14.2 64bit
Kernel: 4.19.46
Desktop: dwm
Località: Roma

Re: Quanto è stable la stable - glib-networking

Messaggio da ilmich »

aggiornamento... ho risolto aggiornando 'semplicemente'

glib2
glib-networking

utilizzando gli slackbuilds della current (vanno aggiunti ninja e meson che si possono trovare su slackbuilds.org ma che io comunque già avevo)
Avendo un desktop prevalentemente gtk mi sono fatto un giro su gimp e altri e non ho riscontrato problemi di sorta, ora pero' surf e midori (browsers di cui vi parlavo) funzionano correttamente :)
ho visto cose che voi astemi non potete immaginare
https://github.com/ilmich

ilmich
Master
Master
Messaggi: 1549
Iscritto il: lun 16 lug 2007, 17:39
Slackware: 14.2 64bit
Kernel: 4.19.46
Desktop: dwm
Località: Roma

Re: Quanto è stable la stable - glib-networking

Messaggio da ilmich »

ponce ha scritto:
gio 19 mar 2020, 8:17
credo, ma ovviamente non ne posso essere sicuro al 100%, che ti possa rispondere picche dicendo che webkit non fa parte di Slackware e che l'aggiornamento di glib2 & C. porterebbe incompatibilita' col resto del software in Slackware.
ehhhh posso immaginare... anche se a sto punto (ma spero non lo facciano) andrebbero tolti da slackbuilds o comunque segnalato che sulla stable cosi' com'e' webkit non funziona piu'
ho visto cose che voi astemi non potete immaginare
https://github.com/ilmich

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2759
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.7.10
Desktop: lxde
Località: Pisa
Contatta:

Re: Quanto è stable la stable - glib-networking

Messaggio da ponce »

scusa, a quale versione di webkit su SBo ti riferisci?

se e' webkit2gtk credo che tu debba mandare un messaggio a Willy, il maintainer, descrivendogli il problema...

su current l'ho aggiornato io nel mio repository, in modo da poter usare l'ultima versione, ma credo che Willy voglia fare il backport, in qualche modo.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2759
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.7.10
Desktop: lxde
Località: Pisa
Contatta:

Re: Quanto è stable la stable - glib-networking

Messaggio da ponce »

comunque, detto inter nos, l'aggiornamento di glib2 farebbe comodo anche per diverse altre cose (le due che uso piu' spesso sono qemu e libvirt, che sono bloccati alle versioni attuali), ma la vedo ardua.

ilmich
Master
Master
Messaggi: 1549
Iscritto il: lun 16 lug 2007, 17:39
Slackware: 14.2 64bit
Kernel: 4.19.46
Desktop: dwm
Località: Roma

Re: Quanto è stable la stable - glib-networking

Messaggio da ilmich »

ponce ha scritto:
gio 19 mar 2020, 9:28
se e' webkit2gtk credo che tu debba mandare un messaggio a Willy, il maintainer, descrivendogli il problema...
si quella... non ho provato con le altre... comunque il problema non è nella versione di webkit... ma è sul sistema.
Da quello che posso immaginare nel mondo sono stati deprecati alcuni protocolli tls che hanno perciò smesso di funzionare, quindi aggiornando glib-networking si deve essere aggiornata anche questa gestione e di conseguenza webkit che lo utilizza funziona nuovamente.

posso comunque scrivergli, ma dubito possa farci molto perchè purtroppo tocca aggiornare in coppia glib2 e glib-networking.

in ogni caso penso che si possa fare un tentativo con Pat... è vero che webkit non è un pacchetto ufficiale pero' diciamo che comunque le glib-networking sono di fatto insicure.
ho visto cose che voi astemi non potete immaginare
https://github.com/ilmich

ilmich
Master
Master
Messaggi: 1549
Iscritto il: lun 16 lug 2007, 17:39
Slackware: 14.2 64bit
Kernel: 4.19.46
Desktop: dwm
Località: Roma

Re: Quanto è stable la stable - glib-networking

Messaggio da ilmich »

comunque per chi ne avesse bisogno i due pacchetti sono qui

https://ilmich.github.io/slk64-14.2/gli ... 6_64-1.txz
https://ilmich.github.io/slk64-14.2/gli ... 6_64-1.txz

come dicevo in precedenza ho installato da SBO

ninja
meson

eppoi ho ricompilato utilizzando i due slackbuilds della current

https://mirrors.slackware.com/slackware ... e/l/glib2/
https://mirrors.slackware.com/slackware ... etworking/
ho visto cose che voi astemi non potete immaginare
https://github.com/ilmich

Rispondi