la macchina non si spegne

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
Rama
Linux 3.x
Linux 3.x
Messaggi: 560
Iscritto il: sab 29 mar 2008, 12:18
Slackware: 15.0 x86_64
Kernel: 5.15.117
Desktop: KDE 5.23
Distribuzione: linuxmint-21.1-xfce
Località: Novara, provincia

la macchina non si spegne

Messaggio da Rama »

ieri ho spento il pc dopo 12 giorni per poter provare stamani Win11 pro, dopo mezz'ora mi son stufato, ho riavviato e tornato alla Slack, però ho avuto la sgradita sorpresa che né la sospensione, né lo spegnimento e né il riavvio funzionano -fatti da KDE;
dopo l'ultimo Spegni in messages trovo:

Apr 15 15:40:04 darkstar last message buffered 2 times
Apr 15 15:40:04 darkstar kernel: pcieport 0000:00:1d.4: AER: Multiple Corrected error received: 0000:00:1d.4
Apr 15 15:40:05 darkstar last message buffered 1 times
Apr 15 15:46:52 darkstar kernel: pcieport 0000:00:1d.4: AER: Corrected error received: 0000:00:1d.4
Apr 15 15:46:54 darkstar last message buffered 1 times

CTRL+ALT+CANC non va, se provo CTRL+ALT+F1 dopo il login come root ci pensa un po' e poi:
timed out after 60 seconds

in syslog:

Apr 15 15:40:05 darkstar kernel: pcieport 0000:00:1d.4: [ 0] RxErr
Apr 15 15:46:52 darkstar kernel: pcieport 0000:00:1d.4: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Receiver ID)
Apr 15 15:46:52 darkstar kernel: pcieport 0000:00:1d.4: device [8086:9db4] error status/mask=00000080/00000000
Apr 15 15:46:52 darkstar kernel: pcieport 0000:00:1d.4: [ 7] BadDLLP
Apr 15 15:46:54 darkstar kernel: pcieport 0000:00:1d.4: PCIe Bus Error: severity=Corrected, type=Physical Layer, (Receiver ID)
Apr 15 15:46:54 darkstar kernel: pcieport 0000:00:1d.4: device [8086:9db4] error status/mask=00000081/00000000
Apr 15 15:46:54 darkstar kernel: pcieport 0000:00:1d.4: [ 0] RxErr
Apr 15 15:46:54 darkstar kernel: pcieport 0000:00:1d.4: [ 7] BadDLLP

erio
Linux 4.x
Linux 4.x
Messaggi: 1354
Iscritto il: ven 9 ott 2009, 19:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: la macchina non si spegne

Messaggio da erio »


Avatar utente
Rama
Linux 3.x
Linux 3.x
Messaggi: 560
Iscritto il: sab 29 mar 2008, 12:18
Slackware: 15.0 x86_64
Kernel: 5.15.117
Desktop: KDE 5.23
Distribuzione: linuxmint-21.1-xfce
Località: Novara, provincia

Re: la macchina non si spegne

Messaggio da Rama »

ho guardato ma vo a tentoni ;-P
mi ero segnato di cambiare la modalità di PCIE16_3 da auto a x8 e disabilitare AER, presumo nel bios;
solo che spento (col tasto) e riavviato nel bios non ho trovato le voci;
riavviato e la sospensione funziona, ora do un'occhiata ai log...
nulla in messages;
molto in syslog:

Apr 15 18:08:44 darkstar kernel: x86/cpu: SGX disabled by BIOS.
Apr 15 18:08:44 darkstar kernel: MDS CPU bug present and SMT on, data leak possible. See https://www.kernel.org/doc/html/latest/ ... n/mds.html for more details.
Apr 15 18:08:44 darkstar kernel: MMIO Stale Data CPU bug present and SMT on, data leak possible. See https://www.kernel.org/doc/html/latest/ ... _data.html for more details.
Apr 15 18:08:44 darkstar kernel: #5 #6 #7
Apr 15 18:08:44 darkstar kernel: ENERGY_PERF_BIAS: Set to 'normal', was 'performance'
Apr 15 18:08:44 darkstar kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XDCI], AE_NOT_FOUND (20210730/dswload2-162)
Apr 15 18:08:44 darkstar kernel: ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20210730/psobject-220)
Apr 15 18:08:44 darkstar kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PR00._CPC], AE_NOT_FOUND (20210730/psargs-330)
Apr 15 18:08:44 darkstar kernel: ACPI Error: Aborting method \_SB.PR01._CPC due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
Apr 15 18:08:44 darkstar kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PR00._CPC], AE_NOT_FOUND (20210730/psargs-330)
Apr 15 18:08:44 darkstar kernel: ACPI Error: Aborting method \_SB.PR02._CPC due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
Apr 15 18:08:44 darkstar kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PR00._CPC], AE_NOT_FOUND (20210730/psargs-330)
Apr 15 18:08:44 darkstar kernel: ACPI Error: Aborting method \_SB.PR03._CPC due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
Apr 15 18:08:44 darkstar kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PR00._CPC], AE_NOT_FOUND (20210730/psargs-330)
Apr 15 18:08:44 darkstar kernel: ACPI Error: Aborting method \_SB.PR04._CPC due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
Apr 15 18:08:44 darkstar kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PR00._CPC], AE_NOT_FOUND (20210730/psargs-330)
Apr 15 18:08:44 darkstar kernel: ACPI Error: Aborting method \_SB.PR05._CPC due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
Apr 15 18:08:44 darkstar kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PR00._CPC], AE_NOT_FOUND (20210730/psargs-330)
Apr 15 18:08:44 darkstar kernel: ACPI Error: Aborting method \_SB.PR06._CPC due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
Apr 15 18:08:44 darkstar kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PR00._CPC], AE_NOT_FOUND (20210730/psargs-330)
Apr 15 18:08:44 darkstar kernel: ACPI Error: Aborting method \_SB.PR07._CPC due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
Apr 15 18:08:44 darkstar kernel: ata2.00: supports DRM functions and may not be fully accessible
Apr 15 18:08:44 darkstar last message buffered 1 times
Apr 15 18:08:49 darkstar kernel: acpi PNP0C14:01: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:00)
Apr 15 18:08:51 darkstar kernel: thermal thermal_zone2: failed to read out thermal zone (-61)
Apr 15 18:08:53 darkstar kernel: snd_hda_codec_hdmi hdaudioC0D2: Monitor plugged-in, Failed to power up codec ret=[-13]
Apr 15 18:09:07 darkstar kernel: vboxdrv: loading out-of-tree module taints kernel.
Apr 15 18:09:08 darkstar kernel: VBoxNetFlt: Successfully started.
Apr 15 18:09:08 darkstar kernel: VBoxNetAdp: Successfully started.
Apr 15 18:09:20 darkstar pulseaudio[1898]: [pulseaudio] cli-command.c: stat('/etc/pulse/default.pa.d'): File o directory non esistente
Apr 15 18:09:20 darkstar pulseaudio[1947]: [pulseaudio] pid.c: Daemon already running.
Apr 15 18:09:41 darkstar kernel: ata2.00: supports DRM functions and may not be fully accessible
Apr 15 18:09:41 darkstar last message buffered 1 times
Apr 15 18:09:41 darkstar kernel: thermal thermal_zone2: failed to read out thermal zone (-61)
Apr 15 18:09:47 darkstar gnome-keyring-daemon[1687]: module_instances: assertion 'funcs != NULL && "instances"' failed
Apr 15 18:09:47 darkstar last message buffered 1 times
Apr 15 18:09:47 darkstar gnome-keyring-daemon[1687]: lookup_login_keyring: assertion 'GCK_IS_SESSION (session)' failed
Apr 15 18:09:47 darkstar gnome-keyring-daemon[1687]: create_credential: assertion 'GCK_IS_SESSION (session)' failed
Apr 15 18:09:47 darkstar gnome-keyring-daemon[1687]: egg_error_message: assertion 'error' failed
Apr 15 18:09:47 darkstar gnome-keyring-daemon[1687]: couldn't create login credential: (unknown)

Avatar utente
Rama
Linux 3.x
Linux 3.x
Messaggi: 560
Iscritto il: sab 29 mar 2008, 12:18
Slackware: 15.0 x86_64
Kernel: 5.15.117
Desktop: KDE 5.23
Distribuzione: linuxmint-21.1-xfce
Località: Novara, provincia

Re: la macchina non si spegne

Messaggio da Rama »

seguendo questa guida https://www.kernel.org/doc/html/latest/ ... _data.html
non c'è il processore i5-8279U Coffee Lake ma in file:///sys/devices/system/cpu/vulnerabilities/mmio_stale_data ho
Mitigation: Clear CPU buffers; SMT vulnerable
secondo il sito significa The processor is vulnerable and the CPU buffer clearing mitigation is enabled.
ma dovrei disabilitare SMT (qualunque cosa sia)?

EDIT
è il multithreading, le prestazioni crollerebbero se lo disabilito?

erio
Linux 4.x
Linux 4.x
Messaggi: 1354
Iscritto il: ven 9 ott 2009, 19:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: la macchina non si spegne

Messaggio da erio »

se hai current fai l'upgrade del kernel, SMT e' l'ipertreading di intel e' strano esiste ancora?hai provato ad aggiungere questo al kernel boot
By using pci=nommconf, the configuration space of all devices will be accessed in the original way, and changing the access methods works around this problem. So if you want, it's both resolving and suppressing it.

Avatar utente
Rama
Linux 3.x
Linux 3.x
Messaggi: 560
Iscritto il: sab 29 mar 2008, 12:18
Slackware: 15.0 x86_64
Kernel: 5.15.117
Desktop: KDE 5.23
Distribuzione: linuxmint-21.1-xfce
Località: Novara, provincia

Re: la macchina non si spegne

Messaggio da Rama »

pci=nommconf andrebbe aggiunto al bootloader?
purtroppo dovrei pasticciare con elilo che non conosco affatto;

EDIT
questo potrebbe servire?
https://www.intel.it/content/www/it/it/ ... etect.html

no, non è servito;

Avatar utente
Rama
Linux 3.x
Linux 3.x
Messaggi: 560
Iscritto il: sab 29 mar 2008, 12:18
Slackware: 15.0 x86_64
Kernel: 5.15.117
Desktop: KDE 5.23
Distribuzione: linuxmint-21.1-xfce
Località: Novara, provincia

Re: la macchina non si spegne

Messaggio da Rama »

erio ha scritto:
sab 15 apr 2023, 18:46
hai provato ad aggiungere questo al kernel boot
By using pci=nommconf
ho provato ma sembra che non abbia alcun bootloader: grub ha solo la dir Themes, elilo niente, lilo.conf non c'è;
è un mistero come si avvii;

erio
Linux 4.x
Linux 4.x
Messaggi: 1354
Iscritto il: ven 9 ott 2009, 19:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: la macchina non si spegne

Messaggio da erio »

beh! hai debian slackware e windows non e' che parte dall'ultimo,se e' cosi non so che dirti,ogni volta che parte il portatile mi prende l'acido a vedere sta rotellina che gira gira....

Avatar utente
Rama
Linux 3.x
Linux 3.x
Messaggi: 560
Iscritto il: sab 29 mar 2008, 12:18
Slackware: 15.0 x86_64
Kernel: 5.15.117
Desktop: KDE 5.23
Distribuzione: linuxmint-21.1-xfce
Località: Novara, provincia

Re: la macchina non si spegne

Messaggio da Rama »

da bios ho impostato la Slack, se voglio scegliere le altre devo premere F7, ma può darsi che in realtà sia Debian ad occuparsene;
però l'ho messa dopo la Debian che mi gestiva la Slack quando l'avevo sul secondo disco;

susumella
Linux 2.x
Linux 2.x
Messaggi: 455
Iscritto il: mar 25 mag 2004, 0:00

Re: la macchina non si spegne

Messaggio da susumella »

guarda, magari non sarà così, ma io ho avuto lo stesso problema ed era dovuto al pacchetto di Skype (non ci crederai, lo capisco, dopo un mese di analisi ero incredulo anche io). Se ce l'hai, prova a disinstallarlo (io poi ho ricompilato a mano)

susumella
Linux 2.x
Linux 2.x
Messaggi: 455
Iscritto il: mar 25 mag 2004, 0:00

Re: la macchina non si spegne

Messaggio da susumella »

per essere precisi, ti linko il thread:
viewtopic.php?f=51&t=41361&p=355786#p355786

Avatar utente
Rama
Linux 3.x
Linux 3.x
Messaggi: 560
Iscritto il: sab 29 mar 2008, 12:18
Slackware: 15.0 x86_64
Kernel: 5.15.117
Desktop: KDE 5.23
Distribuzione: linuxmint-21.1-xfce
Località: Novara, provincia

Re: la macchina non si spegne

Messaggio da Rama »

non ho Skype;
al momento il problema non si è ripresentato;

Rispondi