virtualbox 6.1.44 errore segmentazione da fluxbox

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
red
Linux 3.x
Linux 3.x
Messaggi: 810
Iscritto il: gio 20 gen 2005, 0:00
Slackware: current
Kernel: 6.6.12
Desktop: fluxbox
Località: Verona
Contatta:

virtualbox 6.1.44 errore segmentazione da fluxbox

Messaggio da red »

Ciao a tutti,
non riesco a trovare una soluzione al problema, a patto che esista.

VirtualBox funziona perfettamente in KDE, ma se lo lancio da Fluxbox dà "errore di segmentazione".
Lo compilo con gli slackbuild di Ponce presi da Github perché quelli di SBo mi funzionano, ma non "slackware-addons" che dà errore.

L'unica cosa che ho pensato è che sia un problema delle QT, ma sinceramente non saprei come fare perché anche in rete non trovo nulla.

Quindi chiedo a voi se avete anche voi questo problema e se eventualmente sapete come risolvere.

Grazie.

Avatar utente
brg
Linux 3.x
Linux 3.x
Messaggi: 580
Iscritto il: sab 12 mar 2011, 14:20
Slackware: 15.0
Kernel: 5.15.117
Desktop: KDE5
Località: Montecatini
Contatta:

Re: virtualbox 6.1.44 errore segmentazione da fluxbox

Messaggio da brg »

Potrebbe essere un problema di variabili di sistema o di qualcos'altro che viene impostato in KDE, ma non in Fluxbox? Oppure un problema con d-bus o systemd? O magari Fluxbox parte con Wayland e KDE con X11? Fluxbox non è più aggiornato da anni e quindi non è integrato con le ultime tecnologie.

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3829
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 15.0
Kernel: 5.15.38
Desktop: dwm

Re: virtualbox 6.1.44 errore segmentazione da fluxbox

Messaggio da joe »

Un paio di altre ipotesi:
- KDE lo usi da inti4 quindi con un display manager (slack di default lancia SDDM)
- invece fluxbox lo hai impostato via init3

Dicci tu se è il caso.
Un esempio è Teamviewer, che in init3 non funziona. Per cui se si vuole utilizzare occorre per forza impostare init4 e display manager ecc...

Però probabilmente nel tuo caso sei nello stessa condizione di init per entrambi gli ambienti grafici, quindi la cosa mi sa che abbia poco senso, ma non si sa mai la butto lì lo stesso.

Rispondi