configurazione wireless

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
Mr_pippo91
Linux 0.x
Linux 0.x
Messaggi: 40
Iscritto il: ven 16 mag 2008, 15:53
Nome Cognome: Filippo detto PIPPO
Slackware: 12.0
Kernel: 3.5.7

Re: configurazione wireless

Messaggio da Mr_pippo91 »

e la chiave esadecimale che è?

Bart
Staff
Staff
Messaggi: 4249
Iscritto il: lun 9 ago 2004, 0:00
Località: Rimini

Re: configurazione wireless

Messaggio da Bart »

Ci va la tua password.

Avatar utente
ksniffer
Linux 3.x
Linux 3.x
Messaggi: 540
Iscritto il: lun 30 lug 2007, 13:18
Kernel: 2.6.34
Desktop: KDE 4.4.4
Distribuzione: ArchLinux
Contatta:

Re: configurazione wireless

Messaggio da ksniffer »

prova a usare wlassistant-0.5.7 è nei pacchetti di slacky.eu .

Hai Slackware 12.0 o 12.1?

Avatar utente
Mr_pippo91
Linux 0.x
Linux 0.x
Messaggi: 40
Iscritto il: ven 16 mag 2008, 15:53
Nome Cognome: Filippo detto PIPPO
Slackware: 12.0
Kernel: 3.5.7

Re: configurazione wireless

Messaggio da Mr_pippo91 »

ho una slackware 12... il programma per rilevare la rete è KWiFiManager... il punto è che non ho capito alcune modifiche che mi hanno detto di fare....

Bart
Staff
Staff
Messaggi: 4249
Iscritto il: lun 9 ago 2004, 0:00
Località: Rimini

Re: configurazione wireless

Messaggio da Bart »

Mr_pippo91 ha scritto:ho una slackware 12... il programma per rilevare la rete è KWiFiManager... il punto è che non ho capito alcune modifiche che mi hanno detto di fare....
Per rilevare la rete non ti servono tool del genere ma hai già tutto, poi dipende dai tuoi gusti. Cosa non hai capito?

Avatar utente
corrado
Linux 2.x
Linux 2.x
Messaggi: 218
Iscritto il: dom 13 feb 2005, 0:00
Nome Cognome: corrado
Slackware: current
Kernel: 2.6.29.6-smp
Desktop: kde-4
Località: isola del liri
Contatta:

Re: configurazione wireless

Messaggio da corrado »

Bart ha scritto:
Mr_pippo91 ha scritto:ho una slackware 12... il programma per rilevare la rete è KWiFiManager... il punto è che non ho capito alcune modifiche che mi hanno detto di fare....
Per rilevare la rete non ti servono tool del genere ma hai già tutto, poi dipende dai tuoi gusti. Cosa non hai capito?
Mi accodo a questo post... Dopo l'aggiornamento alla 12.1 ho avuto dei problemi con il wireless. Ora riesco ad "abilitare" l'interfaccia wireless e quindi a pingarla ma non rilevo la rete di casa (e di conseguenza non navigo...).
Posto i miei file di configurazione.
- /etc/wpa_supplicant:

Codice: Seleziona tutto

ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1

# WPA protected network, supply your own ESSID and WPAPSK here:
network={
  scan_ssid=0
  ssid="SSID_di_casa"
  proto=WPA
  key_mgmt=WPA-PSK
  pairwise=CCMP TKIP
  group=CCMP TKIP WEP104 WEP40
  psk="la-parola-che-ho-messo-sul-router"
  priority=9
}
- /etc/rc.d/rc.inet1.conf

Codice: Seleziona tutto

# Config information for eth0:
IPADDR[0]="192.168.0.3"
NETMASK[0]="255.255.255.0"
#USE_DHCP[0]=""
#DHCP_HOSTNAME[0]=""

# Default gateway IP address:
GATEWAY="192.168.0.1"

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"

## Example config information for wlan0.  Uncomment the lines you need and fill
## in your info.  (You may not need all of these for your wireless network)
IFNAME[4]="wlan0"
IPADDR[4]="192.168.0.4"
NETMASK[4]="255.255.255.0"
#USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
#WLAN_ESSID[4]=NETGEAR_casa
#WLAN_MODE[4]=Managed
#WLAN_RATE[4]="54M auto"
#WLAN_CHANNEL[4]="auto"
#WLAN_KEY[4]="770B993CDD"
WLAN_IWPRIV[4]="AuthMode=WPAPSK EncrypType=TKIP WPAPSK=..numeri-e-lettere-che-erano-già-presenti-nel-file..."
WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="ndiswrapper"

## Some examples of additional network parameters that you can use.
## Config information for wlan0:
#IFNAME[4]="wlan0"              # Use a different interface name nstead of
                                # the default 'eth4'
#HWADDR[4]="00:01:23:45:67:89"  # Overrule the card's hardware MAC address
#MTU[4]=""                      # The default MTU is 1500, but you might need
                                # 1360 when you use NAT'ed IPSec traffic.
#DHCP_KEEPRESOLV[4]="yes"       # If you dont want /etc/resolv.conf overwritten
#DHCP_KEEPNTP[4]="yes"          # If you don't want ntp.conf overwritten
#DHCP_KEEPGW[4]="yes"           # If you don't want the DHCP server to change
                                # your default gateway
#DHCP_IPADDR[4]=""              # Request a specific IP address from the DHCP
                                # server
#WLAN_ESSID[4]=DARKSTAR         # Here, you can override _any_ parameter
                                # defined in rc.wireless.conf, by prepending
                                # 'WLAN_' to the parameter's name. Useful for
                                # those with multiple wireless interfaces.
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=thekey"
                                # Some drivers require a private ioctl to be
                                # set through the iwpriv command. If more than
                                # one is required, you can place them in the
                                # IWPRIV parameter (separated with the pipe (|)
                                # character, see the example).
- /etc/rc.d/rc.wireless.conf

Codice: Seleziona tutto

VERBOSE=1

case "$HWADDR" in

## NOTE : Comment out the following five lines to activate the samples below ...
## --------- START SECTION TO REMOVE -----------
## Pick up any Access Point, should work on most 802.11 cards
#*)
#    INFO="Any ESSID"
#    ESSID="any"
#   ;;
## ---------- END SECTION TO REMOVE ------------


# Here are a few examples with a few Wireless LANs supported...
# The matching is done on the first 3 bytes of the MAC address

# mia configurazione
00:1b:11:ba:*)
INFO="Configurazione mia scheda"
    ESSID="NETGEAR_casa"
    MODE="Managed"
    CHANNEL="11"
    RATE="auto"
    KEY="la-parola-che-ho-messo-sul-router"
    ;;
esac
Non riesco a capire dove è l'errore...
Inoltre non so se KEY, nel file rc.wireless.conf, e psk, nel file wpa_supplicant.conf, hanno lo stesso valore.
Ancora, nella parte finale del file rc.inet1.conf devo modificare qualcosa?

Saluti
corrado

Bart
Staff
Staff
Messaggi: 4249
Iscritto il: lun 9 ago 2004, 0:00
Località: Rimini

Re: configurazione wireless

Messaggio da Bart »

In /etc/rc.d/rc.wireless.conf KEY,ESSID e CHANNEL non servono se li setti in /etc/wpa_supplicant.conf.
In /etc/rc.d/rc.inet1.conf bisogna capire se devi usare il dhcp o no. Vedo che hai configurato molti parametri ma non li hai decommentati: c'è ancora il # davanti al comando.
Infine ti ricordo che devi lanciare prima il comando

Codice: Seleziona tutto

wpa_supplicant -D wext -c /etc/wpa_supplicant.conf -ieth1
(ovviamente con le tue impostazioni, queste sono le mie)
prima di riavviare la rete, altrimenti non ti vedrà mai la connessione wireless.

Avatar utente
corrado
Linux 2.x
Linux 2.x
Messaggi: 218
Iscritto il: dom 13 feb 2005, 0:00
Nome Cognome: corrado
Slackware: current
Kernel: 2.6.29.6-smp
Desktop: kde-4
Località: isola del liri
Contatta:

Re: configurazione wireless

Messaggio da corrado »

Bart ha scritto:In /etc/rc.d/rc.wireless.conf KEY,ESSID e CHANNEL non servono se li setti in /etc/wpa_supplicant.conf.
In /etc/rc.d/rc.inet1.conf bisogna capire se devi usare il dhcp o no.
Non uso il dhcp.
Vedo che hai configurato molti parametri ma non li hai decommentati: c'è ancora il # davanti al comando.
Non so quali devo decommentare e quali no...ho cercato di attenermi alla configurazione che hai postato tu.
Infine ti ricordo che devi lanciare prima il comando

Codice: Seleziona tutto

wpa_supplicant -D wext -c /etc/wpa_supplicant.conf -ieth1
(ovviamente con le tue impostazioni, queste sono le mie)
prima di riavviare la rete, altrimenti non ti vedrà mai la connessione wireless.
Ho dato il comando cambiando "wext" con ath5k (che credo sia il modulo per le atheros) ma ottengo questo messaggio:

Codice: Seleziona tutto

root@darkstar:/home/corrado# wpa_supplicant -D ath5k -c /etc/wpa_supplicant.conf -i wlan0
Unsupported driver 'ath5k'.
Se invece uso il "wext" ottengo:

Codice: Seleziona tutto

root@darkstar:/home/corrado# wpa_supplicant -D wext -c /etc/wpa_supplicant.conf -i wlan0
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ctrl_iface exists and seems to be in use - cannot override it
Delete '/var/run/wpa_supplicant/wlan0' manually if it is not used anymore
Failed to initialize control interface '/var/run/wpa_supplicant'.
You may have another wpa_supplicant process already running or the file was
left by an unclean termination of wpa_supplicant in which case you will need
to manually remove this file before starting wpa_supplicant again.

ioctl[SIOCSIWAUTH]: Operation not supported

Bart
Staff
Staff
Messaggi: 4249
Iscritto il: lun 9 ago 2004, 0:00
Località: Rimini

Re: configurazione wireless

Messaggio da Bart »

Ok Corrado, calma e sangue freddo. ;)
Che scheda hai? I driver wext vanno per le schede Intel, io ho una ipw2200bg e quindi uso quelli lì, tu invece devi mettere quelli della tua scheda wi-fi.

Avatar utente
corrado
Linux 2.x
Linux 2.x
Messaggi: 218
Iscritto il: dom 13 feb 2005, 0:00
Nome Cognome: corrado
Slackware: current
Kernel: 2.6.29.6-smp
Desktop: kde-4
Località: isola del liri
Contatta:

Re: configurazione wireless

Messaggio da corrado »

Bart ha scritto:Ok Corrado, calma e sangue freddo. ;)
Che scheda hai? I driver wext vanno per le schede Intel, io ho una ipw2200bg e quindi uso quelli lì, tu invece devi mettere quelli della tua scheda wi-fi.
Ho una d-link dwl-g520. Fino a ieri andava con i madwifi e con poche righe che avevo messo in rc.local (usavo comunque il WEP e non il WPA).
Il driver credo sia ath5k ma ottengo l'errore che ti ho postato su.
Con lsmod ath5k è caricato ma usato da "0".

Hai possibilità di instant messaging?

Avatar utente
Mr_pippo91
Linux 0.x
Linux 0.x
Messaggi: 40
Iscritto il: ven 16 mag 2008, 15:53
Nome Cognome: Filippo detto PIPPO
Slackware: 12.0
Kernel: 3.5.7

Re: configurazione wireless

Messaggio da Mr_pippo91 »

x bart.... quando io uso kWifi manager e faccio ricerca reti lui mi dice che la scansione è completa e non ne sono state rilevate alcune.... ma è impossibile dato che ho il modem a 2 metri e mezzo di distanza....

Bart
Staff
Staff
Messaggi: 4249
Iscritto il: lun 9 ago 2004, 0:00
Località: Rimini

Re: configurazione wireless

Messaggio da Bart »

Mr_pippo91 ha scritto:x bart.... quando io uso kWifi manager e faccio ricerca reti lui mi dice che la scansione è completa e non ne sono state rilevate alcune.... ma è impossibile dato che ho il modem a 2 metri e mezzo di distanza....
Prova a vedere se te le vede lanciando da root:

Codice: Seleziona tutto

iwlist [interfaccia] scanning.
dove per interfaccia devi mettere quella wireless (eth1, wlan0....)
Corrado se vuoi vengo su irc. ;) Comunque guardando i file /etc/wpa_supplicant.conf e /etc/rc.d/wireless.conf mi sembra che vadano bene. Per me il problema è su rc.inet1.conf. Tu hai settato:

Codice: Seleziona tutto

# Config information for eth0:
IPADDR[0]="192.168.0.3"
NETMASK[0]="255.255.255.0"
#USE_DHCP[0]=""
#DHCP_HOSTNAME[0]=""
Prova con

Codice: Seleziona tutto

# Config information for eth0:
IPADDR[0]="192.168.0.3"
NETMASK[0]="255.255.255.0"
USE_DHCP[0]="no"
#DHCP_HOSTNAME[0]=""
poi hai messo:

Codice: Seleziona tutto

IFNAME[4]="wlan0"
IPADDR[4]="192.168.0.4"
NETMASK[4]="255.255.255.0"
#USE_DHCP[4]="yes"
Prova con:

Codice: Seleziona tutto

IFNAME[4]="wlan0"
IPADDR[4]="192.168.0.4"
NETMASK[4]="255.255.255.0"
USE_DHCP[4]="no"
Poi prova ad usare il wpa e non il wep.
La lista dei driver con wpa_supplicant è la seguente:
drivers:
wext = Linux wireless extensions (generic)
hostap = Host AP driver (Intersil Prism2/2.5/3)
atmel = ATMEL AT76C5XXx (USB, PCMCIA)
ndiswrapper = Linux ndiswrapper
ipw = Intel ipw2100/2200 driver (old; use wext with Linux 2.6.13 or newer)
wired = wpa_supplicant wired Ethernet driver
Quindi quando te lanci:

Codice: Seleziona tutto

wpa_supplicant -D ath5k -c /etc/wpa_supplicant.conf -i wlan0
è normale che ti dia errore perché quei driver non esistono. Quando hai provato con i wext invece nell'errore ti diceva che falliva perché avevi un'altra istanza di wpa_supplicant running. Magari riprova. ;)
Se hai il supporto al wep/wpa modulare controlla che siano caricati i moduli:
IEEE80211_CRYPT_WEP per il wep;
IEEE80211_CRYPT_CCMP per aka TGi, WPA, WPA2, WPA-PSK, etc;
IEEE80211_CRYPT_TKIP per aka TGi, WPA, WPA2, WPA-PSK, etc;
Ultima cosa: una volta lanciato wpa_supplicant (se va a buon fine), affinché ti si colleghi alla tua rete wireless, devi riavviare la rete con

Codice: Seleziona tutto

/etc/rc.d/rc.inet1 restart
;)

Avatar utente
corrado
Linux 2.x
Linux 2.x
Messaggi: 218
Iscritto il: dom 13 feb 2005, 0:00
Nome Cognome: corrado
Slackware: current
Kernel: 2.6.29.6-smp
Desktop: kde-4
Località: isola del liri
Contatta:

Re: configurazione wireless

Messaggio da corrado »

Innanzi tutto grazie per la disponibilità.
Bart ha scritto: Corrado se vuoi vengo su irc. ;) Comunque guardando i file /etc/wpa_supplicant.conf e /etc/rc.d/wireless.conf mi sembra che vadano bene. Per me il problema è su rc.inet1.conf. Tu hai settato:
[...]
Prova con

Codice: Seleziona tutto

# Config information for eth0:
IPADDR[0]="192.168.0.3"
NETMASK[0]="255.255.255.0"
USE_DHCP[0]="no"
#DHCP_HOSTNAME[0]=""
[...]
Prova con:

Codice: Seleziona tutto

IFNAME[4]="wlan0"
IPADDR[4]="192.168.0.4"
NETMASK[4]="255.255.255.0"
USE_DHCP[4]="no"
Poi prova ad usare il wpa e non il wep.
La lista dei driver con wpa_supplicant è la seguente:
drivers:
wext = Linux wireless extensions (generic)
hostap = Host AP driver (Intersil Prism2/2.5/3)
atmel = ATMEL AT76C5XXx (USB, PCMCIA)
ndiswrapper = Linux ndiswrapper
ipw = Intel ipw2100/2200 driver (old; use wext with Linux 2.6.13 or newer)
wired = wpa_supplicant wired Ethernet driver
Ho fatto i cambiamenti che mi hai suggerito ma senza risultati;
ho riprovato con il driver generico wext:
dopo aver stoppato wlan0, con il comando

Codice: Seleziona tutto

/etc/rc.inet1 wlan0_stop
ho dato il comando

Codice: Seleziona tutto

wpa_supplicant -Dwext -c/etc/wpa_supplicant.conf -i wlan0
e poi ho riavviato l'interfaccio wlan0 con

Codice: Seleziona tutto

/etc/rc.inet1 wlan0_start
ma la scansione non trova alcun AP.
Se hai il supporto al wep/wpa modulare controlla che siano caricati i moduli:
IEEE80211_CRYPT_WEP per il wep;
IEEE80211_CRYPT_CCMP per aka TGi, WPA, WPA2, WPA-PSK, etc;
IEEE80211_CRYPT_TKIP per aka TGi, WPA, WPA2, WPA-PSK, etc;
Ultima cosa: una volta lanciato wpa_supplicant (se va a buon fine), affinché ti si colleghi alla tua rete wireless, devi riavviare la rete con

Codice: Seleziona tutto

/etc/rc.d/rc.inet1 restart
;)
I moduli ci sono, cioè li ho caricati con modprobe, ma la scansione non trova alcun AP...

Help me... :(

Avatar utente
corrado
Linux 2.x
Linux 2.x
Messaggi: 218
Iscritto il: dom 13 feb 2005, 0:00
Nome Cognome: corrado
Slackware: current
Kernel: 2.6.29.6-smp
Desktop: kde-4
Località: isola del liri
Contatta:

Re: configurazione wireless

Messaggio da corrado »

Ah, ho trovato sul wiki di alien il modo per ottenere la chiave esadecimale:

Codice: Seleziona tutto

wpa_passphrase ESSID-RETE parola-chiave
.

Posto anche i risultati della scansione:

Codice: Seleziona tutto

Starting AP scan (broadcast SSID)
Scan requested (ret=0) - scan timeout 30 seconds
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
Wireless event: cmd=0x8b19 len=8
Received 0 bytes of scan results (0 BSSes)
Scan results: 0
Selecting BSS from priority group 9
Try to find WPA-enabled AP
Try to find non-WPA AP
No suitable AP found.
Setting scan request: 5 sec 0 usec
Starting AP scan (broadcast SSID)
Scan requested (ret=0) - scan timeout 30 seconds
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
Wireless event: cmd=0x8b19 len=8
Received 0 bytes of scan results (0 BSSes)
Scan results: 0
Selecting BSS from priority group 9
Try to find WPA-enabled AP
Try to find non-WPA AP
No suitable AP found.
Setting scan request: 5 sec 0 usec
Ed ecco cosa ottengo dopo aver interrotto la scansione con CTRL-C:

Codice: Seleziona tutto

^CCTRL-EVENT-TERMINATING - signal 2 received
Removing interface wlan0
State: SCANNING -> DISCONNECTED
wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
No keys have been configured - skip key clearing
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
wpa_driver_wext_set_wpa
wpa_driver_wext_set_drop_unencrypted
wpa_driver_wext_set_countermeasures
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - No keys have been configured - skip key clearing
Cancelling scan request
Cancelling authentication timeout
WEXT: Operstate: linkmode=0, operstate=6
Saluti
corrado

Avatar utente
Mr_pippo91
Linux 0.x
Linux 0.x
Messaggi: 40
Iscritto il: ven 16 mag 2008, 15:53
Nome Cognome: Filippo detto PIPPO
Slackware: 12.0
Kernel: 3.5.7

Re: configurazione wireless

Messaggio da Mr_pippo91 »

ok ho dato il comando che mi hai detto sia con eth1 con eth0 e mi dice Interface doesn't support the scanning

Rispondi