[Risolto]sheda di rete ethernet: eth0 link is down

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
malik
Linux 0.x
Linux 0.x
Messaggi: 46
Iscritto il: mer 9 nov 2011, 23:02
Nome Cognome: francesco
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: kde

[Risolto]sheda di rete ethernet: eth0 link is down

Messaggio da malik »

Buonasera a tutti,

versione slackware: 13.37

kernel:

Codice: Seleziona tutto

kilam@darkstar:~$ uname -r
2.6.37.6-smp
si tratta di computer fisso con sheda di rete PCI comprata nuova.

La scheda viene riconosciuta dal sistema ma non viene riscontrato alcun link. (led della scheda mai acceso)

Codice: Seleziona tutto

02:03.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ [10ec:8139] (rev 10)
il modulo 8139too integrto nel kernel è caricato correttamente

Codice: Seleziona tutto

root@darkstar:/home/kilam\ # ifconfig -a
eth1     Link encap:Ethernet  HWaddr XXXXXXXXXXXX  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

Codice: Seleziona tutto

root@darkstar:/home/kilam\ # dmesg | grep eth1
[92211.702414] ADDRCONF(NETDEV_UP): eth1: link is not ready

Codice: Seleziona tutto

bash-4.1# ethtool eth1
Settings for eth1:
   Supported ports: [ TP MII ]
   Supported link modes:   10baseT/Half 10baseT/Full
                           100baseT/Half 100baseT/Full
   Supports auto-negotiation: Yes
   Advertised link modes:  10baseT/Half 10baseT/Full
                           100baseT/Half 100baseT/Full
   Advertised pause frame use: No
   Advertised auto-negotiation: Yes
   Speed: 10Mb/s
   Duplex: Half
   Port: MII
   PHYAD: 32
   Transceiver: internal
   Auto-negotiation: on
   Supports Wake-on: pumbg
   Wake-on: g
   Current message level: 0x00000007 (7)
                drv probe link
   Link detected: no


Il cavo di rete ed il router sono funzionanti al 100% in quanto testati sul notebook da cui scrivo.

Le prove fatte manipolando la velocità ed il duplex con ethtool non hanno prodotto risultati.

La situazione non cambia con distribuzioni live come Knoppix , dedian Lenny ,

mi potete aiutare grazie
Ultima modifica di malik il gio 25 ott 2012, 17:10, modificato 5 volte in totale.

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6545
Iscritto il: gio 3 nov 2005, 14:05
Nome Cognome: Emanuele Tomasi
Slackware: 64-current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Re: sheda di rete ethernet: eth0 link is down, ethtool :link

Messaggio da targzeta »

Ma hai provato a dare:

Codice: Seleziona tutto

ifconfig eth0 up
prima di usare la rete?


Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà 

Avatar utente
malik
Linux 0.x
Linux 0.x
Messaggi: 46
Iscritto il: mer 9 nov 2011, 23:02
Nome Cognome: francesco
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: kde

Re: sheda di rete ethernet: eth0 link is down, ethtool :link

Messaggio da malik »

Ciao e grazie per la risposta

si certo , la sheda viene attivata , tanto che dopo

Codice: Seleziona tutto

 ifconfig eth1 up
,
nel risultato del solo

Codice: Seleziona tutto

ifconfig 
la sheda è presente e nella seconda riga c'è il prefisso UP
Ultima modifica di malik il mar 9 ott 2012, 1:35, modificato 1 volta in totale.

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6545
Iscritto il: gio 3 nov 2005, 14:05
Nome Cognome: Emanuele Tomasi
Slackware: 64-current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Re: sheda di rete ethernet: eth0 link is down, ethtool :link

Messaggio da targzeta »

E quindi? Perdonami ma non capisco il problema. Cosa c'è che non va? Non navighi? Non riesci a contattare il router, cosa? Il driver ha per caso bisogno di un firmware? L'output che hai postato non dice molto.

Dai un

Codice: Seleziona tutto

dmesg
e controlla se ci sono errori inerenti la scheda.

Facci sapere,
Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà 

Avatar utente
malik
Linux 0.x
Linux 0.x
Messaggi: 46
Iscritto il: mer 9 nov 2011, 23:02
Nome Cognome: francesco
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: kde

Re: sheda di rete ethernet: eth0 link is down, ethtool :link

Messaggio da malik »

Codice: Seleziona tutto

bash-4.1# dmesg | grep eth
[    3.094287] 8139too 0000:00:09.0: eth0: RealTek RTL8139 at 0xd400, c8:3a:35:dd:fb:f9, IRQ 17
[    3.550583] udev[1141]: renamed network interface eth0 to eth1
[  102.543517] eth1: link down
[  102.543999] ADDRCONF(NETDEV_UP): eth1: link is not ready
 

non mi sembra... l'unica cosa strana è udev che rinomina, ma credo che il pc abbia una scheda integrata nella scheda madre
ma disabilitata da BIOS

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6545
Iscritto il: gio 3 nov 2005, 14:05
Nome Cognome: Emanuele Tomasi
Slackware: 64-current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Re: sheda di rete ethernet: eth0 link is down, ethtool :link

Messaggio da targzeta »

Puoi postare l'output completo di

Codice: Seleziona tutto

ifconfig -a
Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà 

Avatar utente
malik
Linux 0.x
Linux 0.x
Messaggi: 46
Iscritto il: mer 9 nov 2011, 23:02
Nome Cognome: francesco
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: kde

Re: sheda di rete ethernet: eth0 link is down, ethtool :link

Messaggio da malik »

spetta che copio

Avatar utente
malik
Linux 0.x
Linux 0.x
Messaggi: 46
Iscritto il: mer 9 nov 2011, 23:02
Nome Cognome: francesco
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: kde

Re: sheda di rete ethernet: eth0 link is down, ethtool :link

Messaggio da malik »

ecco, ditemi se avete bisogno di altro

Codice: Seleziona tutto

 
bash-4.1# ifconfig -a
eth1      Link encap:Ethernet  HWaddr C8:3A:35:DD:FB:F9  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:17 Base address:0xd400 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:44 errors:0 dropped:0 overruns:0 frame:0
          TX packets:44 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:2240 (2.1 Kb)  TX bytes:2240 (2.1

Codice: Seleziona tutto

 
bash-4.1# ifconfig
eth1      Link encap:Ethernet  HWaddr C8:3A:35:DD:FB:F9  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:17 Base address:0xd400 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:44 errors:0 dropped:0 overruns:0 frame:0
          TX packets:44 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:2240 (2.1 Kb)  TX bytes:2240 (2.1 Kb)

Codice: Seleziona tutto

 
bash-4.1# ethtool eth1
Settings for eth1:
	Supported ports: [ TP MII ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	Supports auto-negotiation: Yes
	Advertised link modes:  10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	Advertised pause frame use: No
	Advertised auto-negotiation: Yes
	Speed: 10Mb/s
	Duplex: Half
	Port: MII
	PHYAD: 32
	Transceiver: internal
	Auto-negotiation: on
	Supports Wake-on: pumbg
	Wake-on: g
	Current message level: 0x00000007 (7)
			       drv probe link
	Link detected: no

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6545
Iscritto il: gio 3 nov 2005, 14:05
Nome Cognome: Emanuele Tomasi
Slackware: 64-current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Re: sheda di rete ethernet: eth0 link is down, ethtool :link

Messaggio da targzeta »

Io non capisco. Prima era eth0, ora è diventata eth1. Ma, a parte ethtool, un semplice ping funziona? Hai un router da pingare?

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà 

Avatar utente
malik
Linux 0.x
Linux 0.x
Messaggi: 46
Iscritto il: mer 9 nov 2011, 23:02
Nome Cognome: francesco
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: kde

Re: sheda di rete ethernet: eth0 link is down, ethtool :link

Messaggio da malik »

questo lsmod, ho provato a scaricare e ricaricare il modulo ma invano.

Codice: Seleziona tutto

bash-4.1# lsmod | grep eth 
bash-4.1# lsmod | grep 8139
8139too                16597  0 
mii                     3334  1 8139too

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6545
Iscritto il: gio 3 nov 2005, 14:05
Nome Cognome: Emanuele Tomasi
Slackware: 64-current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Re: sheda di rete ethernet: eth0 link is down, ethtool :link

Messaggio da targzeta »

Mi ripeto. A parte ethtool, riesci a pingare qualcosa?

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà 

Avatar utente
malik
Linux 0.x
Linux 0.x
Messaggi: 46
Iscritto il: mer 9 nov 2011, 23:02
Nome Cognome: francesco
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: kde

Re: sheda di rete ethernet: eth0 link is down, ethtool :link

Messaggio da malik »

no Emanuele, non pingo nulla , il problema è che la sheda non ha link
, vedi che non ha nemmeno un ip address il ping verso il router restituisce
network irraggingibile

Avatar utente
malik
Linux 0.x
Linux 0.x
Messaggi: 46
Iscritto il: mer 9 nov 2011, 23:02
Nome Cognome: francesco
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: kde

Re: sheda di rete ethernet: eth0 link is down, ethtool :link

Messaggio da malik »

non considerare eth0 ho sbagliato io a copiare, mi scuso è sempre stata eth1

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6545
Iscritto il: gio 3 nov 2005, 14:05
Nome Cognome: Emanuele Tomasi
Slackware: 64-current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Re: sheda di rete ethernet: eth0 link is down, ethtool :link

Messaggio da targzeta »

Sì, non hai un IP perché non l'hai impostato. Il fatto che il link sia down non vuol dire nulla. Se hai un router con un dhcp sever, prova a dare:

Codice: Seleziona tutto

dhcpcd eth1
e vedi cosa ti da.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà 

Avatar utente
malik
Linux 0.x
Linux 0.x
Messaggi: 46
Iscritto il: mer 9 nov 2011, 23:02
Nome Cognome: francesco
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: kde

Re: sheda di rete ethernet: eth0 link is down, ethtool :link

Messaggio da malik »

ripeto il problema è il link, il led della scheda non si accende , ed ethtool restituisce no link
comunque , un attimo che ti posto il risultato della richiesta di dhcp

Rispondi