Pagina 1 di 1

Problema con tablet android

Inviato: ven giu 01, 2018 14:36
da StormyMonday
Salve a tutti, dopo un lunghissimo periodo di assenza sono tornato con un nuovo problema, anche se riguarda parzialmente Slackware, spero quindi sia la sezione giusta (oltre che il forum...)
Da qualche giorno il mio tablet cinese ha smesso di funzionare, e si blocca sulla schermata di avvio, ho provato ad entrare nel menu per fare hard reset con la combinazione di tasti ma non c'è stato verso.
Mi è stato detto che potrebbe essere la nand flash che è andata, e che si potrebbe tentare con fsck, per vedere di riparare il fs.
Il problema è che quando vado a connetterlo mi appare come usb in thunar ma non riesco ad accedervi nemmeno come root...
mi ritorna "unable to open MTP device '[usb:001,014]'"

Questo è il mio lsusb e viene rilevato come Onda

Codice: Seleziona tutto

bash-4.3$ lsusb
Bus 004 Device 004: ID 0bda:0177 Realtek Semiconductor Corp.
Bus 004 Device 003: ID 0c45:651b Microdia
Bus 004 Device 002: ID 0438:7900 Advanced Micro Devices, Inc.
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 004: ID 8087:0a2a Intel Corp.
Bus 003 Device 003: ID 046d:c051 Logitech, Inc. G3 (MX518) Optical Mouse
Bus 003 Device 002: ID 0438:7900 Advanced Micro Devices, Inc.
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 015: ID 1f3a:1007 Onda (unverified)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
bash-4.3$


MTP detect...

Codice: Seleziona tutto

bash-4.3$ mtp-detect
libmtp version: 1.1.11

Listing raw device(s)
Device 0 (VID=1f3a and PID=1007) is UNKNOWN in libmtp v1.1.11.
Please report this VID/PID and the device model to the libmtp development team
   Found 1 device(s):
   1f3a:1007 @ bus 1, dev 15
Attempting to connect device(s)
PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device
inep: usb_get_endpoint_status(): Resource temporarily unavailable
outep: usb_get_endpoint_status(): No such device
libusb_open() failed!: No such device
LIBMTP PANIC: Could not init USB on second attempt
Unable to open raw device 0
OK.
bash-4.3$


E MTP connect

Codice: Seleziona tutto

bash-4.3$ mtp-connect
Your system does not appear to have UTF-8 enabled ($LANG="en_US")
If you want to have support for diacritics and Unicode characters,
please switch your locale to an UTF-8 locale, e.g. "en_US.UTF-8".
libmtp version: 1.1.11

Device 0 (VID=1f3a and PID=1007) is UNKNOWN in libmtp v1.1.11.
Please report this VID/PID and the device model to the libmtp development team
PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device
inep: usb_get_endpoint_status(): Resource temporarily unavailable
outep: usb_get_endpoint_status(): No such device
libusb_open() failed!: No such device
LIBMTP PANIC: Could not init USB on second attempt
No devices.
bash-4.3$


Che posso fare?
E sopratutto ammesso di riusciread accedere, è corretto agire con fsck?

Grazie per l'aiuto o anche solo per una indicazione...
Saluti
Michele

Re: Problema con tablet android

Inviato: ven giu 01, 2018 14:59
da ponce
bentornato!
a parte i problemi che hai nel montarlo via mtp (bisogna che il tablet abbia un sistema operativo funzionante che esporti il filesystem interno tramite quel protocollo, e non mi sembra il tuo caso), in ogni caso non puoi fare l'fsck connettendo il device via usb, lo dovresti lanciare probabilmente dal bootloader del tablet in modalita' recovery (se ci fosse installato un bootloader atto allo scopo).
comunque, per essere onesti, non vedo il nesso con Slackware: sicuramente non te lo monta via mtp nemmeno windows...

Re: Problema con tablet android

Inviato: ven giu 01, 2018 17:07
da StormyMonday
No, nemmeno da windows, credi ci sia il modo di recuperarlo o è da buttare?

Re: Problema con tablet android

Inviato: ven giu 01, 2018 17:15
da ponce
sinceramente non ho idea, dovresti cercare supporto dal produttore (o magari qualche forum non ufficiale che pero' si occupi di quei tablet).

Re: Problema con tablet android

Inviato: ven giu 01, 2018 23:30
da erio
prova ad installare android studio se devi vedere dentro al sistema,e se il tablet ha anche la funzione telefono,opzione sviluppatore per il debug via usb,sempre che non sia un problema hardware..