Ancora amarok

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
Lean
Linux 3.x
Linux 3.x
Messaggi: 799
Iscritto il: ven 18 mar 2005, 0:00
Slackware: 12.1
Kernel: 2.6.24.5-smp
Desktop: KDE 3.5.9
Località: Modena - Messina
Contatta:

Ancora amarok

Messaggio da Lean »

Ciao a tutti! Ho problemi con le ultime versioni di amarok (1.3.9 e quella che è uscita oggi nelle news)
In pratica la installo (comprese le dipendenze) e tutto funziona alla perfezione. Il problema nasce quando lo chiudo e apro un altro mp3. Infatti non parte più niente.... noto che nella "process table" è presente amarokapp. Quando killo questo e apro un mp3 amarok riparte regolarmente.
In pratica alla chiusura del programma non viene chiuso anche amarokapp.... qualcuno ha idea??
Noto che quando lo chiudo c'è questo errore...
*** glibc detected *** double free or corruption (!prev): 0x084e4548 ***

Avatar utente
francogdn
Linux 2.x
Linux 2.x
Messaggi: 320
Iscritto il: ven 19 mag 2006, 10:52
Distribuzione: Fedora
Località: Torino

Messaggio da francogdn »

Nello script di avvio prova ad inserire questa variabile d'ambiente:

MALLOC_CHECK_=0

Ciao.

Avatar utente
Lean
Linux 3.x
Linux 3.x
Messaggi: 799
Iscritto il: ven 18 mar 2005, 0:00
Slackware: 12.1
Kernel: 2.6.24.5-smp
Desktop: KDE 3.5.9
Località: Modena - Messina
Contatta:

Messaggio da Lean »

Ummm.. cioè? Spiegati meglio

Avatar utente
francogdn
Linux 2.x
Linux 2.x
Messaggi: 320
Iscritto il: ven 19 mag 2006, 10:52
Distribuzione: Fedora
Località: Torino

Messaggio da francogdn »

Le nuove versioni di glibc eseguono dei controlli per rilevare anticipatamente eventuali corruzioni di dati.

Quello che ti ho suggerito è solo un workaround. Sicuramente le nuove versioni di amaroK non causeranno questo errore, dovuto ad una chiamata errata alla funzione C malloc()...

creati uno script di questo tipo:

#!/bin/bash
export MALLOC_CHECK_=0
/path-to-amarok/amarok

Se imposti a 0 MALLOC_CHECK_, non vedrai l'errore nei log e non verrà terminato il programma. Se imposti 1, vedrai l'errore ma non verrà terminato il programma.

Avatar utente
jacobbe
Linux 0.x
Linux 0.x
Messaggi: 76
Iscritto il: dom 15 mag 2005, 0:00
Slackware: 12.0
Località: Treviso, Padova

Messaggio da jacobbe »

Grande! È un suggerimento eccezionale...
Io dopo i vari aggiornamenti di gcc, libc, ecc.. nella current avevo problemi con diverse app come amsn (compiled from sources).
adesso se lo eseguo con
$ MALLOC_CHECK_=0 amsn

non ho problemi... grazie!

Avatar utente
francogdn
Linux 2.x
Linux 2.x
Messaggi: 320
Iscritto il: ven 19 mag 2006, 10:52
Distribuzione: Fedora
Località: Torino

Messaggio da francogdn »

Prego :)

Ciao.

mangus
Linux 2.x
Linux 2.x
Messaggi: 451
Iscritto il: lun 1 mar 2004, 0:00
Località: Castel de brett!! (bologna)
Contatta:

Messaggio da mangus »

Ma non è il contrario di quello che dice questo file in slackware current?
mangus@saturno:~$ cat /etc/profile.d/glibc.sh
#!/bin/sh
# Set more relaxed (glibc-2.3.5 like) malloc() checking.
#
# This relaxes the default paranoia level so that it reports
# bugs, but does not kill the questionable process. You can
# get away with running broken programs with this setting,
# but at a possible performance and security cost.
#export MALLOC_CHECK_=1
mangus@saturno:~$
:?: :?:

Avatar utente
francogdn
Linux 2.x
Linux 2.x
Messaggi: 320
Iscritto il: ven 19 mag 2006, 10:52
Distribuzione: Fedora
Località: Torino

Messaggio da francogdn »

No, è esattamente quello che ho scritto io qualche post fa.

Se imposti MALLOC_CHECK_=1 "... it reports bugs, but does not kill the questionable process", traducendo: "... riporta il bug (nel log), ma non killa il processo che ne è causa".
Se invece imposti 0, il programma non viene terminato e nei log non comparirà alcuna segnalazione.

Il comportamento di default, se non imposti questa variabile d'ambiente, è terminare il processo e segnalare il bug nel log.

mangus
Linux 2.x
Linux 2.x
Messaggi: 451
Iscritto il: lun 1 mar 2004, 0:00
Località: Castel de brett!! (bologna)
Contatta:

Messaggio da mangus »

giusto , grazie, sempre restando nell' argomento penso, tempo fa avevo inserito in basrc questa variabile
export G_SLICE=always-malloc
per problemi vari con glibc.. oggi l'ho tolta per provare e mi crashava di tutto
kate, kmail e vari..... l'ho subito rimessa... :D
Solo io ho questi problemi o è un aspetto diverso di ciò che si parlava nel topic?
Non è che le glibc presenti in slackware sono un pò vecchie rispetto al software(KDE)
che è in circolazione?
Mah Ciao a tutti!

p.s.
ecco l'errore dei crash
***MEMORY-ERROR***: [12639]: GSlice: failed to allocate 248 bytes (alignment: 256): Invalid argument

Avatar utente
francogdn
Linux 2.x
Linux 2.x
Messaggi: 320
Iscritto il: ven 19 mag 2006, 10:52
Distribuzione: Fedora
Località: Torino

Messaggio da francogdn »

Credo che il tuo problema sia dovuto ad un problema di glib.
Non saprei aiutarti, dato che non mi si è mai presentato, però ho visto che qui sul forum l'argomento è stato trattato incidentalmente...

http://www.slacky.it/forum/viewtopic.ph ... 8e45dba89e


Ciao.

Rispondi