porta 443 aperta

Postate qui per tutte le discussioni legate alla sicurezza di Linux/Slackware

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
Rama
Linux 2.x
Linux 2.x
Messaggi: 324
Iscritto il: sab mar 29, 2008 12:18
Slackware: 14.2 64bit
Kernel: 4.18.9 preemptive
Desktop: KDE 4.14.21
Distribuzione: Debian Stretch
Località: Novara, provincia

porta 443 aperta

Messaggioda Rama » gio gen 18, 2018 12:58

dopo qualche mese ieri ho fatto il controllo delle porte in https://www.grc.com/x/ne.dll?bh0bkyd2 e https://www.yougetsignal.com/tools/open-ports/ e mi risulta aperta la porta 443;
il firewall del router non ha alcuna regola che la riguardi, quindi per default dovrebbe risultare stealth, non open;

il primo sito mi dice:

Solicited TCP Packets: RECEIVED (FAILED) — As detailed in the port report below, one or more of your system's ports actively responded to our deliberate attempts to establish a connection. It is generally possible to increase your system's security by hiding it from the probes of potentially hostile hackers. Please see the details presented by the specific port links below, as well as the various resources on this site, and in our extremely helpful and active user community.

Unsolicited Packets: PASSED — No Internet packets of any sort were received from your system as a side-effect of our attempts to elicit some response from any of the ports listed above. Some questionable personal security systems expose their users by attempting to "counter-probe the prober", thus revealing themselves. But your system remained wisely silent. (Except for the fact that not all of its ports are completely stealthed as shown below.)

Ping Echo: PASSED — Your system ignored and refused to reply to repeated Pings (ICMP Echo Requests) from our server.


dal poco che ci capisco non dovrei preoccuparmi, ma non riesco a capire come mai di punto in bianco la porta risulti aperta;

Avatar utente
conraid
Staff
Staff
Messaggi: 13221
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: porta 443 aperta

Messaggioda conraid » gio gen 18, 2018 13:57

La 443 è https, magari il router ha l'interfaccia aperta con ssl per sicurezza.

Guarda se c'è un opzione per aprire solo da rete locale. Il mio (netgear 834) ce l'ha.

Avatar utente
Rama
Linux 2.x
Linux 2.x
Messaggi: 324
Iscritto il: sab mar 29, 2008 12:18
Slackware: 14.2 64bit
Kernel: 4.18.9 preemptive
Desktop: KDE 4.14.21
Distribuzione: Debian Stretch
Località: Novara, provincia

Re: porta 443 aperta

Messaggioda Rama » gio gen 18, 2018 18:23

all'ultimo controllo, credo fosse dicembre, risultava tutto stealth;
ora ho provato a chiudere la 443: il primo sito la vede ancora aperta, il secondo chiusa;
può influire il nuovo kernel?
più tardi provo a riavviare col precedente e nel caso proverò anche a cambiare router;

EDIT
col vecchio kernel si ha la stessa situazione;
cambiando il router tutto è stealth, non so che pensare, forse il Netgear è andato a ramengo?

Avatar utente
conraid
Staff
Staff
Messaggi: 13221
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: porta 443 aperta

Messaggioda conraid » sab gen 20, 2018 13:15

Rama ha scritto:all'ultimo controllo, credo fosse dicembre, risultava tutto stealth;
ora ho provato a chiudere la 443: il primo sito la vede ancora aperta, il secondo chiusa;
può influire il nuovo kernel?
più tardi provo a riavviare col precedente e nel caso proverò anche a cambiare router;

EDIT
col vecchio kernel si ha la stessa situazione;
cambiando il router tutto è stealth, non so che pensare, forse il Netgear è andato a ramengo?


Il kernel nuovo non c'entra niente, anche perché interessa il router. È lì che devi guardare, e come ti ho detto sembra che sia in ascolto su HTTPS, può essere l'interfaccia di amministrazione del router, anche se solitamente sta in ascolto su porte non standard, devi togliere la possibilità di gestirla in remoto.
Poi magari è aperta ma permette di collegarsi solo a determinati IP, etc... quindi mica è detto che sia un problema. E comunque hai sempre user e password, che sicuramente hai scelto difficili. Insomma, non mi farei tanti problemi, ma al tempo stesso disabiliterei l'opzione.

Sul mio netgear si chiama "gestione remota" l'opzione, e come vedi ha varie opzioni, controlla.
screen75.png
screen75.png (61.16 KiB) Visto 1591 volte


Può anche essere una regola firewall, controlla anche quelle (nel router sempre).

Avatar utente
Rama
Linux 2.x
Linux 2.x
Messaggi: 324
Iscritto il: sab mar 29, 2008 12:18
Slackware: 14.2 64bit
Kernel: 4.18.9 preemptive
Desktop: KDE 4.14.21
Distribuzione: Debian Stretch
Località: Novara, provincia

Re: porta 443 aperta

Messaggioda Rama » sab gen 20, 2018 20:17

ma certo che non ho abilitato la gestione remota, e manco l'UPnP;
forse mi sono spiegato male: non ho toccato le impostazioni del router e fino a dicembre tutto era stealth;
che il kernel non c'entri lo sospettavo, dopotutto l'ho compilato basandomi sul .config del vecchio, però per scrupolo l'ho verificato riavviando col vecchio e la porta risulta aperta;
gli è che con l'altro router (stesse impostazioni, è l'obbrobrio datomi da Wind che ogni tanto per motivi suoi non mi fa navigare, pur asserendo quando faccio il controllo che non ci sono problemi di connessione) risulta tutto stealth;
per questo sospetto che sia colpa del Netgear, magari un bug nell'ultimo aggiornamento;

rik70
Master
Master
Messaggi: 1943
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.2
Kernel: 4.18
Desktop: Xfce 4.12
Distribuzione: archlinux

Re: porta 443 aperta

Messaggioda rik70 » dom gen 21, 2018 16:05

Credo che la faccenda dello "Stealth" dipenda da come sono impostate le regole del firewall nella catena INPUT - prendendo come riferimento un firewall basato su iptables.

Per avere un dispositivo completamente "nascosto" è necessario che i pacchetti che dall'esterno arrivano alla porta wan vengano scartati con un "DROP".

Alcuni però preferiscono impostare un REJECT per evitare che il dispositivo continui a essere interrogato fino a quando la richiesta va in time-out. L'unica conseguenza è che test come quelli descritti sopra - il primo in particolare - falliscono. Ma non c'è assolutamente un problema di sicurezza.

Pertanto, se siete "paranoici" e il firmware del dispositivo lo permette, basta modificare le regole del firewall.