Repository 32bit  Forum
Repository 64bit  Wiki

RISOLTO - stampante hp

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

RISOLTO - stampante hp

Messaggioda ermes » sab nov 21, 2009 16:51

ciao a tutti.
ho cambiato la stampante... presa una hp deskjet f2420.
vado sul sicuro, è una Hp (non ho mai avuto problemi) ho controllato la compatibilità... tutto a posto... e invece no.
uso hp device manager (hp-toolbox) per aggiungere la stampante. In automatica capisce che non ci sono stampanti istallate e mi propone la procedura guidata per l'istallazione.
seguo la procedura ma al secondo passaggio non riesce a trovare nessun device (???)

allora scelgo al possibilità di installare la stampante con CUPS... vede il drive usb: collegato alla stampante e tutto sembra funzionare a dovere... ma poi non stampa... e non compare nemmeno nel hp-toolbox...

ho visto che in altre discussioni si consigliava di ri-avviare il sistema (alla windows)... fatto anche quello... ma niente.
inutile dire che:
- la stampante è collegata correttamente
- è accesa
(sono i due fondamentali consigli trovati nella scatola)
- in windows funziona (sic !!! :oops: )

ho provato a lanciare il comando hp-check e ho ottenuto 5 warnings:
2relativi a dipendenze mancanti:
Codice: Seleziona tutto
Checking for dependency: PolicyKit - Administrative policy framework...
warning: NOT FOUND! This is an OPTIONAL/RUNTIME ONLY dependency. Some HPLIP functionality may not function properly.
Checking for dependency: Reportlab - PDF library for Python...
warning: NOT FOUND! This is an OPTIONAL/RUNTIME ONLY dependency. Some HPLIP functionality may not function properly.


3 relativi al fatto che le stampanti non sono installate con hplip:
Codice: Seleziona tutto
---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
Deskjet_f2420
-------------
Type: Unknown
Device URI: usb://HP/Deskjet%20F2400%20series?serial=CN98K153MF05H4
PPD: /etc/cups/ppd/Deskjet_f2420.ppd                               
PPD Description: HP DeskJet 2000 - CUPS+Gutenprint v5.2.4         
Printer status: printer Deskjet_f2420 is idle.  enabled since Sat 21 Nov 2009 04:17:45 PM CET
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend to function in HPLIP.

Deskjet_f2420_new
-----------------
Type: Unknown   
Device URI: usb://HP/Deskjet%20F2400%20series?serial=CN98K153MF05H4
PPD: /etc/cups/ppd/Deskjet_f2420_new.ppd                           
PPD Description: HP Deskjet f2200 Series hpijs, 3.9.4b             
Printer status: printer Deskjet_f2420_new is idle.  enabled since Sat 21 Nov 2009 04:17:55 PM CET
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend to function in HPLIP.

new
---
Type: Unknown
Device URI: usb://HP/Deskjet%20F2400%20series?serial=CN98K153MF05H4
PPD: /etc/cups/ppd/new.ppd                                         
PPD Description: HP Deskjet f2100 Series hpijs, 3.9.4b             
Printer status: printer new is idle.  enabled since Sat 21 Nov 2009 04:19:55 PM CET


altro non riesco a dirvi se non che non so più cosa fare

grazie in anticipo
Ultima modifica di ermes il mar nov 24, 2009 21:39, modificato 1 volta in totale.
Avatar utente
ermes
Linux 2.4
Linux 2.4
 
Messaggi: 339
Iscritto il: dom feb 20, 2005 0:00
Località: Rho (Mi)
Slackware: current 64
Desktop: kde

Re: stampante hp

Messaggioda 414N » sab nov 21, 2009 17:40

Io ho acquistato di recente una HP PSC4480 e ho avuto un problema simile al tuo, appena installata la stampante.
Ho eseguito la procedura guidata da interfaccia web di CUPS, salvo poi ritrovarmi con la stampante non riconosciuta nel software HP.
L'ho rimossa da CUPS e ho ripetuto la procedura tramite HPLIP e, finalmente, è andato tutto per il verso giusto.
Una cosa che ti consiglio di controllare è se il tuo utente fa parte del gruppo lp: i driver HPLIP lo richiedono.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: stampante hp

Messaggioda phobos3576 » sab nov 21, 2009 18:06

414N ha scritto:Io ho acquistato di recente una HP PSC4480 e ho avuto un problema simile al tuo, appena installata la stampante.
Ho eseguito la procedura guidata da interfaccia web di CUPS, salvo poi ritrovarmi con la stampante non riconosciuta nel software HP.
L'ho rimossa da CUPS e ho ripetuto la procedura tramite HPLIP e, finalmente, è andato tutto per il verso giusto.
Una cosa che ti consiglio di controllare è se il tuo utente fa parte del gruppo lp: i driver HPLIP lo richiedono.


Si, esatto. E' necessario aggiungersi al gruppo LP; successivamente bisogna rimuovere le stampanti installate in precedenza e ripetere poi la procedura usando CUPS e non HPLIP (preferibilmente, da root).

Sulla current non so, ma sulla 13 HPLIP funziona veramente bene; è anche integrato in KDE4 e mostra tutti i messaggi relativi al funzionamento della stampante.
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: stampante hp

Messaggioda ermes » sab nov 21, 2009 23:42

l'utente fa già parte di lp.
quando cerco di installare con il tool hp non trova dispositivi ne driver.

boh !
Avatar utente
ermes
Linux 2.4
Linux 2.4
 
Messaggi: 339
Iscritto il: dom feb 20, 2005 0:00
Località: Rho (Mi)
Slackware: current 64
Desktop: kde

Re: stampante hp

Messaggioda phobos3576 » dom nov 22, 2009 0:17

Non usare HPLIP.

Loggati come root.
Spegni la stampante.
Apri un browser e vai su CUPS.
Rimuovi tutte le stampanti.
Chiudi il browser.
Accendi la stampante e attendi che venga rilevata dal kernel.
Vai di nuovo su CUPS con il browser.
Aggiungi una nuova stampante assicurandoti che CUPS la rilevi automaticamente (HPLIP numero di serie, etc).
Configura la stampante e stampa la pagina di prova.
Torna utente normale.
Se tutto è andato bene, dovresti trovare l'icona HP sulla taskbar (a destra).

Immagine

Da quell'icona (tasto destro del mouse), avvia l'HP Device Manager e controlla se tutto è a posto.
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: stampante hp

Messaggioda ildiama » dom nov 22, 2009 11:38

414N ha scritto:Una cosa che ti consiglio di controllare è se il tuo utente fa parte del gruppo lp: i driver HPLIP lo richiedono.

Ma.. dove l'avete trovata sta cosa? E perché Pat non lo aggiunge nella installazione standard, visto che lo fa per tutti gli altri pacchetti? Lo dico perché io qua non ho nessun gruppo lp (e quindi ovviamente non ne faccio parte), ho installato la mia multifunzione hp tramite hplip (addirittura collegata via wireless) e tutto funziona alla grande: stampa, fax (anche via pc) e scanner. :badgrin: :-k
Avatar utente
ildiama
Linux 2.6
Linux 2.6
 
Messaggi: 536
Iscritto il: mar dic 27, 2005 16:49
Località: Senigallia
Slackware: mine
Kernel: 2.6.alto..
Desktop: KDE4

Re: stampante hp

Messaggioda ermes » dom nov 22, 2009 15:18

anche a me ha funzionato sempre come dice ildiama... solo che ora non funziona più !
ho provato a seguire il consiglio di phobos... ma niente da fare.

da root, installata la stampante, lancio la stampa di prova e non succede niente (anche nel log non risultano errori)... e quando torno utente normale la stampante non esiste e hplip nopn mi da nemmeno la possibilità di installarla.

ri-boh!

rimango in attesa di altre proposte

ciao e grazie
Avatar utente
ermes
Linux 2.4
Linux 2.4
 
Messaggi: 339
Iscritto il: dom feb 20, 2005 0:00
Località: Rho (Mi)
Slackware: current 64
Desktop: kde

Re: stampante hp

Messaggioda phobos3576 » dom nov 22, 2009 16:32

X Ildiama. La questione del gruppo lp riguardava la Slackware 12.2; può darsi che dalla 13 in poi non sia più necessario.

X Ermes. Visto che stai usando la Current, magari potresti aver fatto qualche aggiornamento che crea problemi ad HPLIP.
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: stampante hp

Messaggioda ermes » dom nov 22, 2009 22:45

sto seriamente pensando di ritornare a 13 e poi rifare l'aggiornamento...
mi seccherebbe parecchio però
Avatar utente
ermes
Linux 2.4
Linux 2.4
 
Messaggi: 339
Iscritto il: dom feb 20, 2005 0:00
Località: Rho (Mi)
Slackware: current 64
Desktop: kde

Re: stampante hp

Messaggioda puzuma » lun nov 23, 2009 14:32

ho avuto anch'io problemi simili con una multifunzione HP.

Prima della slack 13 per far funzionare correttamente hplip dovevi avviare i vari programmi specificando un locale diverso da quello standard:

Codice: Seleziona tutto
LC_ALL=$LANG.UTF8 hp-toolbox


fatto questo la stampante viene ricosciuta correttamente. Però poi non stampa :-(

Questo perché con le multifunzione c'è un secondo problema (presente anche nella 13 e nella current): udev la riconosce come scanner e le regole di sane reimpostano i permessi del device in modo da renderlo invisibile ad hplip. il modo per risolvere il problema è di modificare le regole di udev. Adesso non ho la slack sotto mano e non mi ricordo il file, ma non è difficile da rintraciare se cerchi l'ID della stampante tra i file udev installati da sane.
The quiet ones are the ones who change the world. The loud ones only take the credit.
Avatar utente
puzuma
Linux 2.4
Linux 2.4
 
Messaggi: 481
Iscritto il: mar lug 04, 2006 16:14
Località: Udine
Nome Cognome: Stefano Salvador
Slackware: current
Kernel: 2.6.32.2
Desktop: KDE 4.4.0

Re: stampante hp

Messaggioda phobos3576 » lun nov 23, 2009 22:14

puzuma ha scritto:Questo perché con le multifunzione c'è un secondo problema (presente anche nella 13 e nella current): udev la riconosce come scanner e le regole di sane reimpostano i permessi del device in modo da renderlo invisibile ad hplip. il modo per risolvere il problema è di modificare le regole di udev. Adesso non ho la slack sotto mano e non mi ricordo il file, ma non è difficile da rintraciare se cerchi l'ID della stampante tra i file udev installati da sane.


Probabilmente, nel caso delle HP multifunzione (complete quindi anche di scanner), è importante editare il file /etc/sane.d/dll.conf, commentare tutto tranne la riga hpaio e riavviare HAL e UDEV.

Se si ha la necessità di condividere lo scanner in una rete di computer, è necessario decommentare anche la prima riga net.
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: stampante hp

Messaggioda ermes » mar nov 24, 2009 13:42

grazie
questa sera proverò a pasticciare un po' e poi farò sapere

per ora grazie
Avatar utente
ermes
Linux 2.4
Linux 2.4
 
Messaggi: 339
Iscritto il: dom feb 20, 2005 0:00
Località: Rho (Mi)
Slackware: current 64
Desktop: kde

Re: stampante hp

Messaggioda 414N » mar nov 24, 2009 15:09

Ho controllato or ora il sito HPLIP per vedere la compatibilità con la tua stampante e la versione minima di hplip richiesta.
A quanto sembra, la versione minima richiesta è la 3.9.10, mentre la Slackware 13.0 include la 3.9.4b.
Secondo me dovresti aggiornare hplip, magari usando lo Slackbuild di Pat usato per produrre il pacchetto della 13 (dovrebbe bastare cambiare la sola versione).
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: stampante hp

Messaggioda ermes » mar nov 24, 2009 21:20

Bingo !!!
avevo guardato che la stampante fosse supportata ma non da quale versione di Hplip.

grazie a tutti ;)
Avatar utente
ermes
Linux 2.4
Linux 2.4
 
Messaggi: 339
Iscritto il: dom feb 20, 2005 0:00
Località: Rho (Mi)
Slackware: current 64
Desktop: kde


Torna a Slackware

Chi c’è in linea

Visitano il forum: Exabot [Bot] e 3 ospiti