Slack 14 & Gnome

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
mr.simo
Linux 1.x
Linux 1.x
Messaggi: 107
Iscritto il: dom 1 nov 2009, 2:17
Nome Cognome: oxsimo

Slack 14 & Gnome

Messaggio da mr.simo »

Un saluto a tutti gli utenti,

Ho una piccola domanda da fare. :)

Ho visto che il progetto GSlacky è fermo da un pò, e facendo una ricerca nei repo di Slackware 14 per "gnome" vedo che sono disponibili i pacchetti:


gnome-common - 3.6.0
gnome-desktop - 3.4.2
gnome-js-common - 0.1.2
gnome-mime-data - 2.18.0
gnome-python-keyring - 2.32.0
gnome-vfs - 2.24.4
gnome-video-effects - 0.4.0
libgnome-media-profiles - 3.0.0
libgnomecanvas - 2.30.3
libgnomecanvasmm - 2.26.0

Da qui: http://www.slacky.eu/asche/pkgs/index.p ... ome&ver=16

Suppongo che i pacchetti necessari da installare per avere Gnome funzionante siano quelli in grassetto giusto?
Oppure me ne sto dimenticando qualcuno?

Grazie mille in anticipo!

:wave:

Avatar utente
ZeroUno
Staff
Staff
Messaggi: 5305
Iscritto il: ven 2 giu 2006, 14:52
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current
Località: Roma / Castelli
Contatta:

Re: Slack 14 & Gnome

Messaggio da ZeroUno »

gsb
ftp.osuosl.org/pub/gsb/
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg

Codice: Seleziona tutto

1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111

Avatar utente
mr.simo
Linux 1.x
Linux 1.x
Messaggi: 107
Iscritto il: dom 1 nov 2009, 2:17
Nome Cognome: oxsimo

Re: Slack 14 & Gnome

Messaggio da mr.simo »

ZeroUno ha scritto:GSB
Ciao ZeroUno, tu mi consigli di installare Gnome SlackBuild, però la versione più recente risulta essere la gsb-3.2_slackware-13.37 mentre io ho una S14.

Però se mi dici che funziona benone lo installo. :p

miklos
Master
Master
Messaggi: 1540
Iscritto il: lun 16 lug 2007, 17:39
Slackware: 14.1 64bit
Kernel: 3.16.3
Desktop: openbox 3.5.2
Località: Roma

Re: Slack 14 & Gnome

Messaggio da miklos »

io te lo sconsiglio invece, o comunque è una cosa che dovresti affrontare non alla leggera perchè alcuni pacchetti che nella 13.37 non c'erano e quindi per usare gnome si installavano a parte ora sono nella versione ufficiale (la 14 appunto)
purtroppo al momento i precompilati per gnome (tipo quello che ti ha suggerito zerouno) sono in una fase di abbandono/stallo perchè comunque compilare gnome è una bella rogna, quindi in questo momento gnome 3 purtroppo è uno di quei software difficili da usare su slackware :(
ho visto cose che voi astemi non potete immaginare
https://github.com/ilmich

miklos
Master
Master
Messaggi: 1540
Iscritto il: lun 16 lug 2007, 17:39
Slackware: 14.1 64bit
Kernel: 3.16.3
Desktop: openbox 3.5.2
Località: Roma

Re: Slack 14 & Gnome

Messaggio da miklos »

t'ho detto na fesseria... installa questo
ho visto cose che voi astemi non potete immaginare
https://github.com/ilmich

Avatar utente
mr.simo
Linux 1.x
Linux 1.x
Messaggi: 107
Iscritto il: dom 1 nov 2009, 2:17
Nome Cognome: oxsimo

Re: Slack 14 & Gnome

Messaggio da mr.simo »

Ciao miklos,

Grazie anche a te, però la versione di dropline è per Slackware 13.1.
miklos ha scritto: comunque è una cosa che dovresti affrontare non alla leggera perchè alcuni pacchetti che nella 13.37 non c'erano e quindi per usare gnome si installavano a parte ora sono nella versione ufficiale (la 14 appunto)
In questo caso si potrebbe cercare quali sono questi pacchetti e modificare l'installer (se possibile). :-k

Avatar utente
hashbang
Packager
Packager
Messaggi: 1984
Iscritto il: ven 4 giu 2010, 10:27
Nome Cognome: Luca De Pandis
Distribuzione: macOS | OpenBSD
Località: Lecce / Bergamo
Contatta:

Re: Slack 14 & Gnome

Messaggio da hashbang »

mr.simo ha scritto:Ciao miklos,

Grazie anche a te, però la versione di dropline è per Slackware 13.1.
No.
Dropline fornisce GNOME 3.6 e 3.8 per Slackware 14.0
http://www.droplinegnome.org/files/

Se non ricordo male basta installare il pacchetto dropline-installer. Il resto dovrebbe essere automatico.
k8s | rook | flatcar | cert-manager | calico

Codice: Seleziona tutto

host$ kubectl get packager/hashbang -n slacky -o yaml

Avatar utente
ZeroUno
Staff
Staff
Messaggi: 5305
Iscritto il: ven 2 giu 2006, 14:52
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current
Località: Roma / Castelli
Contatta:

Re: Slack 14 & Gnome

Messaggio da ZeroUno »

sorry, ho postato velocemente, non avevo visto che non c'era gsb per la 14
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg

Codice: Seleziona tutto

1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111

Avatar utente
mr.simo
Linux 1.x
Linux 1.x
Messaggi: 107
Iscritto il: dom 1 nov 2009, 2:17
Nome Cognome: oxsimo

Re: Slack 14 & Gnome

Messaggio da mr.simo »

No pasa nada. ;)

Grazie a tutti per i consigli.

:wave:

Rispondi