Test di auricolare con microfono

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2561
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.0
Kernel: 3.19.4-hb_smp
Desktop: KDE-4.8.5

Test di auricolare con microfono

Messaggioda joe » mer ago 14, 2013 13:51

Sto tentando di far funzionare un vecchio auricolare dotato di microfono..
È collegato al PC attraverso due mini-jack che si connettono frontalmente negli appositi fori posti frontalmente sul case.

Ho visto in rete che il test più semplice consiste nel lanciare:

Codice: Seleziona tutto

arecord|aplay

e quindi parlando nel microfono si dovrebbe sentire la voce in cuffia.
Ho provato ma non sento niente.
Altra prova:

Codice: Seleziona tutto

arecord -d10 mictest.wav

questo registrerebbe su un file 10 secondi di ripresa microfonica.
Riascoltando il file sia con aplay che con mplayer non sento nulla.

Mi dareste una mano per fare altri tentativi?
Qualcuno mi aveva suggerito Pulse Audio, ma prima volevo fare ancora qualche tentativo.
Anche perchè l'auricolare non è nuovo ma lo uso da anni, solo per l'uscita audio, mai il microfono... Quindi prima di tutto devo accertarmi che il microfono sia funzionante.

Vi ringrazio in anticipo! :D

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2561
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.0
Kernel: 3.19.4-hb_smp
Desktop: KDE-4.8.5

Re: Test di auricolare con microfono

Messaggioda joe » mer ago 14, 2013 19:03

Ok, sembra funzionare in qualche modo col comando seguente:

Codice: Seleziona tutto

arecord -fS16_LE -r44100 -traw -c1 testmic.wav

e per riascoltare la registrazione:

Codice: Seleziona tutto

aplay -fS16_LE -r44100 -traw -c1 --disable-softvol testmic.wav

Però...
riascoltando la registrazione con aplay il volume della mia voce è molto basso eppure ho parlato normalmente.
Come fare per riprodurlo il più possibile fedele al volume della mia voce?

rik70
Master
Master
Messaggi: 1704
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: 4.0.x-smp
Desktop: Xfce 4.12

Re: Test di auricolare con microfono

Messaggioda rik70 » ven ago 16, 2013 11:55

Ciao,

ma intendi dire che il volume del microfono è troppo basso o ....?

Se è buona la prima, hai provato con alsamixer ha sollevare il cursore del microfono dalla sezione "capture"?

Codice: Seleziona tutto

alsamixer -V capture


Con alcune schede audio è disponibile anche l'interrutore mic boost. Questo di solito è nella sezione playback e può aiutare.

Altro non mi viene in mente.

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2561
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.0
Kernel: 3.19.4-hb_smp
Desktop: KDE-4.8.5

Re: Test di auricolare con microfono

Messaggioda joe » sab ago 17, 2013 10:22

Sì alzando il "capture" la situazione migliora anche se si aggiunge un "rumore di fondo".
Penso che alla fine si tratti semplicemente di regolare da alsamixer i parametri del capture.
Aggiungendo il boost del microfono il rumore di fondo aumenta troppo e anche la voce riprodotta assume una certa distorsione.
Farò altre prove...
Se vi viene in mente qualche altro consiglio dite pure.
Grazie per le risposte intanto.

rik70
Master
Master
Messaggi: 1704
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: 4.0.x-smp
Desktop: Xfce 4.12

Re: Test di auricolare con microfono

Messaggioda rik70 » sab ago 17, 2013 11:46

joe ha scritto:Sì alzando il "capture" la situazione migliora anche se si aggiunge un "rumore di fondo".


E' normale, o meglio lo è quando il microfono è di scarsa qualità - come nel 90% dei casi.


Torna a “Gnu/Linux in genere”

Chi c’è in linea

Visitano il forum: Nessuno e 12 ospiti