Aggiornamento KDE 3.2.2

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
F4B1CK
Linux 2.x
Linux 2.x
Messaggi: 264
Iscritto il: dom 11 gen 2004, 0:00
Slackware: current 64 bit
Kernel: 4.4.x
Desktop: KDE 5
Località: Cosenza
Contatta:

Aggiornamento KDE 3.2.2

Messaggio da F4B1CK »

Ho scaricato il pacchetto contenente tutti gli aggiornamenti dal sito, ma ho riscontrato notevoli problemi, quindi se qulacuno può aiutarmi...
<BR>Li elenco, descrivendo come li ho risolti, e poi elenco cosa non ho risolto :
<BR>
<BR>1 - dopo aver scompattato e lanciato il comando :
<BR> upgradepkg --install-new *.tgz
<BR> per alcuni pachetti compariva un warning di ldconfig :
<BR> /sbin/ldconfig : kcm_fontinst.so non è un link dinamico
<BR>Soluzione : ho duplicato i file kcm_fontinst.* nei corrispettivi libkcm_fontinst.* (richiesti anche dal pannello di controllo) e poi ho linkato il file libkcm_fontinst.so cno kcm_fontinst.so
<BR>
<BR>2 - all´avvio di startx mi richiedeva la libreria libxinerama.so.1 che non era presente sul mio sitema (ho XFree 4.3.0). L´ho linkata dinamicamente con il comando ld (come descritto in un´altro post) ed ho creato il collegamento.
<BR>
<BR>3 - Sorpresa !! Avvio KDM che parte, ma non riesce a lanciare il server grafico scelto. Inserisco nome utente e password ed invece di lanciare KDE,Gnome,Xfce e compagnia bella mi resetta il server X e riparte con kdm. Come risolvo ?? Soprattutto, come vedo cosa combina ?
<BR>
<BR>4 - Se avvio kde a manina (startx) parte, solo che per qualche strano problema paragnostico, mancano, nel seguente ordine :
<BR> sfondo del desktop
<BR> icone posizionate da me ed icone di deafult (niente icone,insomma)
<BR> qualsiasi tasto del mouse premo, non ho nessun effetto (no menù)
<BR>
<BR>Come risolvo ? non ho capito cosa manca...
<BR>
<BR>5 - Ancora, mancano le altre due librerie :
<BR> libkcm_input.la (config. mouse da KDE Start Center)
<BR> libkcm_keyboard.la (conf. della tastiera da KDE Start Center)<br>

king_fesen
Linux 0.x
Linux 0.x
Messaggi: 12
Iscritto il: ven 26 mar 2004, 0:00

Aggiornamento KDE 3.2.2

Messaggio da king_fesen »

io ho provato kde 3.2.2, l´ho installata con il megapacchettone e dopo aver fatto i due link dinamici (spiegati in un altra discussione) ho avviato X e funziona tutto il problema nasce dal fatto che ha qualche baco....
<BR>Per quanto mi riguarda ti conviene tenere la 3.2.1 o 3.2.0<br>

F4B1CK
Linux 2.x
Linux 2.x
Messaggi: 264
Iscritto il: dom 11 gen 2004, 0:00
Slackware: current 64 bit
Kernel: 4.4.x
Desktop: KDE 5
Località: Cosenza
Contatta:

Aggiornamento KDE 3.2.2

Messaggio da F4B1CK »

Posso passare alla versione 3.2.1 dalla 3.2.2 senza problemi di sorta ? Se si, come faccio ad installare senza i soliti casini di librerie e/o link sparsi ? Attenzione : io ho installato la 3.2.2 direttamente dalla 3.1.4.<br>

king_fesen
Linux 0.x
Linux 0.x
Messaggi: 12
Iscritto il: ven 26 mar 2004, 0:00

Aggiornamento KDE 3.2.2

Messaggio da king_fesen »

certo basta che rimuovi tutti i pacchetti di kde 3.2.2 e installi quelli della 3.2.1.
<BR>Sai come fare???<br>

Avatar utente
useless
Staff
Staff
Messaggi: 3896
Iscritto il: dom 12 ott 2003, 0:00
Località: A place where the streets have no name
Contatta:

Aggiornamento KDE 3.2.2

Messaggio da useless »

x "disaggiornare" kde dal 322 al 321 puoi usare il solito upgradepkg, comunque prima di fare questo prova ad aggiornare anche X al 4.4.<br>

Rispondi